aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-03-22 09:31:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-03-22 09:31:00 +0000
commit1fca8a5759c4d2a2cbce06dbd5d8b28a0fa11b5c (patch)
tree550c9ee0e964c663d04ffa2ee86a4c6ef71b15f3
parent63b79a4032c1ebe389908cba5e47ca366dc92d70 (diff)
downloadalpine_aports-1fca8a5759c4d2a2cbce06dbd5d8b28a0fa11b5c.tar.bz2
alpine_aports-1fca8a5759c4d2a2cbce06dbd5d8b28a0fa11b5c.tar.xz
alpine_aports-1fca8a5759c4d2a2cbce06dbd5d8b28a0fa11b5c.zip
testing/perl-module-implementation: new aport
Loads one of several alternate underlying implementations for a module http://search.cpan.org/dist/Module-Implementation/
-rw-r--r--testing/perl-module-implementation/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/perl-module-implementation/APKBUILD b/testing/perl-module-implementation/APKBUILD
new file mode 100644
index 0000000000..456b76fcdd
--- /dev/null
+++ b/testing/perl-module-implementation/APKBUILD
@@ -0,0 +1,39 @@
1# Automatically generated by apkbuild-cpan, template 1
2# Contributor:
3# Maintainer:
4pkgname=perl-module-implementation
5_pkgreal=Module-Implementation
6pkgver=0.06
7pkgrel=0
8pkgdesc="Loads one of several alternate underlying implementations for a module"
9url="http://search.cpan.org/dist/Module-Implementation/"
10arch="noarch"
11license="Artistic-2"
12cpandepends="perl-try-tiny perl-module-runtime"
13cpanmakedepends=" perl-test-fatal perl-test-requires "
14depends="$cpandepends"
15makedepends="perl-dev $cpanmakedepends"
16subpackages="$pkgname-doc"
17source="http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/$_pkgreal-$pkgver.tar.gz"
18
19_builddir="$srcdir/$_pkgreal-$pkgver"
20
21prepare() {
22 cd "$_builddir"
23 export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
24 PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
25}
26
27build() {
28 cd "$_builddir"
29 export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
30 make && make test
31}
32
33package() {
34 cd "$_builddir"
35 make DESTDIR="$pkgdir" install || return 1
36 find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
37}
38
39md5sums="748f3540162fc52222d761fab3efb266 Module-Implementation-0.06.tar.gz"