aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-03-22 09:19:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-03-22 09:19:16 +0000
commit44c3a035be2c788273cb5c2e43f73cabaf2cac22 (patch)
tree5c0a0086feaf91c8a169b490c4864af56299f0da
parentc9f07547a4942c979145c47daa0f2ec76ce4c722 (diff)
downloadalpine_aports-44c3a035be2c788273cb5c2e43f73cabaf2cac22.tar.bz2
alpine_aports-44c3a035be2c788273cb5c2e43f73cabaf2cac22.tar.xz
alpine_aports-44c3a035be2c788273cb5c2e43f73cabaf2cac22.zip
main/iproute2: upgrade to 3.2.0
-rw-r--r--main/iproute2/APKBUILD12
-rw-r--r--main/iproute2/remove-libnl-headers.patch31
2 files changed, 38 insertions, 5 deletions
diff --git a/main/iproute2/APKBUILD b/main/iproute2/APKBUILD
index 5940545e84..11bb97a941 100644
--- a/main/iproute2/APKBUILD
+++ b/main/iproute2/APKBUILD
@@ -1,17 +1,18 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=iproute2 2pkgname=iproute2
3pkgver=2.6.38 3pkgver=3.2.0
4_realver=$pkgver 4_realver=$pkgver
5pkgrel=1 5pkgrel=0
6pkgdesc="IP Routing Utilities" 6pkgdesc="IP Routing Utilities"
7url="http://www.linux-foundation.org/en/Net:Iproute2" 7url="http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2"
8arch="all" 8arch="all"
9license="GPL2" 9license="GPL2"
10depends= 10depends=
11install="$pkgname.post-install" 11install="$pkgname.post-install"
12makedepends="bison flex bash" 12makedepends="bison flex bash"
13subpackages="$pkgname-doc" 13subpackages="$pkgname-doc"
14source="http://devresources.linux-foundation.org/dev/iproute2/download/$pkgname-$_realver.tar.bz2 14source="http://kernel.org/pub/linux/utils/net/iproute2/iproute2-$pkgver.tar.xz
15 remove-libnl-headers.patch
15 " 16 "
16 17
17prepare() { 18prepare() {
@@ -39,4 +40,5 @@ package() {
39 make -j1 DESTDIR="$pkgdir" install 40 make -j1 DESTDIR="$pkgdir" install
40} 41}
41 42
42md5sums="a243bfea837e71824b7ca26c3bb45fa8 iproute2-2.6.38.tar.bz2" 43md5sums="6f814291cc3d7f4312cf8c2c052da5f1 iproute2-3.2.0.tar.xz
4463c85514579652f7912f240234d6d4b4 remove-libnl-headers.patch"
diff --git a/main/iproute2/remove-libnl-headers.patch b/main/iproute2/remove-libnl-headers.patch
new file mode 100644
index 0000000000..921e1fa82e
--- /dev/null
+++ b/main/iproute2/remove-libnl-headers.patch
@@ -0,0 +1,31 @@
1From 13603f6a9e46f08576f6284a0ef1ce1fbf94ffe0 Mon Sep 17 00:00:00 2001
2From: Stephen Hemminger <shemminger@vyatta.com>
3Date: Tue, 10 Jan 2012 08:50:49 -0800
4Subject: [PATCH] iplt2p: remove unused libnl headers
5
6Leftover from change to original code.
7---
8 ip/ipl2tp.c | 7 -------
9 1 files changed, 0 insertions(+), 7 deletions(-)
10
11diff --git a/ip/ipl2tp.c b/ip/ipl2tp.c
12index 042ddb4..97f98b6 100644
13--- a/ip/ipl2tp.c
14+++ b/ip/ipl2tp.c
15@@ -23,13 +23,6 @@
16 #include <linux/if_arp.h>
17 #include <linux/ip.h>
18
19-#include <netlink/netlink.h>
20-#include <netlink/genl/genl.h>
21-#include <netlink/genl/family.h>
22-#include <netlink/genl/mngt.h>
23-#include <netlink/genl/ctrl.h>
24-#include <netlink/utils.h>
25-
26 #include <linux/genetlink.h>
27 #include <linux/l2tp.h>
28
29--
301.7.6.5
31