aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-09-09 12:59:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-09 13:00:10 +0000
commit055b0b5c6a2dd7029080cb3d2d4e49aaffe6c5f2 (patch)
tree08ca710faaeb8695d10cb42b43d45bde40e767fe
parent3da4e720e4b7fa886951f4e2f540bab2b4c437af (diff)
downloadalpine_aports-055b0b5c6a2dd7029080cb3d2d4e49aaffe6c5f2.tar.bz2
alpine_aports-055b0b5c6a2dd7029080cb3d2d4e49aaffe6c5f2.tar.xz
alpine_aports-055b0b5c6a2dd7029080cb3d2d4e49aaffe6c5f2.zip
testing/uwsgi: upgrade to 1.9.15 and switch to Lua 5.2
-rw-r--r--testing/uwsgi/APKBUILD25
-rw-r--r--testing/uwsgi/futimes.patch22
-rw-r--r--testing/uwsgi/include-sched.patch8
-rw-r--r--testing/uwsgi/lua-cache-update.patch45
4 files changed, 7 insertions, 93 deletions
diff --git a/testing/uwsgi/APKBUILD b/testing/uwsgi/APKBUILD
index 556a9b13d1..531daec308 100644
--- a/testing/uwsgi/APKBUILD
+++ b/testing/uwsgi/APKBUILD
@@ -1,16 +1,15 @@
1# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi> 1# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
2# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 2# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
3pkgname=uwsgi 3pkgname=uwsgi
4pkgver=1.4.8 4pkgver=1.9.15
5pkgrel=3 5pkgrel=0
6pkgdesc="uWSGI application container server" 6pkgdesc="uWSGI application container server"
7url=http://projects.unbit.it/uwsgi/ 7url=http://projects.unbit.it/uwsgi/
8arch=all 8arch=all
9license=GPL-2 9license=GPL-2
10makedepends="linux-headers lua-dev python python-dev zeromq-dev paxctl" 10makedepends="linux-headers lua5.2-dev python python-dev zeromq-dev paxctl"
11subpackages="uwsgi-lua uwsgi-python:py" 11subpackages="uwsgi-lua uwsgi-python:py"
12source="http://projects.unbit.it/downloads/uwsgi-${pkgver}.tar.gz 12source="http://projects.unbit.it/downloads/uwsgi-${pkgver}.tar.gz
13 futimes.patch include-sched.patch lua-cache-update.patch
14 uwsgi.initd uwsgi.confd 13 uwsgi.initd uwsgi.confd
15 " 14 "
16 15
@@ -33,7 +32,7 @@ build() {
33 python uwsgiconfig.py --build core || return 1 32 python uwsgiconfig.py --build core || return 1
34 33
35 msg "building lua plugin" 34 msg "building lua plugin"
36 UWSGICONFIG_LUALIB="lua" \ 35 UWSGICONFIG_LUAPC="lua5.2" \
37 python uwsgiconfig.py --plugin plugins/lua core || return 1 36 python uwsgiconfig.py --plugin plugins/lua core || return 1
38 37
39 msg "building python plugin" 38 msg "building python plugin"
@@ -62,7 +61,6 @@ package() {
62 61
63lua() { 62lua() {
64 depends=uwsgi 63 depends=uwsgi
65
66 mkdir -p "$subpkgdir"/usr/lib/uwsgi 64 mkdir -p "$subpkgdir"/usr/lib/uwsgi
67 mv "$pkgdir/usr/lib/uwsgi/lua_plugin.so" "$subpkgdir/usr/lib/uwsgi" 65 mv "$pkgdir/usr/lib/uwsgi/lua_plugin.so" "$subpkgdir/usr/lib/uwsgi"
68} 66}
@@ -74,21 +72,12 @@ py() {
74 mv "$pkgdir/usr/lib/uwsgi/python_plugin.so" "$subpkgdir/usr/lib/uwsgi" 72 mv "$pkgdir/usr/lib/uwsgi/python_plugin.so" "$subpkgdir/usr/lib/uwsgi"
75} 73}
76 74
77md5sums="10af354eccaae9c447bd5bdc69bcce12 uwsgi-1.4.8.tar.gz 75md5sums="e2a1c245e0b8b7e3c8dff8dbbfca52f3 uwsgi-1.9.15.tar.gz
782c9aeb5b2adf1fa45ef4ed6bda47236a futimes.patch
7902c43e001d5f44eb421079e17f9db003 include-sched.patch
803bba1063b54043561f520d6986e35057 lua-cache-update.patch
818a8be061d7b5f3108a0f16813da68389 uwsgi.initd 768a8be061d7b5f3108a0f16813da68389 uwsgi.initd
823d6afe6a8c52556d1d6c52384fc38d9a uwsgi.confd" 773d6afe6a8c52556d1d6c52384fc38d9a uwsgi.confd"
83sha256sums="3c35893927a065ed89775cf5a8f66f66d71b060618f4611efbcca76e520aac37 uwsgi-1.4.8.tar.gz 78sha256sums="87a9dba42df4344dab001ed9f14ad3176977367905dbf9524d18c3808c0e17af uwsgi-1.9.15.tar.gz
849ad8375325195e577e6b91a1cf7539817b58fbb4efef248d01a4b704a0e8749f futimes.patch
8525cb58a02a9f1f62be227592a31152e960f51d44a9e9d14751375a9468152e90 include-sched.patch
86fe79c823399c750618572531e8c9ccfa2394da329ce16516af79887f493c1a2d lua-cache-update.patch
8758b998b025e4a9df20ca917bc93e287f9a8cf02d278d513fa461f70e1d08f799 uwsgi.initd 7958b998b025e4a9df20ca917bc93e287f9a8cf02d278d513fa461f70e1d08f799 uwsgi.initd
884cb047e311aecd0f498da1d6a4c0947dd6dc7cc98575d54cb2ef150cacf8425c uwsgi.confd" 804cb047e311aecd0f498da1d6a4c0947dd6dc7cc98575d54cb2ef150cacf8425c uwsgi.confd"
89sha512sums="7ead90c0740db0ebc28256b312a98e8de610b62cc82504c738cc2f3d2b0819ae673eb1875ea31abc3e511dc76db9af9fb15f4d1ae2a62f6b67b2a5966cfe2bab uwsgi-1.4.8.tar.gz 81sha512sums="f845dc85c270caa4599f3f7c7be57848ebbb3dcbd69b0089674fcba42773cb1b4b2516315e09eb75832529c12c727135dbf54b88714e942a5274da01b27b19b8 uwsgi-1.9.15.tar.gz
909e867a3483197adb5ab99334d0e9f092dab44201ddbead99a4649309fd0584e6793531a147e096459984d26d0a73754688426df1fb4686c041d3889f3d29fdef futimes.patch
91d454dcc5ee0a121ff44584e0da98055e6596e8a750315fe4ce6a5fbc615697b2a19b9b32c51ac9878587a855ec3f072e87a3e4e097a8b743699f58ed0d84ec0f include-sched.patch
92baf97b56448c8a38334036b11c4fb36805ccfb3b867443afe3b1ee5b91bf10981d61f690184e51fa9e492b6318b657530e2f3f11d803dce17cef1a16c56719ab lua-cache-update.patch
93ab9dc6277bd05821287f6f8beb3ac2504f0e41db38e11b4d2884ac026f14ac7bfaaca138f045afa712d4f2843f94de105bf0d43fad35d18679ac33b507cd187e uwsgi.initd 82ab9dc6277bd05821287f6f8beb3ac2504f0e41db38e11b4d2884ac026f14ac7bfaaca138f045afa712d4f2843f94de105bf0d43fad35d18679ac33b507cd187e uwsgi.initd
949f00afb2aa574bbc59040f945475712b8c40da0c06eeb5699de5510aa116148e35ab0429fa891084cf0cd7868876d5a80e1601b7c85d0e2e9ea2a1f54cdde619 uwsgi.confd" 839f00afb2aa574bbc59040f945475712b8c40da0c06eeb5699de5510aa116148e35ab0429fa891084cf0cd7868876d5a80e1601b7c85d0e2e9ea2a1f54cdde619 uwsgi.confd"
diff --git a/testing/uwsgi/futimes.patch b/testing/uwsgi/futimes.patch
deleted file mode 100644
index 79b525fa06..0000000000
--- a/testing/uwsgi/futimes.patch
+++ /dev/null
@@ -1,22 +0,0 @@
1--- uwsgi-1.3/core/spooler.c
2+++ uwsgi-1.3.alpine/core/spooler.c
3@@ -223,15 +223,15 @@
4 }
5
6 if (at > 0) {
7- struct timeval tv[2];
8+ struct timespec tv[2];
9 tv[0].tv_sec = at;
10- tv[0].tv_usec = 0;
11+ tv[0].tv_nsec = 0;
12 tv[1].tv_sec = at;
13- tv[1].tv_usec = 0;
14+ tv[1].tv_nsec = 0;
15 #ifdef __sun__
16 if (futimesat(fd, NULL, tv)) {
17 #else
18- if (futimes(fd, tv)) {
19+ if (futimens(fd, tv)) {
20 #endif
21 uwsgi_error("futimes()");
22 }
diff --git a/testing/uwsgi/include-sched.patch b/testing/uwsgi/include-sched.patch
deleted file mode 100644
index 914296597b..0000000000
--- a/testing/uwsgi/include-sched.patch
+++ /dev/null
@@ -1,8 +0,0 @@
1--- uwsgi-1.3/core/utils.c
2+++ uwsgi-1.3.alpine/core/utils.c
3@@ -1,3 +1,5 @@
4+#include <sched.h>
5+
6 #include "uwsgi.h"
7
8
diff --git a/testing/uwsgi/lua-cache-update.patch b/testing/uwsgi/lua-cache-update.patch
deleted file mode 100644
index 6943a97c9a..0000000000
--- a/testing/uwsgi/lua-cache-update.patch
+++ /dev/null
@@ -1,45 +0,0 @@
1--- uwsgi-1.4.3/plugins/lua/lua_plugin.c
2+++ uwsgi-1.4.3.new/plugins/lua/lua_plugin.c
3@@ -157,6 +157,34 @@
4
5 }
6
7+static int uwsgi_api_cache_update(lua_State *L) {
8+
9+ int args = lua_gettop(L);
10+ const char *key ;
11+ const char *value ;
12+ uint64_t expires = 0;
13+ size_t vallen;
14+
15+
16+ if (args > 1) {
17+
18+ key = lua_tolstring(L, 1, NULL);
19+ value = lua_tolstring(L, 2, &vallen);
20+ if (args > 2) {
21+ expires = lua_tonumber(L, 3);
22+ }
23+
24+ uwsgi_cache_set((char *)key, strlen(key), (char *)value,
25+ (uint16_t) vallen, expires,
26+ UWSGI_CACHE_FLAG_UPDATE);
27+
28+ }
29+
30+ lua_pushnil(L);
31+ return 1;
32+
33+}
34+
35 static int uwsgi_api_register_signal(lua_State *L) {
36
37 int args = lua_gettop(L);
38@@ -298,6 +326,7 @@
39 {"send_message", uwsgi_api_send_message},
40 {"cache_get", uwsgi_api_cache_get},
41 {"cache_set", uwsgi_api_cache_set},
42+ {"cache_update", uwsgi_api_cache_update},
43 {"register_signal", uwsgi_api_register_signal},
44 {"register_rpc", uwsgi_api_register_rpc},
45 {NULL, NULL}