aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Kilar <pkilar@gmail.com>2013-09-09 13:58:49 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-10 06:08:18 +0000
commitfc47fa246da5be9e81eac59ea90751aa75fd14ed (patch)
treef01be624fb3255ce8944ffe1253e551acc8240db
parent98f029bc25be56c518dc3920888fe7aa73c3551e (diff)
downloadalpine_aports-fc47fa246da5be9e81eac59ea90751aa75fd14ed.tar.bz2
alpine_aports-fc47fa246da5be9e81eac59ea90751aa75fd14ed.tar.xz
alpine_aports-fc47fa246da5be9e81eac59ea90751aa75fd14ed.zip
testing/py-bottle: new aport http://bottlepy.org/ Fast and simple WSGI-framework for small web-applications.
-rw-r--r--testing/py-bottle/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/py-bottle/APKBUILD b/testing/py-bottle/APKBUILD
new file mode 100644
index 0000000000..d299e629bb
--- /dev/null
+++ b/testing/py-bottle/APKBUILD
@@ -0,0 +1,39 @@
1# Contributor: Paul Kilar <pkilar@gmail.com>
2# Maintainer: Paul Kilar <pkilar@gmail.com>
3pkgname=py-bottle
4pkgver='0.11.6'
5pkgrel=0
6pkgdesc="Bottle is a fast, simple and lightweight WSGI micro web-framework for Python."
7url="http://bottlepy.org/"
8arch="noarch"
9license="MIT"
10depends="python"
11depends_dev=""
12makedepends=""
13install=""
14subpackages=""
15source="https://pypi.python.org/packages/source/b/bottle/bottle-$pkgver.tar.gz"
16_builddir="$srcdir"/bottle-$pkgver
17
18prepare() {
19 local i
20 cd "$_builddir"
21 for i in $source; do
22 case $i in
23 *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
24 esac
25 done
26}
27
28build() {
29 cd "$_builddir"
30 python setup.py build || return 1
31}
32
33package() {
34 cd "$_builddir"
35 python setup.py install --prefix=/usr --root="$pkgdir" || return 1
36}
37md5sums="0bafdc4e13ea2b1a3bddf36b5af108c4 bottle-0.11.6.tar.gz"
38sha256sums="2e63802cbe6a21537e35d92ec3c80a1e302dc619d169efe6a212cab9f48e7b29 bottle-0.11.6.tar.gz"
39sha512sums="511748cee1694db9ec04f5f49cf5d44d273f6424733532d4558acc546b4a44a1462433ca9483bf59235b48318b20289e9ae8f8c5d1dc4379da4a86c03848f922 bottle-0.11.6.tar.gz"