aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-04-14 08:48:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-04-14 08:51:09 +0000
commitdf0f8b4f9ac278bf02d3f2234ab83376bba27161 (patch)
tree4cb0df6878d46a9ae12b1008df640c06d2768104
parentc1247b451a2d1b5a2a0df46e48c114b66a938aec (diff)
downloadalpine_aports-df0f8b4f9ac278bf02d3f2234ab83376bba27161.tar.bz2
alpine_aports-df0f8b4f9ac278bf02d3f2234ab83376bba27161.tar.xz
alpine_aports-df0f8b4f9ac278bf02d3f2234ab83376bba27161.zip
main/aports-build: add config option for which formats we do releases
For now this only indicates if we want make release or not.
-rw-r--r--main/aports-build/APKBUILD14
-rw-r--r--main/aports-build/aports-build9
-rw-r--r--main/aports-build/aports-build.confd3
3 files changed, 15 insertions, 11 deletions
diff --git a/main/aports-build/APKBUILD b/main/aports-build/APKBUILD
index c80a0de077..124d2144be 100644
--- a/main/aports-build/APKBUILD
+++ b/main/aports-build/APKBUILD
@@ -1,7 +1,7 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=aports-build 2pkgname=aports-build
3pkgver=0.6 3pkgver=0.6
4pkgrel=1 4pkgrel=2
5pkgdesc="MQTT based build-on-git-push scripts for Alpine Linux" 5pkgdesc="MQTT based build-on-git-push scripts for Alpine Linux"
6url="http://alpinelinux.org" 6url="http://alpinelinux.org"
7arch="noarch" 7arch="noarch"
@@ -39,12 +39,12 @@ package() {
39 "$pkgdir"/etc/conf.d/aports-build || return 1 39 "$pkgdir"/etc/conf.d/aports-build || return 1
40} 40}
41 41
42md5sums="881bc1da8b754a0fa78c585c96939376 aports-build 42md5sums="e3aecf9b43607646e154de430517fdbf aports-build
43784238e965ca025c0c6ed13c8af01613 aports-build.initd 43784238e965ca025c0c6ed13c8af01613 aports-build.initd
44cdc49e0ef145de72131972a575f20e7b aports-build.confd" 44711d8f441b97c54a9561c08925d16d75 aports-build.confd"
45sha256sums="3c365dfe7e4b535fd6e00aa77f926f6b137e15cb66979e7ad2e74f570aa56372 aports-build 45sha256sums="493040e52324529d8d7e3bb9243788484d9f52a2bb63f9081ac87c00f24c8df5 aports-build
4688215b5969e5ffeda549c6e31de4563569ddee2ac3220c381d40f382d43f8323 aports-build.initd 4688215b5969e5ffeda549c6e31de4563569ddee2ac3220c381d40f382d43f8323 aports-build.initd
47519744cdb4be83e5da1c22d4aa93c7ef97d66e03565e84b710bc21c94b82047e aports-build.confd" 47e14940240ffac141b98903214af858c93a36b5a9f133b97a81871f9d56efff6b aports-build.confd"
48sha512sums="243dfd8d8325695b73123c6c3f6eb338ed47eed281ae21439a9642c17375fac6b490a16ec4a2fdb88ae2ab6f148c6da7181ad013f1fd95c9cfa84d804d32ab43 aports-build 48sha512sums="8f418758b955b1eea67e9d48e4c4f7aa1a6c3230871c5f4bf1a15349dd07cae7d74a84ffeec1e59c94b2568f8549e63dcb47a22552710184ba53c3908b13e97d aports-build
492ef2fa6de4118209ab93a56216f106ac32078df762f4d67e900976c28bea96d44806f4679ef966472a3eb05fdaf1648aab17c0eaa897e8a06b1272766f29d22b aports-build.initd 492ef2fa6de4118209ab93a56216f106ac32078df762f4d67e900976c28bea96d44806f4679ef966472a3eb05fdaf1648aab17c0eaa897e8a06b1272766f29d22b aports-build.initd
50fbe8ed4b1fbfc979de62302873e99c67bab751a7fcd921c3b23815f535cedb34c717e82b3c223f88e06498a573cbd147a73db7bf5adbb5e1947ac75fcb8edcb4 aports-build.confd" 5060c62f25834fce29df73b0e64b733c8b9bbd362c130d04ba33f8dbf042b6b7fbb6193beb84ba9c811b3aef1997675bbb3eeedbbf935e4ae005370c4b4a013d26 aports-build.confd"
diff --git a/main/aports-build/aports-build b/main/aports-build/aports-build
index 1ed209920a..8c972a9220 100644
--- a/main/aports-build/aports-build
+++ b/main/aports-build/aports-build
@@ -107,6 +107,7 @@ done
107shift $(( $OPTIND - 1 )) 107shift $(( $OPTIND - 1 ))
108 108
109while true; do 109while true; do
110 local do_release=false
110 cd $aports || return 1 111 cd $aports || return 1
111 # check if we need to rebuild 112 # check if we need to rebuild
112 log "pulling git" 113 log "pulling git"
@@ -118,6 +119,9 @@ while true; do
118 _current_tag=$(git describe --abbrev=0) 119 _current_tag=$(git describe --abbrev=0)
119 if [ "$_old_tag" != "$_current_tag" ]; then 120 if [ "$_old_tag" != "$_current_tag" ]; then
120 log "$_old_tag -> $_current_tag" 121 log "$_old_tag -> $_current_tag"
122 if [ -n "$release_formats" ]; then
123 do_release=true
124 fi
121 fi 125 fi
122 if [ "$_old" = "$_current" ] && [ -f /tmp/uploaded ] && [ -z "$force" ] && [ "$_current_tag" = "$_old_tag" ]; then 126 if [ "$_old" = "$_current" ] && [ -f /tmp/uploaded ] && [ -z "$force" ] && [ "$_current_tag" = "$_old_tag" ]; then
123 break 127 break
@@ -126,7 +130,7 @@ while true; do
126 force= 130 force=
127 131
128 # check if we need make new release 132 # check if we need make new release
129 if [ "$_current_tag" != "$_old_tag" ]; then 133 if $do_release; then
130 _new_release=1 134 _new_release=1
131 # we want build the realease from this tag 135 # we want build the realease from this tag
132 git checkout "$_current_tag" 136 git checkout "$_current_tag"
@@ -168,8 +172,7 @@ while true; do
168 # report to irc that we are done 172 # report to irc that we are done
169 send_irc "files from $_current uploaded" 173 send_irc "files from $_current uploaded"
170 174
171 # if 175 if $do_release; then
172 if [ "$_current_tag" != "$_old_tag" ]; then
173 if new_release ${_current_tag#v}; then 176 if new_release ${_current_tag#v}; then
174 send_irc "release $_current_tag uploaded" 177 send_irc "release $_current_tag uploaded"
175 fi 178 fi
diff --git a/main/aports-build/aports-build.confd b/main/aports-build/aports-build.confd
index a43d1c39d4..1a7320978c 100644
--- a/main/aports-build/aports-build.confd
+++ b/main/aports-build/aports-build.confd
@@ -7,4 +7,5 @@ git_branch=master
7# prefix for url where logs can be found 7# prefix for url where logs can be found
8# logurlprefix=http://bld1.alpinelinux.org/buildlogs 8# logurlprefix=http://bld1.alpinelinux.org/buildlogs
9 9
10 10# list of release formats. unset for no release
11# release_formats="iso"