aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2014-09-29 20:53:51 +0200
committerBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2014-09-29 21:20:07 +0200
commit36f417888fe678fb950526840471e5d6b7c9d1a4 (patch)
tree7679a1cb4bcc4b8ad1e547fff3f7a1123b7f70c5
parent8518e6ebd46b7e03a7e92cce84852a4fa965db43 (diff)
downloadalpine_aports-36f417888fe678fb950526840471e5d6b7c9d1a4.tar.bz2
alpine_aports-36f417888fe678fb950526840471e5d6b7c9d1a4.tar.xz
alpine_aports-36f417888fe678fb950526840471e5d6b7c9d1a4.zip
testing/bam: new aport
Bam is a lightweight build system that uses Lua. It's used by Teeworlds, an incoming aport.
-rw-r--r--testing/bam/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/bam/APKBUILD b/testing/bam/APKBUILD
new file mode 100644
index 0000000000..7a86d2fb78
--- /dev/null
+++ b/testing/bam/APKBUILD
@@ -0,0 +1,27 @@
1# Maintainer:
2# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
3
4pkgname=bam
5pkgver=0.4.0
6pkgrel=0
7pkgdesc='Fast and flexible build system using Lua'
8arch=all
9url=http://github.com/matricks/bam
10license='ZLIB'
11source="https://github.com/downloads/matricks/bam/$pkgname-$pkgver.tar.gz"
12
13build() {
14 cd "$srcdir"/$pkgname-$pkgver
15 sh make_unix.sh || return 1
16}
17
18package() {
19 cd "$srcdir"/$pkgname-$pkgver
20 install -Dm755 bam "$pkgdir"/usr/bin/bam || return 1
21 install -Dm755 license.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE \
22 || return 1
23}
24
25md5sums="2f8e8336b8884110e8a355b12c9fa58a bam-0.4.0.tar.gz"
26sha256sums="5e4e4920b4d265da582f66774e9b1ec8ddfbe75ddc028fba86c12f686ea18db3 bam-0.4.0.tar.gz"
27sha512sums="c599cdf3618d317a5d304febd2e59d1116fc5819cdaf49969fdc25f88ed8f3e25831861c0c7fea05059d8af7085b654a7732bd89086bc166661b932d168ee2ca bam-0.4.0.tar.gz"