aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorxming <xmingske@gmail.com>2014-10-22 10:35:33 +0000
committerBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2014-10-22 12:46:12 +0200
commit214e9e9be559b45ad31bae6799bfa9d2062e87c9 (patch)
treec4a311551347ad2617e3f77cdf3f7e9a9a747405
parentb1740f21e963eec94fe0d86f6a4a6e885e27d992 (diff)
downloadalpine_aports-214e9e9be559b45ad31bae6799bfa9d2062e87c9.tar.bz2
alpine_aports-214e9e9be559b45ad31bae6799bfa9d2062e87c9.tar.xz
alpine_aports-214e9e9be559b45ad31bae6799bfa9d2062e87c9.zip
testing/py-django-pipeline: new aport
an asset packaging library for Django https://github.com/cyberdelia/django-pipeline
-rw-r--r--testing/py-django-pipeline/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/py-django-pipeline/APKBUILD b/testing/py-django-pipeline/APKBUILD
new file mode 100644
index 0000000000..e05dc1b227
--- /dev/null
+++ b/testing/py-django-pipeline/APKBUILD
@@ -0,0 +1,40 @@
1# Contributor: <xmingske@gmail.com>
2# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
3_pkgname=django-pipeline
4pkgname=py-${_pkgname}
5pkgver=1.3.25
6pkgrel=0
7pkgdesc="an asset packaging library for Django"
8url="https://github.com/cyberdelia/django-pipeline"
9arch="noarch"
10license="BSD"
11#makedepends="python-dev py-setuptools py-django"
12makedepends="python-dev py-setuptools"
13depends="python"
14source="$pkgname-$pkgver.tar.gz::https://github.com/cyberdelia/django-pipeline/archive/${pkgver}.tar.gz"
15
16_builddir="${srcdir}/${_pkgname}-${pkgver}"
17
18prepare() {
19 local pf
20 cd "${_builddir}"
21 for pf in $source; do
22 case $pf in
23 *.patch) msg $pf; patch -p1 -i "$srcdir"/${pf} || return 1;;
24 esac
25 done
26}
27
28build() {
29 cd "${_builddir}"
30 python setup.py build || return 1
31}
32
33package() {
34 cd "${_builddir}"
35 python setup.py install --prefix=/usr --root="$pkgdir" || return 1
36}
37
38md5sums="f2dea4e68d65ac5c399fe584366506d6 py-django-pipeline-1.3.25.tar.gz"
39sha256sums="92c4ba5543d3ad980cd3a65a121ced62a6ad6449a773269a693f54e0ca5c565f py-django-pipeline-1.3.25.tar.gz"
40sha512sums="2c66b8b60076a8d19049947a9465d96fd80098c6e560f6cb6ffa26fd17d267830d87913041f9876da1276b0224ef3e8b0183c56367741e11c0f010a236b87169 py-django-pipeline-1.3.25.tar.gz"