aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Angelacos <nangel@alpinelinux.org>2014-10-22 01:29:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-10-22 07:13:14 +0000
commit88cba112c09bacb642ffe7e454782c050292a5e3 (patch)
treefd98c3f53539aa7c775644f87c31c05b1b2712d6
parente076167e5af3cafa29d0fadc0f3d5decf601e395 (diff)
downloadalpine_aports-88cba112c09bacb642ffe7e454782c050292a5e3.tar.bz2
alpine_aports-88cba112c09bacb642ffe7e454782c050292a5e3.tar.xz
alpine_aports-88cba112c09bacb642ffe7e454782c050292a5e3.zip
kamailio - version bump to 4.2.0
new in sub-packages: kamailio: rtpproxy-ng renamed to rtpengine kamailio-extras: tsilo jsonrpc-s kamailio-uuid: new (uuid module) kamailio-ev: new (evapi module)
-rw-r--r--main/kamailio/0001-musl-fixes.patch (renamed from main/kamailio/musl-fixes.patch)13
-rw-r--r--main/kamailio/0001-websocket-remove-libunistring-dependency.patch141
-rw-r--r--main/kamailio/0002-fix_180_replies_in_sca_call_info.patch14
-rw-r--r--main/kamailio/APKBUILD69
-rw-r--r--main/kamailio/kamailio-4.2-backslash.patch (renamed from main/kamailio/kamailio-4.1-backslash.patch)0
5 files changed, 40 insertions, 197 deletions
diff --git a/main/kamailio/musl-fixes.patch b/main/kamailio/0001-musl-fixes.patch
index 28df55fda0..752469e208 100644
--- a/main/kamailio/musl-fixes.patch
+++ b/main/kamailio/0001-musl-fixes.patch
@@ -36,19 +36,6 @@ index cfd09c4..0a27433 100644
36 #include <openssl/err.h> 36 #include <openssl/err.h>
37 #include <openssl/ssl.h> 37 #include <openssl/ssl.h>
38 #include "../../dprint.h" 38 #include "../../dprint.h"
39diff --git a/modules/xhttp_pi/xhttp_pi_fnc.c b/modules/xhttp_pi/xhttp_pi_fnc.c
40index 5602429..2f8e1f7 100644
41--- a/modules/xhttp_pi/xhttp_pi_fnc.c
42+++ b/modules/xhttp_pi/xhttp_pi_fnc.c
43@@ -885,7 +885,7 @@ int ph_getColVals(ph_mod_t *module, ph_cmd_t *cmd,
44 if(vals==NULL||ids==NULL) {LM_ERR("oom\n"); return -1;}
45 col_vals = vals; col_ids = ids;
46 vals = &col_vals[size]; ids = &col_ids[size];
47- memset(vals, 0, sizeof(str*)); memset(ids, 0, sizeof(str*));
48+ memset(vals, 0, sizeof(str)); memset(ids, 0, sizeof(str));
49 /* Retrieve the node attribute */
50 attr.s = ph_xmlNodeGetAttrContentByName(node,
51 XHTTP_PI_XML_ID_ATTR);
52diff --git a/tsend.c b/tsend.c 39diff --git a/tsend.c b/tsend.c
53index 3a18502..99f0c21 100644 40index 3a18502..99f0c21 100644
54--- a/tsend.c 41--- a/tsend.c
diff --git a/main/kamailio/0001-websocket-remove-libunistring-dependency.patch b/main/kamailio/0001-websocket-remove-libunistring-dependency.patch
deleted file mode 100644
index 9b84eba5e3..0000000000
--- a/main/kamailio/0001-websocket-remove-libunistring-dependency.patch
+++ /dev/null
@@ -1,141 +0,0 @@
1From 7cf956836dc20a8f8354e25d018cb5c4eb386187 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
3Date: Fri, 20 Dec 2013 11:53:50 +0200
4Subject: [PATCH 1/1] websocket: remove libunistring dependency
5
6libunistring is old, slow, messy code and uncompilable on new systems.
7remove the sole user of it, and replace it with inline utf8 decoder
8implementation from http://bjoern.hoehrmann.de/utf-8/decoder/dfa/.
9
10improves performance and portability as libunistring is not needed.
11---
12 modules/websocket/Makefile | 2 +-
13 modules/websocket/README | 1 -
14 modules/websocket/doc/websocket_admin.xml | 3 --
15 modules/websocket/utf8_decode.h | 52 +++++++++++++++++++++++++++++++
16 modules/websocket/ws_frame.c | 4 +--
17 5 files changed, 55 insertions(+), 7 deletions(-)
18 create mode 100644 modules/websocket/utf8_decode.h
19
20diff --git a/modules/websocket/Makefile b/modules/websocket/Makefile
21index bb7c809..c686a82 100644
22--- a/modules/websocket/Makefile
23+++ b/modules/websocket/Makefile
24@@ -27,7 +27,7 @@ else
25 # E.g.: make TLS_HOOKS=1 TLS_EXTRA_LIBS="-lz -lkrb5"
26 endif
27
28-LIBS+= $(TLS_EXTRA_LIBS) -lunistring
29+LIBS+= $(TLS_EXTRA_LIBS)
30
31 # Static linking, if you'd like to use TLS and WEBSOCKET at the same time
32 #
33diff --git a/modules/websocket/README b/modules/websocket/README
34index 49d8693..bdba3e4 100644
35--- a/modules/websocket/README
36+++ b/modules/websocket/README
37@@ -316,7 +316,6 @@ onreply_route[WS_REPLY] {
38 The following libraries must be installed before running Kamailio with
39 this module loaded:
40 * OpenSSL.
41- * GNU libunistring.
42
43 4. Parameters
44
45diff --git a/modules/websocket/doc/websocket_admin.xml b/modules/websocket/doc/websocket_admin.xml
46index fa7d300..e40dc09 100644
47--- a/modules/websocket/doc/websocket_admin.xml
48+++ b/modules/websocket/doc/websocket_admin.xml
49@@ -262,9 +262,6 @@ onreply_route[WS_REPLY] {
50 <listitem>
51 <para><emphasis>OpenSSL</emphasis>.</para>
52 </listitem>
53- <listitem>
54- <para><emphasis>GNU libunistring</emphasis>.</para>
55- </listitem>
56 </itemizedlist>
57 </para>
58 </section>
59diff --git a/modules/websocket/utf8_decode.h b/modules/websocket/utf8_decode.h
60new file mode 100644
61index 0000000..b274fe7
62--- /dev/null
63+++ b/modules/websocket/utf8_decode.h
64@@ -0,0 +1,52 @@
65+#include <stdint.h>
66+#include <stddef.h>
67+
68+// Copyright (c) 2008-2010 Bjoern Hoehrmann <bjoern@hoehrmann.de>
69+// See http://bjoern.hoehrmann.de/utf-8/decoder/dfa/ for details.
70+
71+#define UTF8_ACCEPT 0
72+#define UTF8_REJECT 12
73+
74+static const uint8_t utf8d[] = {
75+ // The first part of the table maps bytes to character classes that
76+ // to reduce the size of the transition table and create bitmasks.
77+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0, 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
78+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0, 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
79+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0, 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
80+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0, 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
81+ 1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1, 9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,
82+ 7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7, 7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,
83+ 8,8,2,2,2,2,2,2,2,2,2,2,2,2,2,2, 2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,
84+ 10,3,3,3,3,3,3,3,3,3,3,3,3,4,3,3, 11,6,6,6,5,8,8,8,8,8,8,8,8,8,8,8,
85+
86+ // The second part is a transition table that maps a combination
87+ // of a state of the automaton and a character class to a state.
88+ 0,12,24,36,60,96,84,12,12,12,48,72, 12,12,12,12,12,12,12,12,12,12,12,12,
89+ 12, 0,12,12,12,12,12, 0,12, 0,12,12, 12,24,12,12,12,12,12,24,12,24,12,12,
90+ 12,12,12,12,12,12,12,24,12,12,12,12, 12,24,12,12,12,12,12,12,12,24,12,12,
91+ 12,12,12,12,12,12,12,36,12,36,12,12, 12,36,12,12,12,12,12,36,12,36,12,12,
92+ 12,36,12,12,12,12,12,12,12,12,12,12,
93+};
94+
95+static inline uint32_t decode(uint32_t* state, uint32_t* codep, uint32_t byte)
96+{
97+ uint32_t type = utf8d[byte];
98+
99+ *codep = (*state != UTF8_ACCEPT) ?
100+ (byte & 0x3fu) | (*codep << 6) :
101+ (0xff >> type) & (byte);
102+
103+ *state = utf8d[256 + *state + type];
104+ return *state;
105+}
106+
107+static inline int IsUTF8(uint8_t* s, size_t len)
108+{
109+ uint32_t codepoint, state = 0;
110+
111+ while (len--)
112+ decode(&state, &codepoint, *s++);
113+
114+ return state == UTF8_ACCEPT;
115+}
116+
117diff --git a/modules/websocket/ws_frame.c b/modules/websocket/ws_frame.c
118index a3a4cef..3562437 100644
119--- a/modules/websocket/ws_frame.c
120+++ b/modules/websocket/ws_frame.c
121@@ -22,7 +22,7 @@
122 */
123
124 #include <limits.h>
125-#include <unistr.h>
126+#include "utf8_decode.h"
127 #include "../../events.h"
128 #include "../../receive.h"
129 #include "../../stats.h"
130@@ -695,7 +695,7 @@ int ws_frame_transmit(void *data)
131 frame.fin = 1;
132 /* Can't be sure whether this message is UTF-8 or not so check to see
133 if it "might" be UTF-8 and send as binary if it definitely isn't */
134- frame.opcode = (u8_check((uint8_t *) wsev->buf, wsev->len) == NULL) ?
135+ frame.opcode = IsUTF8((uint8_t *) wsev->buf, wsev->len) ?
136 OPCODE_TEXT_FRAME : OPCODE_BINARY_FRAME;
137 frame.payload_len = wsev->len;
138 frame.payload_data = wsev->buf;
139--
1401.8.5.1
141
diff --git a/main/kamailio/0002-fix_180_replies_in_sca_call_info.patch b/main/kamailio/0002-fix_180_replies_in_sca_call_info.patch
deleted file mode 100644
index d5905d1651..0000000000
--- a/main/kamailio/0002-fix_180_replies_in_sca_call_info.patch
+++ /dev/null
@@ -1,14 +0,0 @@
1diff --git a/modules/sca/sca_call_info.c b/modules/sca/sca_call_info.c
2index 1e5bbfd..f8c4169 100644
3--- a/modules/sca/sca_call_info.c
4+++ b/modules/sca/sca_call_info.c
5@@ -1072,9 +1072,6 @@ sca_call_info_invite_reply_18x_handler( sip_msg_t *msg,
6
7 switch ( msg->REPLY_STATUS ) {
8 case 180:
9- state = SCA_APPEARANCE_STATE_ALERTING;
10- break;
11-
12 case 183:
13 state = SCA_APPEARANCE_STATE_PROGRESSING;
14 break;
diff --git a/main/kamailio/APKBUILD b/main/kamailio/APKBUILD
index d1d4e64a9d..59e3cbd21b 100644
--- a/main/kamailio/APKBUILD
+++ b/main/kamailio/APKBUILD
@@ -1,8 +1,8 @@
1# Contributor: Michael Mason <ms13sp@gmail.com> 1# Contributor: Michael Mason <ms13sp@gmail.com>
2# Maintainer: Nathan Angelacos <nangel@alpinelinux.org> 2# Maintainer: Nathan Angelacos <nangel@alpinelinux.org>
3pkgname=kamailio 3pkgname=kamailio
4pkgver=4.1.5 4pkgver=4.2.0
5pkgrel=2 5pkgrel=0
6pkgdesc="Open Source SIP Server" 6pkgdesc="Open Source SIP Server"
7url="http://www.kamailio.org/" 7url="http://www.kamailio.org/"
8arch="all" 8arch="all"
@@ -13,7 +13,7 @@ license="GPL2+"
13depends="" 13depends=""
14makedepends="bison flex expat-dev postgresql-dev pcre-dev mysql-dev 14makedepends="bison flex expat-dev postgresql-dev pcre-dev mysql-dev
15 libxml2-dev curl-dev unixodbc-dev confuse-dev ncurses-dev sqlite-dev 15 libxml2-dev curl-dev unixodbc-dev confuse-dev ncurses-dev sqlite-dev
16 lua-dev openldap-dev openssl-dev net-snmp-dev" 16 lua-dev openldap-dev openssl-dev net-snmp-dev libuuid libev-dev"
17install="$pkgname.pre-install $pkgname.pre-upgrade" 17install="$pkgname.pre-install $pkgname.pre-upgrade"
18 18
19# See Makefile.groups for the list of recommended modules for 19# See Makefile.groups for the list of recommended modules for
@@ -34,12 +34,12 @@ _mod_list_basic="avp async auth benchmark blst cfg_rpc cfgutils corex counters \
34 maxfwd mediaproxy mi_datagram mi_fifo mi_rpc mqueue \ 34 maxfwd mediaproxy mi_datagram mi_fifo mi_rpc mqueue \
35 nat_traversal nathelper path pike pv ratelimit rr rtimer \ 35 nat_traversal nathelper path pike pv ratelimit rr rtimer \
36 rtpproxy sanity sdpops siputils sl statistics textops \ 36 rtpproxy sanity sdpops siputils sl statistics textops \
37 textopsx tm tmx topoh xlog rtpproxy-ng stun sipt" 37 textopsx tm tmx topoh xlog rtpengine stun sipt"
38 38
39# - extra used modules, with no extra dependency 39# - extra used modules, with no extra dependency
40_mod_list_extras="auth_diameter call_control cnxcc dmq domainpolicy msrp pdb \ 40_mod_list_extras="auth_diameter call_control cnxcc dmq domainpolicy msrp pdb \
41 qos sca seas sms sst timer tmrec uac_redirect xhttp \ 41 qos sca seas sms sst timer tmrec tsilo uac_redirect xhttp \
42 xhttp_rpc xprint" 42 xhttp_rpc xprint jsonrpc-s nosip"
43 43
44# - common modules depending on database 44# - common modules depending on database
45_mod_list_db="acc alias_db auth_db avpops cfg_db db_flatstore \ 45_mod_list_db="acc alias_db auth_db avpops cfg_db db_flatstore \
@@ -74,7 +74,7 @@ _mod_list_postgres="db_postgres"
74_mod_list_unixodbc="db_unixodbc" 74_mod_list_unixodbc="db_unixodbc"
75 75
76# - modules depending on mysql cassandra library 76# - modules depending on mysql cassandra library
77_mod_list_cassandra="db_cassandra" 77_mod_list_cassandra="db_cassandra ndb_cassandra"
78 78
79# - modules depending on xml2 library 79# - modules depending on xml2 library
80_mod_list_cpl="cpl-c" 80_mod_list_cpl="cpl-c"
@@ -115,9 +115,6 @@ _mod_list_outbound="outbound"
115# - modules depending on unistring library 115# - modules depending on unistring library
116_mod_list_websocket="websocket" 116_mod_list_websocket="websocket"
117 117
118# - modules depending on openssl library
119_mod_list_stun="stun"
120
121# - modules depending on libval-threads libcrypto libsres libpthread 118# - modules depending on libval-threads libcrypto libsres libpthread
122_mod_list_dnssec="dnssec" 119_mod_list_dnssec="dnssec"
123 120
@@ -176,6 +173,19 @@ _mod_list_java="app_java"
176# - modules depending on iptables library 173# - modules depending on iptables library
177_mod_list_iptrtpproxy="iptrtpproxy" 174_mod_list_iptrtpproxy="iptrtpproxy"
178 175
176# - modules depending on uuid library
177_mod_list_uuid="uuid"
178
179# - modules depending on ev library
180_mod_list_ev="evapi"
181
182# - modules depending on kazoo/rabbitmq
183_mod_list_kazoo="kazoo"
184
185# - modules depending on mongodb
186_mod_list_mongodb="db_mongodb ndb_mongodb"
187
188
179# Alpine Specific 189# Alpine Specific
180_mod_list_debugger="$_mod_list_devel benchmark debugger" 190_mod_list_debugger="$_mod_list_devel benchmark debugger"
181 191
@@ -189,18 +199,15 @@ _modules="$_module_group_kstandard"
189for _i in db postgres sqlite dbtext mysql \ 199for _i in db postgres sqlite dbtext mysql \
190 cpl xml unixodbc snmpstats xmpp carrierroute \ 200 cpl xml unixodbc snmpstats xmpp carrierroute \
191 ldap utils tls presence lua ims outbound debugger \ 201 ldap utils tls presence lua ims outbound debugger \
192 extras websocket authephemeral; do 202 extras websocket authephemeral ev uuid; do
193 203
194 subpackages="$subpackages $pkgname-$_i" 204 subpackages="$subpackages $pkgname-$_i"
195 eval "_modules=\"\$_modules \$_mod_list_$_i\"" 205 eval "_modules=\"\$_modules \$_mod_list_$_i\""
196done 206done
197 207
198source="http://www.kamailio.org/pub/kamailio/$pkgver/src/kamailio-${pkgver}_src.tar.gz 208source="http://www.kamailio.org/pub/kamailio/$pkgver/src/kamailio-${pkgver}_src.tar.gz
199 kamailio-4.1-backslash.patch 209 kamailio-4.2-backslash.patch
200 0001-websocket-remove-libunistring-dependency.patch 210 0001-musl-fixes.patch
201 0002-fix_180_replies_in_sca_call_info.patch
202 musl-fixes.patch
203
204 kamailio.cfg 211 kamailio.cfg
205 kamailio.initd 212 kamailio.initd
206 " 213 "
@@ -240,7 +247,7 @@ prepare() {
240 247
241build() { 248build() {
242 cd "$_builddir" 249 cd "$_builddir"
243 make FLAVOUR=kamailio STUN=1 \ 250 make FLAVOUR=kamailio STUN=1 EMBEDDED_UTF_DECODE=1\
244 PREFIX=/usr \ 251 PREFIX=/usr \
245 CC_EXTRA_OPTS="$CFLAGS -D_GNU_SOURCE" \ 252 CC_EXTRA_OPTS="$CFLAGS -D_GNU_SOURCE" \
246 cfg_target=/etc/kamailio/ \ 253 cfg_target=/etc/kamailio/ \
@@ -414,24 +421,28 @@ authephemeral() {
414 "$_mod_list_authephemeral" 421 "$_mod_list_authephemeral"
415} 422}
416 423
417md5sums="623b46e969445494655b1aa5ab5ad4b0 kamailio-4.1.5_src.tar.gz 424ev() {
425 _generic_pkg "Network event broadcast API" \
426 "$_mod_list_ev"
427}
428
429uuid() {
430 _generic_pkg "UUID generator using libuuid" \
431 "$_mod_list_uuid"
432}
433
434md5sums="6b5dc98be07a5d68b3701d7955102d34 kamailio-4.2.0_src.tar.gz
418bad1ac2d4c95043df271d2ea6d37627a kamailio-4.1-backslash.patch 435bad1ac2d4c95043df271d2ea6d37627a kamailio-4.1-backslash.patch
4196251a5c33373c5276897c8abbbecc619 0001-websocket-remove-libunistring-dependency.patch 4364685288dc54680597b00f956dc95d4d6 0001-musl-fixes.patch
420018ce30f5169866d12b395ba30bf3263 0002-fix_180_replies_in_sca_call_info.patch
421558aa761bddb6ac85c152bd767670fcc musl-fixes.patch
422a3c959ec568c43a905710e7d25cd8c25 kamailio.cfg 437a3c959ec568c43a905710e7d25cd8c25 kamailio.cfg
4230e0a271fd3ddb7e87c01c26c7d041d59 kamailio.initd" 4380e0a271fd3ddb7e87c01c26c7d041d59 kamailio.initd"
424sha256sums="e24d078aa2a8500f7cf75120628140218241b1faf9f40ece118f4e6a5ca3b3d3 kamailio-4.1.5_src.tar.gz 439sha256sums="617423cedf740719c21f4731094f1e0b755ae65952979eeea3e8e229a8da21a4 kamailio-4.2.0_src.tar.gz
425d7e59be721ed0ad4621d404493b9a519708d801e9d4914b0164b819fa1abcd13 kamailio-4.1-backslash.patch 440d7e59be721ed0ad4621d404493b9a519708d801e9d4914b0164b819fa1abcd13 kamailio-4.1-backslash.patch
426bbc06f9ae62b2e8df2c58f9a171f0408e075d5a51e2457e85ef3ca01aa972df9 0001-websocket-remove-libunistring-dependency.patch 441b98555ff304b51b82c6cf7e01d757b15ea4f05bd2e603c84d4384df6a6be62b6 0001-musl-fixes.patch
427e7217f214c4bdd8c2dbccfa1036a68749b2e7c0dbad0b10a44a84709e1660a99 0002-fix_180_replies_in_sca_call_info.patch
4284f316e4c1617833111b86aad1e8878b62599e42bb229fe1ef7eee1d4438471e2 musl-fixes.patch
4298024266849033a917147827c3579a382f10f3796989bebc6de3d7c80c965fb72 kamailio.cfg 4428024266849033a917147827c3579a382f10f3796989bebc6de3d7c80c965fb72 kamailio.cfg
430a90d3ab09a3ed58892e94710a1f80492a61ffad1ccf7ccb5b851bb8f538d32c4 kamailio.initd" 443a90d3ab09a3ed58892e94710a1f80492a61ffad1ccf7ccb5b851bb8f538d32c4 kamailio.initd"
431sha512sums="578870f96d9251e676c2689d7a48d2a0a4fd37e5bfde0d145adfcffea1470d618f1eb0e5012ffe2c63d1b2c9e659128e3cbe50403c94499951b75e59bb223f0e kamailio-4.1.5_src.tar.gz 444sha512sums="811c19bf55000905a827f6ea956cd1c445fe1522c69b8eaf83d5a5dc5fba250fe84c6841e3e8d0769f225bc94c87f2fdf6349ed0f2521395a52b609bf55842e7 kamailio-4.2.0_src.tar.gz
432a9bb1e8f9f373264b8351ddae099a36a46ddd46fdec09e468d297ba4f64bb4896e7d6e599da70a424e8a28695ab3f3b4ac940afab534593a6b9d08ae462f001a kamailio-4.1-backslash.patch 445a9bb1e8f9f373264b8351ddae099a36a46ddd46fdec09e468d297ba4f64bb4896e7d6e599da70a424e8a28695ab3f3b4ac940afab534593a6b9d08ae462f001a kamailio-4.1-backslash.patch
433a972e57d8d64c104cb3df329442c746588818ed7f148a409d6050bcbbbb021cc1eeb970b59924e0ffb7f9487faacb99cada0dbfb19b0b87f66ca6b2bcf8b8345 0001-websocket-remove-libunistring-dependency.patch 446dea7ef2ccf01357576045ba375d41301e2447b4454324007c7ca1862322835c57045852017192ca5434b32dd1b7a2e9669209b7111889dab335b74f042d0f11f 0001-musl-fixes.patch
434558a4dbd2c84a6d0208c5e0a65eacc6241ad20948a5882834d40106f6f1d4b40ec139bf8b513e6e7cb7afee71823f1811d85e2904f9b06720383b5581a1e9aca 0002-fix_180_replies_in_sca_call_info.patch
4359afb7191541b40678ede6dd1bb034b2a6a704659acb54e156096fe0660e08358b0691028b1facfb50608ca2d25714962c92ede62e1f95cb53475c89d96bd33e4 musl-fixes.patch
4360b666bfa10fd0af97b62749f8691cb3f76d9b40d1abe0a33e810e367bd733d2e8189c89f7f23010ec591116aada6e1a8a403b17449fe775038917617f281ad4d kamailio.cfg 4470b666bfa10fd0af97b62749f8691cb3f76d9b40d1abe0a33e810e367bd733d2e8189c89f7f23010ec591116aada6e1a8a403b17449fe775038917617f281ad4d kamailio.cfg
4375ddaa059cdef10462c904f061f7bb085e62ad7501e2ed41f797d9e68822bce4e0e5ca09c1586c3901c920f8ce563c8c3ede860752c2b9bdb8f09908388ef337f kamailio.initd" 4485ddaa059cdef10462c904f061f7bb085e62ad7501e2ed41f797d9e68822bce4e0e5ca09c1586c3901c920f8ce563c8c3ede860752c2b9bdb8f09908388ef337f kamailio.initd"
diff --git a/main/kamailio/kamailio-4.1-backslash.patch b/main/kamailio/kamailio-4.2-backslash.patch
index 52d04efc2b..52d04efc2b 100644
--- a/main/kamailio/kamailio-4.1-backslash.patch
+++ b/main/kamailio/kamailio-4.2-backslash.patch