aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Matheis <jomat+alpinebuild@jmt.gr>2014-08-28 15:02:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-10-20 12:35:04 +0000
commit9b94e270d15694252b5335fad45d47d1b1dceb71 (patch)
tree6c284745285a7bdf57bb1f86e1c9b90ba4071671
parentd9504f0a8ea97d3c9594eb9af36cf79ac2164fb7 (diff)
downloadalpine_aports-9b94e270d15694252b5335fad45d47d1b1dceb71.tar.bz2
alpine_aports-9b94e270d15694252b5335fad45d47d1b1dceb71.tar.xz
alpine_aports-9b94e270d15694252b5335fad45d47d1b1dceb71.zip
testing/xautolock: new aport
ftp://ibiblio.org/pub/Linux/X11/screensavers/ An automatic X screen-locker/screen-saver
-rw-r--r--testing/xautolock/APKBUILD45
-rw-r--r--testing/xautolock/processwait.patch33
2 files changed, 78 insertions, 0 deletions
diff --git a/testing/xautolock/APKBUILD b/testing/xautolock/APKBUILD
new file mode 100644
index 0000000000..50af820a21
--- /dev/null
+++ b/testing/xautolock/APKBUILD
@@ -0,0 +1,45 @@
1# Contributor: Johannes Matheis <jomat+alpinebuild@jmt.gr>
2# Maintainer: Johannes Matheis <jomat+alpinebuild@jmt.gr>
3pkgname=xautolock
4pkgver=2.2
5pkgrel=0
6pkgdesc="An automatic X screen-locker/screen-saver"
7url="ftp://ibiblio.org/pub/Linux/X11/screensavers/"
8arch="all"
9license="GPL2"
10depends=""
11depends_dev="imake xorg-server-dev libxscrnsaver-dev xorg-cf-files"
12makedepends="$depends_dev"
13install=""
14subpackages="$pkgname-doc"
15source="$url/$pkgname-$pkgver.tgz processwait.patch"
16
17_builddir="$srcdir/$pkgname-$pkgver"
18prepare() {
19 local i
20 cd "$_builddir"
21 for i in $source; do
22 case $i in
23 *.patch) msg $i; patch -p0 -i "$srcdir"/$i || return 1;;
24 esac
25 done
26}
27
28build() {
29 cd "$_builddir"
30 xmkmf
31 make || return 1
32}
33
34package() {
35 cd "$_builddir"
36 make DESTDIR="$pkgdir" install
37 make MANPATH=/usr/share/man DESTDIR="$pkgdir" install.man
38}
39
40md5sums="9526347a202694ad235d731d9d3de91f xautolock-2.2.tgz
41bbd3d70adf4fd2794c4ed71441e6fa33 processwait.patch"
42sha256sums="11f0275175634e6db756e96f5713ec91b8b1c41f8663df54e8a5d27dc71c4da2 xautolock-2.2.tgz
43adee645f0a1b3767c711ca52b2b82ab22f30dd6e39e79935aedfb1c70e6de2c2 processwait.patch"
44sha512sums="5f9dcc25cda706610e77a74235c4b421ca3a833d154b1a269057f0774579e1c6ec36fe0e5be5fadd6942ce8c1640a760f891397586b162e6024b524635153d04 xautolock-2.2.tgz
453e87cb592ddfdc91dd5c66a360e71fc6f59cedc080cfc8f1a51888dfad67c96e72047ad292d63d7b9468daddf2ea5c8d7c6da3e9819eac1818a8388df2d96a8e processwait.patch"
diff --git a/testing/xautolock/processwait.patch b/testing/xautolock/processwait.patch
new file mode 100644
index 0000000000..8a8509a6b7
--- /dev/null
+++ b/testing/xautolock/processwait.patch
@@ -0,0 +1,33 @@
1--- src/engine.c.orig 2014-08-28 12:50:56.086307943 +0000
2+++ src/engine.c 2014-08-28 12:50:59.496333650 +0000
3@@ -209,24 +209,24 @@ evaluateTriggers (Display* d)
4 {
5 #else /* VMS */
6 if (lockerPid)
7 {
8-#if !defined (UTEKV) && !defined (SYSV) && !defined (SVR4)
9+#if (!defined (UTEKV) && !defined (SYSV) && !defined (SVR4)) && defined (__GLIBC__)
10 union wait status; /* childs process status */
11-#else /* !UTEKV && !SYSV && !SVR4 */
12+#else /* (!UTEKV && !SYSV && !SVR4) && __GLIBC__ */
13 int status = 0; /* childs process status */
14-#endif /* !UTEKV && !SYSV && !SVR4 */
15+#endif /* (!UTEKV && !SYSV && !SVR4) && __GLIBC__ */
16
17 if (unlockNow && !disabled)
18 {
19 (void) kill (lockerPid, SIGTERM);
20 }
21
22-#if !defined (UTEKV) && !defined (SYSV) && !defined (SVR4)
23+#if (!defined (UTEKV) && !defined (SYSV) && !defined (SVR4)) && defined (__GLIBC__)
24 if (wait3 (&status, WNOHANG, 0))
25-#else /* !UTEKV && !SYSV && !SVR4 */
26+#else /* (!UTEKV && !SYSV && !SVR4) && __GLIBC__ */
27 if (waitpid (-1, &status, WNOHANG))
28-#endif /* !UTEKV && !SYSV && !SVR4 */
29+#endif /* (!UTEKV && !SYSV && !SVR4) && __GLIBC__ */
30 {
31 /*
32 * If the locker exited normally, we disable any pending kill
33 * trigger. Otherwise, we assume that it either has crashed or