aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Bowes <jbowes@repl.ca>2016-02-15 16:40:24 -0400
committerTimo Teräs <timo.teras@iki.fi>2016-02-22 14:24:03 +0000
commit7ac7e0c24e77c4b11ee02fe92537c5ce3fd2cf65 (patch)
tree7342345830bf0af5a86ca48a2e1843a6a8322675
parent0b87fe1b7d417dad80a48b3d7743c37cf47cb943 (diff)
downloadalpine_aports-7ac7e0c24e77c4b11ee02fe92537c5ce3fd2cf65.tar.bz2
alpine_aports-7ac7e0c24e77c4b11ee02fe92537c5ce3fd2cf65.tar.xz
alpine_aports-7ac7e0c24e77c4b11ee02fe92537c5ce3fd2cf65.zip
testing/rocksdb: new aport
http://rocksdb.org A persistent key-value store for fast storage environments
-rw-r--r--testing/rocksdb/10-support-busybox-install.patch20
-rw-r--r--testing/rocksdb/20-skip-glibc-specific-features.patch23
-rw-r--r--testing/rocksdb/APKBUILD53
3 files changed, 96 insertions, 0 deletions
diff --git a/testing/rocksdb/10-support-busybox-install.patch b/testing/rocksdb/10-support-busybox-install.patch
new file mode 100644
index 0000000000..8974dfa9a0
--- /dev/null
+++ b/testing/rocksdb/10-support-busybox-install.patch
@@ -0,0 +1,20 @@
1--- a/Makefile
2+++ b/Makefile
3@@ -996,14 +996,14 @@ install-headers:
4 install -d $(INSTALL_PATH)/$$header_dir; \
5 done
6 for header in `find "include/rocksdb" -type f -name *.h`; do \
7- install -C -m 644 $$header $(INSTALL_PATH)/$$header; \
8+ install -c -m 644 $$header $(INSTALL_PATH)/$$header; \
9 done
10
11 install-static: install-headers $(LIBRARY)
12- install -C -m 755 $(LIBRARY) $(INSTALL_PATH)/lib
13+ install -c -m 755 $(LIBRARY) $(INSTALL_PATH)/lib
14
15 install-shared: install-headers $(SHARED4)
16- install -C -m 755 $(SHARED4) $(INSTALL_PATH)/lib && \
17+ install -c -m 755 $(SHARED4) $(INSTALL_PATH)/lib && \
18 ln -fs $(SHARED4) $(INSTALL_PATH)/lib/$(SHARED3) && \
19 ln -fs $(SHARED4) $(INSTALL_PATH)/lib/$(SHARED2) && \
20 ln -fs $(SHARED4) $(INSTALL_PATH)/lib/$(SHARED1)
diff --git a/testing/rocksdb/20-skip-glibc-specific-features.patch b/testing/rocksdb/20-skip-glibc-specific-features.patch
new file mode 100644
index 0000000000..b331a42e2d
--- /dev/null
+++ b/testing/rocksdb/20-skip-glibc-specific-features.patch
@@ -0,0 +1,23 @@
1--- a/port/port_posix.cc
2+++ b/port/port_posix.cc
3@@ -32,7 +32,7 @@ static int PthreadCall(const char* label, int result) {
4 }
5
6 Mutex::Mutex(bool adaptive) {
7-#ifdef OS_LINUX
8+#if 0
9 if (!adaptive) {
10 PthreadCall("init mutex", pthread_mutex_init(&mu_, nullptr));
11 } else {
12--- a/port/stack_trace.cc
13+++ b/port/stack_trace.cc
14@@ -5,8 +5,7 @@
15 //
16 #include "port/stack_trace.h"
17
18-#if defined(ROCKSDB_LITE) || !(defined(OS_LINUX) || defined(OS_MACOSX)) || \
19- defined(CYGWIN)
20+#if 1
21
22 // noop
23
diff --git a/testing/rocksdb/APKBUILD b/testing/rocksdb/APKBUILD
new file mode 100644
index 0000000000..e05e02ae6a
--- /dev/null
+++ b/testing/rocksdb/APKBUILD
@@ -0,0 +1,53 @@
1# Contributor: James Bowes <jbowes@repl.ca>
2# Maintainer:
3pkgname=rocksdb
4pkgver=4.2
5pkgrel=0
6pkgdesc="A persistent key-value store for fast storage environments"
7url="http://rocksdb.org"
8arch="all"
9license="BSD"
10depends=""
11depends_dev=""
12makedepends="$depends_dev linux-headers snappy-dev zlib-dev bzip2-dev"
13install=""
14subpackages="$pkgname-dev $pkgname-doc"
15source="saveas-https://github.com/facebook/$pkgname/archive/v$pkgver.tar.gz/$pkgname-$pkgver.tar.gz
16 10-support-busybox-install.patch
17 20-skip-glibc-specific-features.patch"
18
19_builddir="$srcdir/$pkgname-$pkgver"
20prepare() {
21 local i
22 cd "$_builddir"
23 for i in $source; do
24 case $i in
25 *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
26 esac
27 done
28}
29
30build() {
31 cd "$_builddir"
32 make shared_lib
33}
34
35package() {
36 cd "$_builddir"
37 INSTALL_PATH="$pkgdir"/usr make install-shared
38 install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
39 mkdir -p "$pkgdir"/usr/share/doc
40 cp -a doc "$pkgdir"/usr/share/doc/$pkgname
41 install -Dm644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md
42 install -Dm644 HISTORY.md "$pkgdir"/usr/share/doc/$pkgname/HISTORY.md
43}
44
45md5sums="503a821e3fcc1bda759a99f934c14875 rocksdb-4.2.tar.gz
46cfb497c3c250089632bd79d37f5ee686 10-support-busybox-install.patch
47b6f3ad1dac1df1378647236de310bd4f 20-skip-glibc-specific-features.patch"
48sha256sums="83d89ca5b7574328b2380132413ba1e1e6fe5688d1cf1c85f1d2910d93e68f4c rocksdb-4.2.tar.gz
49f96e21398f1bbd2e508280f294bfe8cafd4e750aa32d56fa89da32e2014f2304 10-support-busybox-install.patch
500036ae5fd12bc0941aee572b5f5f28a4ccc296d64e19bcc3309af6a26b0f4ab9 20-skip-glibc-specific-features.patch"
51sha512sums="ac95f2ad5f0d31f189308b4b664d45468d7cdb05330f2cc9fd013f9541c91e69f8766c34483b8154753c93693467592b2a04e80f852e67cb6a4cf20c1f754390 rocksdb-4.2.tar.gz
52ef35fec6d4c831b1ede297466bc9a06db8884e79c1b6fb0d2757e02aee933eb36269d067aaa665cbbd2b5b2854777ea56692a318f45a928c8d8161bf74576aef 10-support-busybox-install.patch
536e6e93fa05cc7225cef381b020bd2a4e94bb8d38fa930d8117e8f2f1afd2abb1604c129892c891a8c9cc8f52bcdf2f6856d855bb717b7f71a2f0499f23b613d8 20-skip-glibc-specific-features.patch"