aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValery Kartel <valery.kartel@gmail.com>2016-02-22 12:56:28 +0200
committerTimo Teräs <timo.teras@iki.fi>2016-02-23 07:45:54 +0000
commitae6d8820a00d31809716682b979d96a2f76361a5 (patch)
tree5f5c693b1569567ea59882180d3b3728e0f25f95
parent60d81d4e9c540f8fe9819d63850372b456a36a6f (diff)
downloadalpine_aports-ae6d8820a00d31809716682b979d96a2f76361a5.tar.bz2
alpine_aports-ae6d8820a00d31809716682b979d96a2f76361a5.tar.xz
alpine_aports-ae6d8820a00d31809716682b979d96a2f76361a5.zip
testing/php7: fix mysqli, mysqlnd and pdo_mysql extensions
- mysqli and pdo_mysql now uses system libmysqlclient library - mysqlnd now has mysqli as a backend - fixes #5111
-rw-r--r--testing/php7/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/testing/php7/APKBUILD b/testing/php7/APKBUILD
index 72e889c474..d3c3076ae5 100644
--- a/testing/php7/APKBUILD
+++ b/testing/php7/APKBUILD
@@ -3,7 +3,7 @@
3pkgname=php7 3pkgname=php7
4_pkgreal=php 4_pkgreal=php
5pkgver=7.0.3 5pkgver=7.0.3
6pkgrel=0 6pkgrel=1
7pkgdesc="The PHP language runtime engine - 7th branch" 7pkgdesc="The PHP language runtime engine - 7th branch"
8url="http://www.php.net/" 8url="http://www.php.net/"
9arch="x86_64 armhf" 9arch="x86_64 armhf"
@@ -148,7 +148,8 @@ _build() {
148 --with-mcrypt=shared \ 148 --with-mcrypt=shared \
149 --with-sqlite3=shared --with-pdo-sqlite=shared \ 149 --with-sqlite3=shared --with-pdo-sqlite=shared \
150 --with-pdo-dblib=shared \ 150 --with-pdo-dblib=shared \
151 --with-mysqli=shared,mysqlnd --enable-mysqlnd=shared --with-pdo-mysql=shared --with-mysql-sock=/run/mysqld/mysqld.sock \ 151 --with-mysqli=shared,/usr/bin/mysql_config \
152 --enable-mysqlnd=shared --with-pdo-mysql=shared,/usr/bin/mysql_config --with-mysql-sock=/run/mysqld/mysqld.sock \
152 --with-pgsql=shared --with-pdo-pgsql=shared \ 153 --with-pgsql=shared --with-pdo-pgsql=shared \
153 --with-unixODBC=shared,/usr -with-pdo-odbc=shared,unixODBC,/usr \ 154 --with-unixODBC=shared,/usr -with-pdo-odbc=shared,unixODBC,/usr \
154 --with-dbmaker=shared \ 155 --with-dbmaker=shared \
@@ -356,7 +357,7 @@ ldap() { _mv_ext ldap; }
356mbstring() { _mv_ext mbstring; } 357mbstring() { _mv_ext mbstring; }
357mcrypt() { _mv_ext mcrypt; } 358mcrypt() { _mv_ext mcrypt; }
358mysqli() { _mv_ext mysqli; } 359mysqli() { _mv_ext mysqli; }
359mysqlnd() { _mv_ext mysqlnd; } 360mysqlnd() { _mv_ext mysqlnd $pkgname-mysqli; }
360odbc() { _mv_ext odbc; } 361odbc() { _mv_ext odbc; }
361opcache() { _mv_ext opcache; } 362opcache() { _mv_ext opcache; }
362openssl() { _mv_ext openssl; } 363openssl() { _mv_ext openssl; }