aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Johnson <nathan@nathanjohnson.info>2016-02-19 22:39:25 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-02-22 13:53:26 +0000
commite81049956f7cd1251ef6ec8e90c487c7c2bda99b (patch)
treecfafebe95921da7a8eacefcc954284c94d278071
parent34cb414e46f7c7cd26e4889f1f17dbeb265efbb2 (diff)
downloadalpine_aports-e81049956f7cd1251ef6ec8e90c487c7c2bda99b.tar.bz2
alpine_aports-e81049956f7cd1251ef6ec8e90c487c7c2bda99b.tar.xz
alpine_aports-e81049956f7cd1251ef6ec8e90c487c7c2bda99b.zip
community/go: update to go 1.6
-rw-r--r--community/go/APKBUILD28
-rw-r--r--community/go/default-sc-getpw-r-size-max.patch57
-rw-r--r--community/go/no-pic.patch2
3 files changed, 13 insertions, 74 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index 7db7178f75..bdc53d562b 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -1,9 +1,9 @@
1# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net> 1# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
2# Maintainer: Eivind Uggedal <eivind@uggedal.com> 2# Maintainer: Eivind Uggedal <eivind@uggedal.com>
3pkgname=go 3pkgname=go
4pkgver=1.5.3 4pkgver=1.6
5# This should be the latest commit on the corresponding release branch 5# This should be the latest commit on the corresponding release branch
6_toolsver="d02228d1857b9f49cd0252788516ff5584266eb6" 6_toolsver="c887be1b2ebd11663d4bf2fbca508c449172339e"
7pkgrel=0 7pkgrel=0
8pkgdesc="Go programming language compiler" 8pkgdesc="Go programming language compiler"
9url="http://www.golang.org/" 9url="http://www.golang.org/"
@@ -17,8 +17,7 @@ install=""
17subpackages="$pkgname-doc $pkgname-tools $pkgname-cross" 17subpackages="$pkgname-doc $pkgname-tools $pkgname-cross"
18source="http://golang.org/dl/go${pkgver}.src.tar.gz 18source="http://golang.org/dl/go${pkgver}.src.tar.gz
19 $pkgname-tools-$pkgver.tar.gz::https://github.com/golang/tools/archive/${_toolsver}.tar.gz 19 $pkgname-tools-$pkgver.tar.gz::https://github.com/golang/tools/archive/${_toolsver}.tar.gz
20 no-pic.patch 20 no-pic.patch"
21 default-sc-getpw-r-size-max.patch"
22 21
23# NOTE: building go for x86 with grsec kernel requires: 22# NOTE: building go for x86 with grsec kernel requires:
24# sysctl -w kernel.modify_ldt=1 23# sysctl -w kernel.modify_ldt=1
@@ -136,15 +135,12 @@ cross() {
136 done 135 done
137} 136}
138 137
139md5sums="80a0eac7ab750b01b3f7096a1d4667b8 go1.5.3.src.tar.gz 138md5sums="e67833ea37fbc002fbe38efe6c1bcd98 go1.6.src.tar.gz
140c64b28ba5df8499bcc19adc995da991a go-tools-1.5.3.tar.gz 139733a96b59562ed84ff552542f16a3ab3 go-tools-1.6.tar.gz
141b303cb36017c5f1303b1567b31b48de3 no-pic.patch 140efa8ac40fa8429f7cd6f23eca05a0a0f no-pic.patch"
14212a36502180b9801f8d9e60824563c92 default-sc-getpw-r-size-max.patch" 141sha256sums="a96cce8ce43a9bf9b2a4c7d470bc7ee0cb00410da815980681c8353218dcf146 go1.6.src.tar.gz
143sha256sums="754e06dab1c31ab168fc9db9e32596734015ea9e24bc44cae7f237f417ce4efe go1.5.3.src.tar.gz 142955e5a119babad356d9cf00cdaaf3c27648d4451109b467c872fad8cc94d5b56 go-tools-1.6.tar.gz
14480db6fc563df50eb924dbf4f96cef287fc6b89cc8b98595c1dac3c80a118f290 go-tools-1.5.3.tar.gz 1431eb60ded9035e9692e4c17b2bb6e9c073e21261eaafa56ee0528d5d2c43a936d no-pic.patch"
145973144c68d10cdc740501ad814841912bae7c3936480fabb3f7fe092ba82ba7f no-pic.patch 144sha512sums="59e9d72a80558fd5e3f176e068897a45333b36e35f6c00393647941a70e741168e65941b6059397378020c3b78ec3471a48809682f7efd97cf33eec6325fc3e8 go1.6.src.tar.gz
14670f8f9b3ad6b8639db2b401ae14747a6e8d762443ca054c358a5aa4815df7d1f default-sc-getpw-r-size-max.patch" 145955def7cc3e5ceb5d8e47477400007d32c25f3bc2764f04a0451bd0235af507e63a0966d201a345f51ac764471da8620b5357d1099ec39e2422bd04d25fd71b8 go-tools-1.6.tar.gz
147sha512sums="b348832ea7cb095cf793960cf9f4da5e9f6ca8de7b5262bb819de97efea4835643e30a18efd4a82d01ea3854a1905af9e134271716c4b68c9d2a8f6e15f65ff0 go1.5.3.src.tar.gz 14651e4c3ee0cda98090db5d00468072bcbf5f0a1a429dd8dedddccaa1467b285f724b012be96d329566b195470bea0aaf4b464e8ba6d2029b0dd42678a7a14b663 no-pic.patch"
14880813c2da74c7b25fa2cfd15b2505757e7f466469ac701cb22d190dc83a607f091c4dea207a2e371e53d7a1f5459e7b53e5eea53c95565e958a6eb7fcb212359 go-tools-1.5.3.tar.gz
149e21084dc07a74c7b6437ae22034b62e3a255692d32dba767c15efdb123d3159c03a02437a41350e512eaa2478a7afbd8b409317a779c56ee4939512d060d57fa no-pic.patch
150d59c977341b9ab15664b4b0c4f3df9e74ce48ffbd59594a7abb5a0907469f9d362c4e558606dd4b7cd102c165dd53027bae6aa1c48623c2105461dcad4cee14d default-sc-getpw-r-size-max.patch"
diff --git a/community/go/default-sc-getpw-r-size-max.patch b/community/go/default-sc-getpw-r-size-max.patch
deleted file mode 100644
index 77be27d13d..0000000000
--- a/community/go/default-sc-getpw-r-size-max.patch
+++ /dev/null
@@ -1,57 +0,0 @@
1From cb867d2fd64adc851f82be3c6eb6e38ec008930b Mon Sep 17 00:00:00 2001
2From: Dominik Honnef <dominik@honnef.co>
3Date: Sun, 21 Jun 2015 20:07:29 +0200
4Subject: [PATCH] os/user: don't depend on _SC_GETPW_R_SIZE_MAX on Linux
5
6Even Linux systems may not have _SC_GETPW_R_SIZE_MAX if using a
7different libc than glibc (e.g. musl). Instead of having special-cases
8for the BSDs, handle -1 correctly by always using a default buffer size.
9
10Fixes #11319.
11
12Change-Id: I8b1b260eb9830e6dbe7667f3f33d115ae4de4ce8
13Reviewed-on: https://go-review.googlesource.com/13772
14Reviewed-by: Brad Fitzpatrick <bradfitz@golang.org>
15Run-TryBot: Brad Fitzpatrick <bradfitz@golang.org>
16---
17 src/os/user/lookup_unix.go | 19 ++++++++-----------
18 1 file changed, 8 insertions(+), 11 deletions(-)
19
20diff --git a/src/os/user/lookup_unix.go b/src/os/user/lookup_unix.go
21index f4f603e..e8a1eb1 100644
22--- a/src/os/user/lookup_unix.go
23+++ b/src/os/user/lookup_unix.go
24@@ -9,7 +9,6 @@ package user
25
26 import (
27 "fmt"
28- "runtime"
29 "strconv"
30 "strings"
31 "syscall"
32@@ -55,17 +54,15 @@ func lookupUnix(uid int, username string, lookupByName bool) (*User, error) {
33 var pwd C.struct_passwd
34 var result *C.struct_passwd
35
36- var bufSize C.long
37- if runtime.GOOS == "dragonfly" || runtime.GOOS == "freebsd" {
38- // DragonFly and FreeBSD do not have _SC_GETPW_R_SIZE_MAX
39- // and just return -1. So just use the same
40- // size that Linux returns.
41+ bufSize := C.sysconf(C._SC_GETPW_R_SIZE_MAX)
42+ if bufSize == -1 {
43+ // DragonFly and FreeBSD do not have _SC_GETPW_R_SIZE_MAX.
44+ // Additionally, not all Linux systems have it, either. For
45+ // example, the musl libc returns -1.
46 bufSize = 1024
47- } else {
48- bufSize = C.sysconf(C._SC_GETPW_R_SIZE_MAX)
49- if bufSize <= 0 || bufSize > 1<<20 {
50- return nil, fmt.Errorf("user: unreasonable _SC_GETPW_R_SIZE_MAX of %d", bufSize)
51- }
52+ }
53+ if bufSize <= 0 || bufSize > 1<<20 {
54+ return nil, fmt.Errorf("user: unreasonable _SC_GETPW_R_SIZE_MAX of %d", bufSize)
55 }
56 buf := C.malloc(C.size_t(bufSize))
57 defer C.free(buf)
diff --git a/community/go/no-pic.patch b/community/go/no-pic.patch
index 5a4e3966d6..db1f809dcc 100644
--- a/community/go/no-pic.patch
+++ b/community/go/no-pic.patch
@@ -2,7 +2,7 @@ diff --git a/src/cmd/link/internal/ld/lib.go b/src/cmd/link/internal/ld/lib.go
2index 8ccbec9dd634..4e96bfadc260 100644 2index 8ccbec9dd634..4e96bfadc260 100644
3--- a/src/cmd/link/internal/ld/lib.go 3--- a/src/cmd/link/internal/ld/lib.go
4+++ b/src/cmd/link/internal/ld/lib.go 4+++ b/src/cmd/link/internal/ld/lib.go
5@@ -1071,6 +1071,11 @@ func hostlink() { 5@@ -1194,6 +1194,11 @@ func hostlink() {
6 argv = append(argv, peimporteddlls()...) 6 argv = append(argv, peimporteddlls()...)
7 } 7 }
8 8