aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Angelacos <nangel@tetrasec.net>2010-08-13 00:53:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-08-13 07:40:13 +0000
commit952934d8b0c304ba8710fdebcc707151b26c08c9 (patch)
tree4af9f87eda449ed9e62fd69b97442b6950af4e47
parente5dc46c0d8922d52d27ecf46945fded98c0289a5 (diff)
downloadalpine_aports-952934d8b0c304ba8710fdebcc707151b26c08c9.tar.bz2
alpine_aports-952934d8b0c304ba8710fdebcc707151b26c08c9.tar.xz
alpine_aports-952934d8b0c304ba8710fdebcc707151b26c08c9.zip
testing/flashrom: new aport
A utility for identifying, reading, writing, verifying and erasing flash chips http://www.flashrom.org/Flashrom
-rw-r--r--testing/flashrom/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/flashrom/APKBUILD b/testing/flashrom/APKBUILD
new file mode 100644
index 0000000000..62420605a3
--- /dev/null
+++ b/testing/flashrom/APKBUILD
@@ -0,0 +1,31 @@
1Contributor: nangel@tetrasec.net
2# Maintainer:
3pkgname=flashrom
4pkgver=0.9.2
5pkgrel=0
6pkgdesc="A utility for identifying, reading, writing, verifying and erasing flash chips"
7url="http://www.flashrom.org/Flashrom"
8license="GPL"
9depends=
10makedepends=pciutils-dev
11subpackages="$pkgname-doc"
12source="http://qa.coreboot.org/releases/flashrom-0.9.2.tar.bz2"
13
14_builddir="$srcdir"/$pkgname-$pkgver
15
16prepare() {
17 cd "$_builddir"
18 # apply patches here
19}
20
21build() {
22 cd "$_builddir"
23 make PREFIX=/usr/ || return 1
24}
25
26package() {
27 cd "$_builddir"
28 make PREFIX="$pkgdir/usr/" install
29}
30
31md5sums="21751b4ea93c5a82c725adae7b63014a flashrom-0.9.2.tar.bz2"