aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Manison <amanison@anselsystems.com>2010-04-20 15:03:46 +0000
committerAndrew Manison <amanison@anselsystems.com>2010-04-20 15:03:46 +0000
commit0e1bf50148e1802f3f010d5df4354de0c56924d2 (patch)
treee67a7937d0a7fcc396ff200e4f5d4cc6c0d48896
parent6b9044eb7969664e8d617131f92639da36d76f09 (diff)
parentdc8e5ec0a58e861e56e01e5f444248a3b1104c83 (diff)
downloadalpine_aports-0e1bf50148e1802f3f010d5df4354de0c56924d2.tar.bz2
alpine_aports-0e1bf50148e1802f3f010d5df4354de0c56924d2.tar.xz
alpine_aports-0e1bf50148e1802f3f010d5df4354de0c56924d2.zip
Merge remote branch 'alpine/master'
-rw-r--r--main/aumix/APKBUILD15
-rw-r--r--main/cdrkit/APKBUILD2
-rw-r--r--main/dhcp/APKBUILD4
-rw-r--r--main/ez-ipupdate/APKBUILD20
-rw-r--r--main/ez-ipupdate/errno.patch56
-rw-r--r--main/libspf2/0001-provide-dn_skipname.patch120
-rw-r--r--main/libspf2/APKBUILD26
-rw-r--r--main/mlmmj/APKBUILD11
-rw-r--r--main/procps/APKBUILD3
-rw-r--r--main/strace/APKBUILD12
-rw-r--r--main/unixodbc/APKBUILD7
-rw-r--r--main/xchat/APKBUILD5
-rw-r--r--main/xchat/depreciated-macros.patch57
13 files changed, 314 insertions, 24 deletions
diff --git a/main/aumix/APKBUILD b/main/aumix/APKBUILD
index 679b87bdfa..1e455850d0 100644
--- a/main/aumix/APKBUILD
+++ b/main/aumix/APKBUILD
@@ -1,7 +1,7 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=aumix 2pkgname=aumix
3pkgver=2.8 3pkgver=2.8
4pkgrel=1 4pkgrel=2
5pkgdesc="A color text mode sound mixer" 5pkgdesc="A color text mode sound mixer"
6url="http://www.jpj.net/~trevor/aumix.html" 6url="http://www.jpj.net/~trevor/aumix.html"
7license="GPL" 7license="GPL"
@@ -14,13 +14,18 @@ source="http://jpj.net/~trevor/aumix/aumix-$pkgver.tar.bz2
14 aumix.initd 14 aumix.initd
15 " 15 "
16 16
17build() { 17prepare() {
18 cd "$srcdir"/aumix-$pkgver 18 cd "$srcdir"/aumix-$pkgver
19 for i in ../*.patch; do 19 for i in ../*.patch; do
20 msg "Applying $i..." 20 msg "Applying $i..."
21 patch -p1 < $i || return 1 21 patch -p1 < $i || return 1
22 done 22 done
23 23
24 sed -i -e '/USE_NLS=yes/d' configure || return 1
25}
26
27build() {
28 cd "$srcdir"/aumix-$pkgver
24 ./configure --prefix=/usr \ 29 ./configure --prefix=/usr \
25 --mandir=/usr/share/man \ 30 --mandir=/usr/share/man \
26 --without-gtk1 \ 31 --without-gtk1 \
@@ -28,7 +33,11 @@ build() {
28 --disable-nls 33 --disable-nls
29 34
30 make || return 1 35 make || return 1
31 make DESTDIR="$pkgdir" install || return 1 36}
37
38package() {
39 cd "$srcdir"/aumix-$pkgver
40 make -j1 DESTDIR="$pkgdir" install || return 1
32 install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/aumix 41 install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/aumix
33} 42}
34md5sums="dc3fc7209752207c23e7c94ab886b340 aumix-2.8.tar.bz2 43md5sums="dc3fc7209752207c23e7c94ab886b340 aumix-2.8.tar.bz2
diff --git a/main/cdrkit/APKBUILD b/main/cdrkit/APKBUILD
index 929f06fa2c..ce5f9830e1 100644
--- a/main/cdrkit/APKBUILD
+++ b/main/cdrkit/APKBUILD
@@ -6,7 +6,7 @@ pkgdesc="Suite of programs for CD/DVD recording, ISO image creation, and audio C
6url="http://cdrkit.org/" 6url="http://cdrkit.org/"
7license="GPL2" 7license="GPL2"
8depends="file bzip2" 8depends="file bzip2"
9makedepends="cmake libcap-dev bzip2-dev zlib-dev" 9makedepends="cmake libcap-dev bzip2-dev zlib-dev !libiconv"
10source="http://$pkgname.org/releases/$pkgname-$pkgver.tar.gz" 10source="http://$pkgname.org/releases/$pkgname-$pkgver.tar.gz"
11subpackages="$pkgname-doc" 11subpackages="$pkgname-doc"
12 12
diff --git a/main/dhcp/APKBUILD b/main/dhcp/APKBUILD
index ab15af69bd..517815a2c0 100644
--- a/main/dhcp/APKBUILD
+++ b/main/dhcp/APKBUILD
@@ -2,7 +2,7 @@
2pkgname=dhcp 2pkgname=dhcp
3pkgver=4.1.0_p1 3pkgver=4.1.0_p1
4_realver=4.1.0p1 4_realver=4.1.0p1
5pkgrel=8 5pkgrel=9
6pkgdesc="ISC Dynamic Host Configuration Protocol (DHCP)" 6pkgdesc="ISC Dynamic Host Configuration Protocol (DHCP)"
7url="https://www.isc.org/" 7url="https://www.isc.org/"
8license="GPL" 8license="GPL"
@@ -26,6 +26,8 @@ prepare() {
26 26
27build() { 27build() {
28 cd "$srcdir/$pkgname-$_realver" 28 cd "$srcdir/$pkgname-$_realver"
29 # fix ipv6
30 export CFLAGS="$CFLAGS -D_GNU_SOURCE"
29 ./configure --prefix=/usr \ 31 ./configure --prefix=/usr \
30 --sysconfdir=/etc/dhcp \ 32 --sysconfdir=/etc/dhcp \
31 --with-cli-pid-file=/var/run/dhcp/dhclient.pid \ 33 --with-cli-pid-file=/var/run/dhcp/dhclient.pid \
diff --git a/main/ez-ipupdate/APKBUILD b/main/ez-ipupdate/APKBUILD
index 33cb03ea17..9da9730560 100644
--- a/main/ez-ipupdate/APKBUILD
+++ b/main/ez-ipupdate/APKBUILD
@@ -2,7 +2,7 @@
2# Maintainer: Jeremy Thomerson <jeremy@thomersonfamily.com> 2# Maintainer: Jeremy Thomerson <jeremy@thomersonfamily.com>
3pkgname=ez-ipupdate 3pkgname=ez-ipupdate
4pkgver=3.0.10 4pkgver=3.0.10
5pkgrel=1 5pkgrel=0
6pkgdesc="utility for updating your host name for many of the dynamic DNS services (ez-ip.net, dyndns.org, etc)" 6pkgdesc="utility for updating your host name for many of the dynamic DNS services (ez-ip.net, dyndns.org, etc)"
7url="http://ez-ipupdate.com/" 7url="http://ez-ipupdate.com/"
8license="GPL" 8license="GPL"
@@ -13,16 +13,27 @@ subpackages=""
13source="http://ez-ipupdate.com/dist/$pkgname-$pkgver.tar.gz 13source="http://ez-ipupdate.com/dist/$pkgname-$pkgver.tar.gz
14 ez-ipupdate.confd 14 ez-ipupdate.confd
15 ez-ipupdate.initd 15 ez-ipupdate.initd
16 errno.patch
16 " 17 "
18_builddir="$srcdir"/$pkgname-$pkgver
19prepare() {
20 cd "$_builddir"
21 for A in ../*.patch ; do
22 patch -p1 < $A
23 done
24}
17 25
18build() { 26build() {
19 cd "$srcdir"/$pkgname-$pkgver 27 cd "$_builddir"
20
21 ./configure --prefix=/usr \ 28 ./configure --prefix=/usr \
22 --sysconfdir=/etc \ 29 --sysconfdir=/etc \
23 --mandir=/usr/share/man \ 30 --mandir=/usr/share/man \
24 --infodir=/usr/share/info 31 --infodir=/usr/share/info
25 make || return 1 32 make || return 1
33}
34
35package() {
36 cd "$_builddir"
26 make DESTDIR="$pkgdir" install 37 make DESTDIR="$pkgdir" install
27 38
28 install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname 39 install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
@@ -33,4 +44,5 @@ build() {
33 44
34md5sums="6505c9d18ef6b5ce13fe2a668eb5724b ez-ipupdate-3.0.10.tar.gz 45md5sums="6505c9d18ef6b5ce13fe2a668eb5724b ez-ipupdate-3.0.10.tar.gz
35e6e06780b1896f2250132cc16cd10710 ez-ipupdate.confd 46e6e06780b1896f2250132cc16cd10710 ez-ipupdate.confd
366b9ce71b7b6b739794f003b2ebbf66ed ez-ipupdate.initd" 476b9ce71b7b6b739794f003b2ebbf66ed ez-ipupdate.initd
481fede0dcb5d9ca108855df0a9d213413 errno.patch"
diff --git a/main/ez-ipupdate/errno.patch b/main/ez-ipupdate/errno.patch
new file mode 100644
index 0000000000..fea5258072
--- /dev/null
+++ b/main/ez-ipupdate/errno.patch
@@ -0,0 +1,56 @@
1# --- T2-COPYRIGHT-NOTE-BEGIN ---
2# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
3#
4# T2 SDE: package/.../ezipupdate/errno.patch
5# Copyright (C) 2004 - 2005 The T2 SDE Project
6# Copyright (C) 1998 - 2003 ROCK Linux Project
7#
8# More information can be found in the files COPYING and README.
9#
10# This patch file is dual-licensed. It is available under the license the
11# patched project is licensed under, as long as it is an OpenSource license
12# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
13# of the GNU General Public License as published by the Free Software
14# Foundation; either version 2 of the License, or (at your option) any later
15# version.
16# --- T2-COPYRIGHT-NOTE-END ---
17
18--- ./conf_file.c.orig 2000-10-23 04:36:18.000000000 +0200
19+++ ./conf_file.c 2003-05-28 08:42:42.000000000 +0200
20@@ -1,4 +1,4 @@
21-/* ============================================================================
22+ /* ============================================================================
23 * Copyright (C) 1999 Angus Mackay. All rights reserved;
24 *
25 * This program is free software; you can redistribute it and/or modify
26@@ -37,13 +37,16 @@
27
28 #include <conf_file.h>
29
30-#if HAVE_STRERROR
31+#if HAVE_ERRNO_H
32+# include <errno.h>
33+#elif HAVE_STRERROR
34 extern int errno;
35 # define error_string strerror(errno)
36-#elif HAVE_SYS_ERRLIST
37-extern const char *const sys_errlist[];
38-extern int errno;
39-# define error_string (sys_errlist[errno])
40+#endif
41+
42+#if HAVE_SYS_ERRLIST
43+//extern char *const strerror[];
44+# define error_string (strerror[errno])
45 #else
46 # define error_string "error message not found"
47 #endif
48@@ -85,7 +88,7 @@ int parse_conf_file(char *fname, struct
49 {
50 if((in=fopen(fname, "r")) == NULL)
51 {
52- fprintf(stderr, "could not open config file \"%s\": %s\n", fname, error_string);
53+ fprintf(stderr, "could not open config file \"%s\"\n", fname);
54 return(-1);
55 }
56 }
diff --git a/main/libspf2/0001-provide-dn_skipname.patch b/main/libspf2/0001-provide-dn_skipname.patch
new file mode 100644
index 0000000000..feb46efa68
--- /dev/null
+++ b/main/libspf2/0001-provide-dn_skipname.patch
@@ -0,0 +1,120 @@
1From abfd38dbff2be2e63ee222a87b4f24de5573e7eb Mon Sep 17 00:00:00 2001
2From: Natanael Copa <natanael.copa@gmail.com>
3Date: Mon, 19 Apr 2010 14:53:35 +0000
4Subject: [PATCH] provide dn_skipname
5
6---
7 configure.ac | 3 +-
8 src/libreplace/__dn_skipname.c | 87 ++++++++++++++++++++++++++++++++++++++++
9 2 files changed, 89 insertions(+), 1 deletions(-)
10 create mode 100644 src/libreplace/__dn_skipname.c
11
12diff --git a/configure.ac b/configure.ac
13index 310d73c..8a0dd2b 100644
14--- a/configure.ac
15+++ b/configure.ac
16@@ -272,7 +273,7 @@ AC_CHECK_FUNCS([strcasecmp strncasecmp strspn strtoul])
17 AC_CHECK_FUNCS([gethostbyname inet_ntoa select strrchr strstr strtol])
18
19 AC_REPLACE_FUNCS([getopt_long_only strncasecmp])
20-AC_REPLACE_FUNCS([__ns_initparse __ns_name_uncompress __ns_get16 __ns_msg_getflag])
21+AC_REPLACE_FUNCS([__ns_initparse __ns_name_uncompress __ns_get16 __ns_msg_getflag __dn_skipname])
22
23 AC_CONFIG_FILES([Makefile
24 Doxyfile
25diff --git a/src/libreplace/__dn_skipname.c b/src/libreplace/__dn_skipname.c
26new file mode 100644
27index 0000000..88d48b5
28--- /dev/null
29+++ b/src/libreplace/__dn_skipname.c
30@@ -0,0 +1,87 @@
31+/* taken from OpenBSD source */
32+/*
33+ * ++Copyright++ 1985, 1993
34+ * -
35+ * Copyright (c) 1985, 1993
36+ * The Regents of the University of California. All rights reserved.
37+ *
38+ * Redistribution and use in source and binary forms, with or without
39+ * modification, are permitted provided that the following conditions
40+ * are met:
41+ * 1. Redistributions of source code must retain the above copyright
42+ * notice, this list of conditions and the following disclaimer.
43+ * 2. Redistributions in binary form must reproduce the above copyright
44+ * notice, this list of conditions and the following disclaimer in the
45+ * documentation and/or other materials provided with the distribution.
46+ * 3. Neither the name of the University nor the names of its contributors
47+ * may be used to endorse or promote products derived from this software
48+ * without specific prior written permission.
49+ *
50+ * THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
51+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
52+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
53+ * ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
54+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
55+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
56+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
57+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
58+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
59+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
60+ * SUCH DAMAGE.
61+ * -
62+ * Portions Copyright (c) 1993 by Digital Equipment Corporation.
63+ *
64+ * Permission to use, copy, modify, and distribute this software for any
65+ * purpose with or without fee is hereby granted, provided that the above
66+ * copyright notice and this permission notice appear in all copies, and that
67+ * the name of Digital Equipment Corporation not be used in advertising or
68+ * publicity pertaining to distribution of the document or software without
69+ * specific, written prior permission.
70+ *
71+ * THE SOFTWARE IS PROVIDED "AS IS" AND DIGITAL EQUIPMENT CORP. DISCLAIMS ALL
72+ * WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES
73+ * OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL DIGITAL EQUIPMENT
74+ * CORPORATION BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL
75+ * DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR
76+ * PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS
77+ * ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS
78+ * SOFTWARE.
79+ * -
80+ * --Copyright--
81+ */
82+
83+/*
84+ * Skip over a compressed domain name. Return the size or -1.
85+ */
86+#include <sys/types.h>
87+#include <resolv.h>
88+
89+int
90+__dn_skipname(const u_char *comp_dn, const u_char *eom)
91+{
92+ const u_char *cp;
93+ int n;
94+
95+ cp = comp_dn;
96+ while (cp < eom && (n = *cp++)) {
97+ /*
98+ * check for indirection
99+ */
100+ switch (n & INDIR_MASK) {
101+ case 0: /* normal case, n == len */
102+ cp += n;
103+ continue;
104+ case INDIR_MASK: /* indirection */
105+ cp++;
106+ break;
107+ default: /* illegal type */
108+ return (-1);
109+ }
110+ break;
111+ }
112+ if (cp > eom)
113+ return (-1);
114+ return (cp - comp_dn);
115+}
116+
117+
118--
1191.7.0.4
120
diff --git a/main/libspf2/APKBUILD b/main/libspf2/APKBUILD
index 266147d8d6..da5ba38415 100644
--- a/main/libspf2/APKBUILD
+++ b/main/libspf2/APKBUILD
@@ -1,29 +1,41 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=libspf2 2pkgname=libspf2
3pkgver=1.2.9 3pkgver=1.2.9
4pkgrel=0 4pkgrel=1
5pkgdesc="Sender Policy Framework library, a part of the SPF/SRS protocol pair." 5pkgdesc="Sender Policy Framework library, a part of the SPF/SRS protocol pair."
6url="http://www.libspf2.org" 6url="http://www.libspf2.org"
7license="LGPL-2.1 BSD-2" 7license="LGPL-2.1 BSD-2"
8subpackages="$pkgname-dev" 8subpackages="$pkgname-dev"
9makedepends= 9makedepends="autoconf automake libtool bind-dev"
10depends= 10depends=
11source="http://www.libspf2.org/spf/libspf2-$pkgver.tar.gz 11source="http://www.libspf2.org/spf/libspf2-$pkgver.tar.gz
12 libspf2-localpolicy-fix.patch" 12 libspf2-localpolicy-fix.patch
13 0001-provide-dn_skipname.patch
14 "
13 15
14 16_builddir="$srcdir"/$pkgname-$pkgver
15build() { 17prepare() {
16 cd "$srcdir"/$pkgname-$pkgver 18 cd "$_builddir"
17 for i in ../*.patch; do 19 for i in ../*.patch; do
18 msg "Apply $i" 20 msg "Apply $i"
19 patch -p1 < $i || return 1 21 patch -p1 < $i || return 1
20 done 22 done
23 libtoolize --force && aclocal && automake && autoconf && autoheader
24}
25
26build() {
27 cd "$_builddir"
21 ./configure --prefix=/usr \ 28 ./configure --prefix=/usr \
22 || return 1 29 || return 1
23 # uclibc claims to have res_ninit() but it doesnt. 30 # uclibc claims to have res_ninit() but it doesnt.
24 sed -i -e 's:HAVE_DECL_RES_NINIT 1:HAVE_DECL_RES_NINIT 0:' config.h 31 sed -i -e 's:HAVE_DECL_RES_NINIT 1:HAVE_DECL_RES_NINIT 0:' config.h
25 make || return 1 32 make || return 1
33}
34
35package() {
36 cd "$_builddir"
26 make DESTDIR="$pkgdir" install || return 1 37 make DESTDIR="$pkgdir" install || return 1
27} 38}
28md5sums="3305df4d1b13ca964d80b23bb5e4e2b6 libspf2-1.2.9.tar.gz 39md5sums="3305df4d1b13ca964d80b23bb5e4e2b6 libspf2-1.2.9.tar.gz
2948d82a6af8c513d75a7402f2933b8b0a libspf2-localpolicy-fix.patch" 4048d82a6af8c513d75a7402f2933b8b0a libspf2-localpolicy-fix.patch
41201889cbd209aa7cae9ce11ed5ebaaa6 0001-provide-dn_skipname.patch"
diff --git a/main/mlmmj/APKBUILD b/main/mlmmj/APKBUILD
index 96649fd6b6..6ac4d1620f 100644
--- a/main/mlmmj/APKBUILD
+++ b/main/mlmmj/APKBUILD
@@ -1,19 +1,24 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=mlmmj 2pkgname=mlmmj
3pkgver=1.2.16 3pkgver=1.2.16
4pkgrel=0 4pkgrel=1
5pkgdesc="Mailing list managing made joyful" 5pkgdesc="Mailing list managing made joyful"
6url="http://mlmmj.org/" 6url="http://mlmmj.org/"
7license="MIT" 7license="MIT"
8subpackages="$pkgname-doc" 8subpackages="$pkgname-doc"
9depends="uclibc" 9depends=
10makedepends=
10source="http://mlmmj.mmj.dk/files/$pkgname-$pkgver.tar.bz2 " 11source="http://mlmmj.mmj.dk/files/$pkgname-$pkgver.tar.bz2 "
11 12
12build() { 13build() {
13 cd "$srcdir"/$pkgname-$pkgver 14 cd "$srcdir"/$pkgname-$pkgver
14 15
15 configure --prefix=/usr 16 ./configure --prefix=/usr
16 make || return 1 17 make || return 1
18}
19
20package() {
21 cd "$srcdir"/$pkgname-$pkgver
17 make -j1 DESTDIR="$pkgdir" install || return 1 22 make -j1 DESTDIR="$pkgdir" install || return 1
18 install -d "$pkgdir"/usr/share/mlmmj/texts 23 install -d "$pkgdir"/usr/share/mlmmj/texts
19 cp -r listtexts/* "$pkgdir"/usr/share/mlmmj/texts/ 24 cp -r listtexts/* "$pkgdir"/usr/share/mlmmj/texts/
diff --git a/main/procps/APKBUILD b/main/procps/APKBUILD
index f0f169779a..2a3accd622 100644
--- a/main/procps/APKBUILD
+++ b/main/procps/APKBUILD
@@ -24,7 +24,8 @@ build() {
24 24
25package() { 25package() {
26 cd "$srcdir"/$pkgname-$pkgver 26 cd "$srcdir"/$pkgname-$pkgver
27 make DESTDIR="$pkgdir" ldconfig=true install || return 1 27 make DESTDIR="$pkgdir" ldconfig=true install="/bin/install -D" \
28 install || return 1
28 install -d "$pkgdir"/usr/include/proc || return 1 29 install -d "$pkgdir"/usr/include/proc || return 1
29 install -m644 proc/*.h "$pkgdir"/usr/include/proc/ || return 1 30 install -m644 proc/*.h "$pkgdir"/usr/include/proc/ || return 1
30} 31}
diff --git a/main/strace/APKBUILD b/main/strace/APKBUILD
index 40965ec9d2..d7a10cfd64 100644
--- a/main/strace/APKBUILD
+++ b/main/strace/APKBUILD
@@ -1,20 +1,28 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=strace 2pkgname=strace
3pkgver=4.5.19 3pkgver=4.5.19
4pkgrel=0 4pkgrel=1
5pkgdesc="A useful diagnositic, instructional, and debugging tool" 5pkgdesc="A useful diagnositic, instructional, and debugging tool"
6url="http://sourceforge.net/projects/strace/" 6url="http://sourceforge.net/projects/strace/"
7license="BSD" 7license="BSD"
8depends="uclibc" 8depends=
9makedepends=
9source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2" 10source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2"
10subpackages="$pkgname-doc" 11subpackages="$pkgname-doc"
11 12
12build () 13build ()
13{ 14{
14 cd "$srcdir/$pkgname-$pkgver" 15 cd "$srcdir/$pkgname-$pkgver"
16 #changes in kernel headers in 2.6.32
17 sed -i -e 's/include <linux\/socket.h>/include <sys\/socket.h>/g' \
18 configure
15 ./configure --prefix=/usr \ 19 ./configure --prefix=/usr \
16 20
17 make || return 1 21 make || return 1
22}
23
24package() {
25 cd "$srcdir/$pkgname-$pkgver"
18 make -j1 DESTDIR="$pkgdir" install 26 make -j1 DESTDIR="$pkgdir" install
19} 27}
20md5sums="2415e435d61e40315a298c80aced0cda strace-4.5.19.tar.bz2" 28md5sums="2415e435d61e40315a298c80aced0cda strace-4.5.19.tar.bz2"
diff --git a/main/unixodbc/APKBUILD b/main/unixodbc/APKBUILD
index cd72a16537..e0ed27c971 100644
--- a/main/unixodbc/APKBUILD
+++ b/main/unixodbc/APKBUILD
@@ -2,7 +2,7 @@
2# Maintainer: Carlo Landmeter <clandmeter@gmail.com> 2# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
3pkgname=unixodbc 3pkgname=unixodbc
4pkgver=2.2.14 4pkgver=2.2.14
5pkgrel=0 5pkgrel=1
6pkgdesc="ODBC is an open specification to access Data Sources" 6pkgdesc="ODBC is an open specification to access Data Sources"
7url="http://www.unixodbc.org/" 7url="http://www.unixodbc.org/"
8license="GPL2" 8license="GPL2"
@@ -18,8 +18,13 @@ build() {
18 --sysconfdir=/etc \ 18 --sysconfdir=/etc \
19 --mandir=/usr/share/man \ 19 --mandir=/usr/share/man \
20 --infodir=/usr/share/info \ 20 --infodir=/usr/share/info \
21 --disable-nls \
21 --enable-gui=no 22 --enable-gui=no
22 make || return 1 23 make || return 1
24}
25
26package() {
27 cd "$srcdir/unixODBC-$pkgver"
23 make -j1 DESTDIR="$pkgdir" install 28 make -j1 DESTDIR="$pkgdir" install
24 29
25} 30}
diff --git a/main/xchat/APKBUILD b/main/xchat/APKBUILD
index 96486e27cb..cb4bdbef65 100644
--- a/main/xchat/APKBUILD
+++ b/main/xchat/APKBUILD
@@ -1,7 +1,7 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=xchat 2pkgname=xchat
3pkgver=2.8.6 3pkgver=2.8.6
4pkgrel=1 4pkgrel=2
5pkgdesc="A GTK+ based IRC client" 5pkgdesc="A GTK+ based IRC client"
6url="http://www.xchat.org/" 6url="http://www.xchat.org/"
7license="GPL" 7license="GPL"
@@ -9,12 +9,14 @@ makedepends="pkgconfig gtk+-dev openssl-dev dbus-glib-dev perl-dev
9 libxext-dev" 9 libxext-dev"
10source="http://www.$pkgname.org/files/source/2.8/$pkgname-$pkgver.tar.bz2 10source="http://www.$pkgname.org/files/source/2.8/$pkgname-$pkgver.tar.bz2
11 http://www.$pkgname.org/files/source/2.8/patches/xc286-smallfixes.diff 11 http://www.$pkgname.org/files/source/2.8/patches/xc286-smallfixes.diff
12 depreciated-macros.patch
12 $pkgname-gtk2.patch" 13 $pkgname-gtk2.patch"
13 14
14_builddir="$srcdir"/$pkgname-$pkgver 15_builddir="$srcdir"/$pkgname-$pkgver
15prepare() { 16prepare() {
16 cd "$_builddir" 17 cd "$_builddir"
17 patch -p1 < ../xc286-smallfixes.diff || return 1 18 patch -p1 < ../xc286-smallfixes.diff || return 1
19 patch -p1 -i "$srcdir"/depreciated-macros.patch || return 1
18 patch -p1 < ../xchat-gtk2.patch || return 1 20 patch -p1 < ../xchat-gtk2.patch || return 1
19} 21}
20 22
@@ -42,4 +44,5 @@ package() {
42 44
43md5sums="1f2670865d43a23a9abc596dde999aca xchat-2.8.6.tar.bz2 45md5sums="1f2670865d43a23a9abc596dde999aca xchat-2.8.6.tar.bz2
44eb68b6261bf6740cb5f223627eb8f384 xc286-smallfixes.diff 46eb68b6261bf6740cb5f223627eb8f384 xc286-smallfixes.diff
47daee42354f95ca54a84248c3cb690fee depreciated-macros.patch
45f3fe00982c0bec93152ed0b32438ef87 xchat-gtk2.patch" 48f3fe00982c0bec93152ed0b32438ef87 xchat-gtk2.patch"
diff --git a/main/xchat/depreciated-macros.patch b/main/xchat/depreciated-macros.patch
new file mode 100644
index 0000000000..1b86be2f1b
--- /dev/null
+++ b/main/xchat/depreciated-macros.patch
@@ -0,0 +1,57 @@
1--- a/src/fe-gtk/fe-gtk.c 2008-02-24 08:39:44.000000000 +0000
2+++ b/src/fe-gtk/fe-gtk.c.new 2010-04-01 18:10:31.840778707 +0000
3@@ -819,7 +819,8 @@
4 switch (info_type)
5 {
6 case 0: /* window status */
7- if (!GTK_WIDGET_VISIBLE (GTK_WINDOW (sess->gui->window)))
8+ if (!gtk_widget_get_visible (GTK_WINDOW (sess->gui->window)))
9+
10 return 2; /* hidden (iconified or systray) */
11 #if GTK_CHECK_VERSION(2,4,0)
12 if (gtk_window_is_active (GTK_WINDOW (sess->gui->window)))
13--- a/src/fe-gtk/menu.c 2008-06-08 07:59:37.000000000 +0000
14+++ b/src/fe-gtk/menu.c.new 2010-04-01 18:15:54.527573869 +0000
15@@ -1670,7 +1670,7 @@
16 menu_canacaccel (GtkWidget *widget, guint signal_id, gpointer user_data)
17 {
18 /* GTK2.2 behaviour */
19- return GTK_WIDGET_IS_SENSITIVE (widget);
20+ return gtk_widget_is_sensitive (widget);
21 }
22
23 #endif
24--- a/src/fe-gtk/maingui.c 2008-04-01 08:53:41.000000000 +0000
25+++ b/src/fe-gtk/maingui.c.new 2010-04-01 18:21:56.400181435 +0000
26@@ -599,7 +599,7 @@
27 int num;
28 GtkWidget *f = NULL;
29
30- if (current_sess && GTK_WIDGET_HAS_FOCUS (current_sess->gui->input_box))
31+ if (current_sess && gtk_widget_has_focus (current_sess->gui->input_box))
32 f = current_sess->gui->input_box;
33
34 num = gtk_notebook_page_num (GTK_NOTEBOOK (mg_gui->note_book), box);
35@@ -809,8 +809,8 @@
36 static void
37 mg_hide_empty_pane (GtkPaned *pane)
38 {
39- if ((pane->child1 == NULL || !GTK_WIDGET_VISIBLE (pane->child1)) &&
40- (pane->child2 == NULL || !GTK_WIDGET_VISIBLE (pane->child2)))
41+ if ((pane->child1 == NULL || !gtk_widget_get_visible (pane->child1)) &&
42+ (pane->child2 == NULL || !gtk_widget_get_visible (pane->child2)))
43 {
44 gtk_widget_hide (GTK_WIDGET (pane));
45 return;
46@@ -2563,9 +2563,9 @@
47 {
48 int handle_size;
49
50-/* if (pane->child1 == NULL || (!GTK_WIDGET_VISIBLE (pane->child1)))
51+/* if (pane->child1 == NULL || (!gtk_widget_get_visible (pane->child1)))
52 return;
53- if (pane->child2 == NULL || (!GTK_WIDGET_VISIBLE (pane->child2)))
54+ if (pane->child2 == NULL || (!gtk_widget_get_visible (pane->child2)))
55 return;*/
56
57 gtk_widget_style_get (GTK_WIDGET (pane), "handle-size", &handle_size, NULL);