aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Manison <amanison@anselsystems.com>2010-07-11 09:43:34 +0000
committerAndrew Manison <amanison@anselsystems.com>2010-07-11 09:43:34 +0000
commit8a781cf9174eb90eac6fe5b630efbe250bf4a47a (patch)
tree49087f5198c90dae7f2edb6c00d9d68125ce0ed3
parent79765211f6541090c4f8e629a34732e9ccaa24fd (diff)
downloadalpine_aports-8a781cf9174eb90eac6fe5b630efbe250bf4a47a.tar.bz2
alpine_aports-8a781cf9174eb90eac6fe5b630efbe250bf4a47a.tar.xz
alpine_aports-8a781cf9174eb90eac6fe5b630efbe250bf4a47a.zip
Fixed bug in definition of CC for make.
-rw-r--r--main/linux-grsec/APKBUILD6
-rw-r--r--main/linux-pae/APKBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index ef73e4958c..b9667cd346 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -75,7 +75,7 @@ menuconfig() {
75 75
76build() { 76build() {
77 cd "$srcdir"/build 77 cd "$srcdir"/build
78 make CC="${CC:--gcc}" \ 78 make CC="${CC:-gcc}" \
79 KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-Alpine" \ 79 KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-Alpine" \
80 || return 1 80 || return 1
81} 81}
@@ -98,13 +98,13 @@ dev() {
98 # kernel modules and install those as /usr/src/linux-headers, 98 # kernel modules and install those as /usr/src/linux-headers,
99 # simlar to what ubuntu does 99 # simlar to what ubuntu does
100 # 100 #
101 # this way you dont need to install the 300-400 kernel sources to 101 # this way you dont need to install the 300-400 kernel sources to
102 # build a tiny kernel module 102 # build a tiny kernel module
103 # 103 #
104 pkgdesc="Headers and script for third party modules for grsec kernel" 104 pkgdesc="Headers and script for third party modules for grsec kernel"
105 local dir="$subpkgdir"/usr/src/linux-headers-${_abi_release} 105 local dir="$subpkgdir"/usr/src/linux-headers-${_abi_release}
106 106
107 # first we import config, run prepare to set up for building 107 # first we import config, run prepare to set up for building
108 # external modules, and create the scripts 108 # external modules, and create the scripts
109 mkdir -p "$dir" 109 mkdir -p "$dir"
110 cp "$srcdir"/$_config "$dir"/.config 110 cp "$srcdir"/$_config "$dir"/.config
diff --git a/main/linux-pae/APKBUILD b/main/linux-pae/APKBUILD
index fa5b0431dd..ca0b084491 100644
--- a/main/linux-pae/APKBUILD
+++ b/main/linux-pae/APKBUILD
@@ -71,7 +71,7 @@ menuconfig() {
71 71
72build() { 72build() {
73 cd "$srcdir"/build 73 cd "$srcdir"/build
74 make CC="${CC:--gcc}" \ 74 make CC="${CC:-gcc}" \
75 KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-Alpine" \ 75 KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-Alpine" \
76 || return 1 76 || return 1
77} 77}
@@ -96,13 +96,13 @@ dev() {
96 # kernel modules and install those as /usr/src/linux-headers, 96 # kernel modules and install those as /usr/src/linux-headers,
97 # simlar to what ubuntu does 97 # simlar to what ubuntu does
98 # 98 #
99 # this way you dont need to install the 300-400 kernel sources to 99 # this way you dont need to install the 300-400 kernel sources to
100 # build a tiny kernel module 100 # build a tiny kernel module
101 # 101 #
102 pkgdesc="Headers and script for third party modules for grsec kernel" 102 pkgdesc="Headers and script for third party modules for grsec kernel"
103 local dir="$subpkgdir"/usr/src/linux-headers-${_abi_release} 103 local dir="$subpkgdir"/usr/src/linux-headers-${_abi_release}
104 104
105 # first we import config, run prepare to set up for building 105 # first we import config, run prepare to set up for building
106 # external modules, and create the scripts 106 # external modules, and create the scripts
107 mkdir -p "$dir" 107 mkdir -p "$dir"
108 cp "$srcdir"/$_config "$dir"/.config 108 cp "$srcdir"/$_config "$dir"/.config