aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-08-02 14:37:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-08-02 14:37:16 +0000
commitdda16dc0689d374e0075f46efafa545c5d03d8fb (patch)
tree999903f1bb68c5146e78a827912e34c190cb56ec
parent0031a7082630ffda720adab5b911bfc663e0d526 (diff)
downloadalpine_aports-dda16dc0689d374e0075f46efafa545c5d03d8fb.tar.bz2
alpine_aports-dda16dc0689d374e0075f46efafa545c5d03d8fb.tar.xz
alpine_aports-dda16dc0689d374e0075f46efafa545c5d03d8fb.zip
testing/py-gtk: new aport
Python bindings for the GTK widget set http://www.pygtk.org/
-rw-r--r--testing/py-gtk/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/py-gtk/APKBUILD b/testing/py-gtk/APKBUILD
new file mode 100644
index 0000000000..d7b65c14c6
--- /dev/null
+++ b/testing/py-gtk/APKBUILD
@@ -0,0 +1,34 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=py-gtk
3pkgver=2.17.0
4pkgrel=0
5pkgdesc="Python bindings for the GTK widget set"
6url="http://www.pygtk.org/"
7license="LGPL"
8depends=
9makedepends="libglade-dev py-cairo-dev py-gobject-dev python-dev"
10source="http://ftp.gnome.org/pub/gnome/sources/pygtk/2.17/pygtk-$pkgver.tar.bz2"
11subpackages="$pkgname-dev $pkgname-doc $pkgname-demo"
12
13_builddir="$srcdir"/pygtk-$pkgver
14build() {
15 cd "$_builddir"
16 ./configure --prefix=/usr || return 1
17 make || return 1
18}
19
20package() {
21 cd "$_builddir"
22 make DESTDIR="$pkgdir" install || return 1
23 install -m644 gtk/gtk-extrafuncs.defs ""$pkgdir"/usr/share/pygtk/2.0/defs/" || return 1
24}
25
26demo() {
27 pkgdesc="Demonstration of pygtk"
28 depends="py-gtk"
29 mkdir -p "$subpkgdir"/usr/bin "$subpkgdir"/usr/lib/pygtk/2.0
30 mv "$pkgdir"/usr/bin/pygtk-demo "$subpkgdir"/usr/bin/
31 mv "$pkgdir"/usr/lib/pygtk/2.0/*demo* \
32 "$subpkgdir"/usr/lib/pygtk/2.0/
33}
34md5sums="43d704343d7ca04a6e4ddd4fa73a3c55 pygtk-2.17.0.tar.bz2"