aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-09-03 14:04:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-09-22 08:56:45 +0000
commit1bf68240087c45f12ba2fc19c1f1981eaf214323 (patch)
treeaaa61eb0b4455e90f76de52ac61ed9dac1a71692
parente6874f53baa0daefc1b331aec2dcdd485753f728 (diff)
downloadalpine_aports-1bf68240087c45f12ba2fc19c1f1981eaf214323.tar.bz2
alpine_aports-1bf68240087c45f12ba2fc19c1f1981eaf214323.tar.xz
alpine_aports-1bf68240087c45f12ba2fc19c1f1981eaf214323.zip
main/icu: fix building with ccache/distcc and bump so we get new version
(cherry picked from commit c240bcc69839d096a399fa3530d44a457ca75f67)
-rw-r--r--main/icu/APKBUILD28
-rw-r--r--main/icu/icu-ccache.patch11
2 files changed, 36 insertions, 3 deletions
diff --git a/main/icu/APKBUILD b/main/icu/APKBUILD
index a2764b8775..8aae187347 100644
--- a/main/icu/APKBUILD
+++ b/main/icu/APKBUILD
@@ -2,17 +2,38 @@
2pkgname=icu 2pkgname=icu
3pkgver=4.4.1 3pkgver=4.4.1
4_ver=4_4_1 4_ver=4_4_1
5pkgrel=2 5pkgrel=3
6pkgdesc="International Components for Unicode library" 6pkgdesc="International Components for Unicode library"
7url="http://www.icu-project.org/" 7url="http://www.icu-project.org/"
8license="custom:icu" 8license="custom:icu"
9subpackages="$pkgname-dev $pkgname-doc" 9subpackages="$pkgname-dev $pkgname-doc"
10depends= 10depends=
11makedepends= 11makedepends=
12source="http://download.icu-project.org/files/icu4c/${pkgver}/${pkgname}4c-$_ver-src.tgz" 12source="http://download.icu-project.org/files/icu4c/${pkgver}/${pkgname}4c-$_ver-src.tgz
13 icu-ccache.patch
14 "
13 15
14_builddir="$srcdir"/icu/source 16_builddir="$srcdir"/icu/source
15 17
18prepare() {
19 cd "$_builddir"
20 local x
21 # https://bugs.icu-project.org/trac/ticket/6102
22 for x in ARFLAGS CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
23 sed -i -e "/^${x} =.*/s:@${x}@::" "config/Makefile.inc.in" \
24 || return 1
25 done
26
27 for i in $source; do
28 case "$i" in
29 *.patch)
30 msg "Applying $i"
31 patch -p1 -i "$srcdir"/$i || return 1
32 ;;
33 esac
34 done
35}
36
16build() { 37build() {
17 cd "$_builddir" 38 cd "$_builddir"
18 ./configure --prefix=/usr \ 39 ./configure --prefix=/usr \
@@ -28,4 +49,5 @@ package() {
28 install -Dm644 "$srcdir"/icu/license.html \ 49 install -Dm644 "$srcdir"/icu/license.html \
29 "$pkgdir"/usr/share/licenses/icu/license.html 50 "$pkgdir"/usr/share/licenses/icu/license.html
30} 51}
31md5sums="b6bc0a1153540b2088f8b03e0ba625d3 icu4c-4_4_1-src.tgz" 52md5sums="b6bc0a1153540b2088f8b03e0ba625d3 icu4c-4_4_1-src.tgz
53e729eb08687b042e40df572932cbf9ce icu-ccache.patch"
diff --git a/main/icu/icu-ccache.patch b/main/icu/icu-ccache.patch
new file mode 100644
index 0000000000..214b9093c6
--- /dev/null
+++ b/main/icu/icu-ccache.patch
@@ -0,0 +1,11 @@
1--- ./tools/icuinfo/Makefile.in.orig
2+++ ./tools/icuinfo/Makefile.in
3@@ -36,7 +36,7 @@
4
5 ICUINFO_OPTS=-i ../../data/out/build/$(ICUDATA_PLATFORM_NAME)
6
7-CPPFLAGS+= -DU_PLATFORM=\"@platform@\" -DU_BUILD=\"@build@\" -DU_HOST=\"@host@\" -DU_CC=\"@CC@\" -DU_CXX=\"@CXX@\"
8+CPPFLAGS+= -DU_PLATFORM=\"@platform@\" -DU_BUILD=\"@build@\" -DU_HOST=\"@host@\" '-DU_CC="@CC@"' '-DU_CXX="@CXX@"'
9 # -DENABLE_RELEASE=@ENABLE_RELEASE@ -DENABLE_DEBUG=@ENABLE_DEBUG@ "
10
11