aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-09-16 14:52:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-09-23 08:17:32 +0000
commit5ca3bbde6d1460508455d1b0fe293c29262cb155 (patch)
tree1503ccd55869de1a6c4837510854237dee525870
parentfad32c9f2e2fc370522f1006be682299520933f1 (diff)
downloadalpine_aports-5ca3bbde6d1460508455d1b0fe293c29262cb155.tar.bz2
alpine_aports-5ca3bbde6d1460508455d1b0fe293c29262cb155.tar.xz
alpine_aports-5ca3bbde6d1460508455d1b0fe293c29262cb155.zip
main/libc0.9.32: new snapshot. enable debugging
(cherry picked from commit a7b8a239e2db4cf5ba868dd1f1d8af6a16854b0e)
-rw-r--r--main/libc0.9.32/0001-config-parser-do-not-assume-that-realloc-return-same.patch59
-rw-r--r--main/libc0.9.32/0001-config-parser-fix-memory-corruption.patch45
-rw-r--r--main/libc0.9.32/0001-nptl-fix-calling-convention-for-__pthread_mutex_cond.patch73
-rw-r--r--main/libc0.9.32/0002-getservice-getservent_r-must-return-ERANGE-when-buff.patch57
-rw-r--r--main/libc0.9.32/0003-config-parser-always-initialize-line-pointer.patch30
-rw-r--r--main/libc0.9.32/APKBUILD48
-rw-r--r--main/libc0.9.32/ld-tls.patch16
-rw-r--r--main/libc0.9.32/uclibc-resolv-tls.patch15
-rw-r--r--main/libc0.9.32/uclibcconfig.x869
9 files changed, 180 insertions, 172 deletions
diff --git a/main/libc0.9.32/0001-config-parser-do-not-assume-that-realloc-return-same.patch b/main/libc0.9.32/0001-config-parser-do-not-assume-that-realloc-return-same.patch
new file mode 100644
index 0000000000..bc08616fdf
--- /dev/null
+++ b/main/libc0.9.32/0001-config-parser-do-not-assume-that-realloc-return-same.patch
@@ -0,0 +1,59 @@
1From 46db9fdff735edfda088b06d619d23dec2fc3e7a Mon Sep 17 00:00:00 2001
2From: Natanael Copa <natanael.copa@gmail.com>
3Date: Thu, 16 Sep 2010 08:23:34 +0000
4Subject: [PATCH 1/3] config parser: do not assume that realloc return same pointer
5
6We need to update the parser->line pointer on realloc and do not
7initialize the token array til after the potensial realloc in
8bb_get_chunk_with_continuation().
9
10While here, also replace a realloc() with malloc() where pointer always
11is NULL.
12
13Signed-off-by: Natanael Copa <natanael.copa@gmail.com>
14---
15 libc/misc/internals/parse_config.c | 9 ++++-----
16 1 files changed, 4 insertions(+), 5 deletions(-)
17
18diff --git a/libc/misc/internals/parse_config.c b/libc/misc/internals/parse_config.c
19index 8fa324e..6734f35 100644
20--- a/libc/misc/internals/parse_config.c
21+++ b/libc/misc/internals/parse_config.c
22@@ -78,6 +78,7 @@ static off_t bb_get_chunk_with_continuation(parser_t* parsr)
23 parsr->line_len += PAGE_SIZE;
24 parsr->data = realloc(parsr->data,
25 parsr->data_len + parsr->line_len);
26+ parsr->line = parsr->data + parsr->data_len;
27 }
28 }
29 return pos;
30@@ -186,23 +187,21 @@ again:
31 parser->line_len = 81;
32 if (parser->data_len == 0)
33 parser->data_len += 1 + ntokens * sizeof(char *);
34- parser->data = realloc(parser->data,
35- parser->data_len + parser->line_len);
36+ parser->data = malloc(parser->data_len + parser->line_len);
37 if (parser->data == NULL)
38 return 0;
39 parser->allocated |= 1;
40 } /* else { assert(parser->data_len > 0); } */
41 if (parser->line == NULL)
42 parser->line = parser->data + parser->data_len;
43- if (*tokens == NULL)
44- *tokens = (char **) parser->data;
45- memset(*tokens, 0, sizeof(*tokens[0]) * ntokens);
46 /*config_free_data(parser);*/
47
48 /* Read one line (handling continuations with backslash) */
49 len = bb_get_chunk_with_continuation(parser);
50 if (len == -1)
51 return 0;
52+ *tokens = (char **) parser->data;
53+ memset(*tokens, 0, sizeof(*tokens[0]) * ntokens);
54 line = parser->line;
55
56 /* Skip multiple token-delimiters in the start of line? */
57--
581.7.2.3
59
diff --git a/main/libc0.9.32/0001-config-parser-fix-memory-corruption.patch b/main/libc0.9.32/0001-config-parser-fix-memory-corruption.patch
deleted file mode 100644
index 58acfb4234..0000000000
--- a/main/libc0.9.32/0001-config-parser-fix-memory-corruption.patch
+++ /dev/null
@@ -1,45 +0,0 @@
1From 80bcb7a4806b27397629cf2e6bcbb7e8a0c5db5b Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
3Date: Fri, 6 Aug 2010 11:29:38 +0300
4Subject: [PATCH] config parser: fix memory corruption
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9fgets will happily write over allocated area limits. Adjusted the
10buffer size according to how much is already read.
11
12Also increase the maximum default line length, as 80 is slightly
13small. It might be better if bb_get_chunk_with_continuation would
14reallocate the line buffer if it was not user given.
15
16Signed-off-by: Timo Teräs <timo.teras@iki.fi>
17---
18 libc/misc/internals/parse_config.c | 4 ++--
19 1 files changed, 2 insertions(+), 2 deletions(-)
20
21diff --git a/libc/misc/internals/parse_config.c b/libc/misc/internals/parse_config.c
22index cbb6ef7..8404d80 100644
23--- a/libc/misc/internals/parse_config.c
24+++ b/libc/misc/internals/parse_config.c
25@@ -60,7 +60,7 @@ static off_t bb_get_chunk_with_continuation(parser_t* parsr)
26 char *chp;
27
28 while (1) {
29- if (fgets(parsr->line + pos, parsr->line_len, parsr->fp) == NULL) {
30+ if (fgets(parsr->line + pos, parsr->line_len - pos, parsr->fp) == NULL) {
31 memset(parsr->line, 0, parsr->line_len);
32 pos = -1;
33 break;
34@@ -179,7 +179,7 @@ int attribute_hidden FAST_FUNC config_read(parser_t *parser, char ***tokens,
35 again:
36 if (parser->data == NULL) {
37 if (parser->line_len == 0)
38- parser->line_len = 81;
39+ parser->line_len = 161;
40 if (parser->data_len == 0)
41 parser->data_len += 1 + ntokens * sizeof(char *);
42 parser->data = realloc(parser->data,
43--
441.7.0.4
45
diff --git a/main/libc0.9.32/0001-nptl-fix-calling-convention-for-__pthread_mutex_cond.patch b/main/libc0.9.32/0001-nptl-fix-calling-convention-for-__pthread_mutex_cond.patch
deleted file mode 100644
index 55edc51c9a..0000000000
--- a/main/libc0.9.32/0001-nptl-fix-calling-convention-for-__pthread_mutex_cond.patch
+++ /dev/null
@@ -1,73 +0,0 @@
1From ed8017b08bee868eb5ea11c0b57074875267a3f1 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
3Date: Fri, 6 Aug 2010 13:26:25 +0300
4Subject: [PATCH] nptl: fix calling convention for __pthread_mutex_cond_lock
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9The assembly versions of pthread_cond_wait calls
10__pthread_mutex_cond_lock and __pthread_mutex_cond_lock_adjust
11using internal calling convention (which differs from default
12calling convention at least on x86). Thus these two functions
13must be defined with internal_function or the call sequence goes
14wrong.
15
16__pthread_mutex_cond_lock resides in
17sysdeps/unix/sysv/linux/pthread_mutex_cond_lock.c, but it does
18evil macro definitions and includes pthread_mutex_lock.c, so
19we need to add some extra kludge to pthread_mutex_lock.c to get
20the prototypes correctly.
21
22Signed-off-by: Timo Teräs <timo.teras@iki.fi>
23---
24 libpthread/nptl/pthreadP.h | 6 ++++--
25 libpthread/nptl/pthread_mutex_lock.c | 7 ++++++-
26 2 files changed, 10 insertions(+), 3 deletions(-)
27
28diff --git a/libpthread/nptl/pthreadP.h b/libpthread/nptl/pthreadP.h
29index 85601d4..c45bd11 100644
30--- a/libpthread/nptl/pthreadP.h
31+++ b/libpthread/nptl/pthreadP.h
32@@ -414,8 +414,10 @@ extern int __pthread_mutex_trylock (pthread_mutex_t *_mutex);
33 extern int __pthread_mutex_lock (pthread_mutex_t *__mutex);
34 extern int __pthread_mutex_lock_internal (pthread_mutex_t *__mutex)
35 attribute_hidden;
36-extern int __pthread_mutex_cond_lock (pthread_mutex_t *__mutex);
37-extern void __pthread_mutex_cond_lock_adjust (pthread_mutex_t *__mutex);
38+extern int __pthread_mutex_cond_lock (pthread_mutex_t *__mutex)
39+ attribute_hidden internal_function;
40+extern void __pthread_mutex_cond_lock_adjust (pthread_mutex_t *__mutex)
41+ attribute_hidden internal_function;
42 extern int __pthread_mutex_unlock (pthread_mutex_t *__mutex);
43 extern int __pthread_mutex_unlock_internal (pthread_mutex_t *__mutex)
44 attribute_hidden;
45diff --git a/libpthread/nptl/pthread_mutex_lock.c b/libpthread/nptl/pthread_mutex_lock.c
46index 78b6671..77147db 100644
47--- a/libpthread/nptl/pthread_mutex_lock.c
48+++ b/libpthread/nptl/pthread_mutex_lock.c
49@@ -42,7 +42,11 @@ static int __pthread_mutex_lock_full (pthread_mutex_t *mutex)
50
51
52 int
53+#ifdef NO_INCR
54+attribute_hidden internal_function
55+#else
56 attribute_protected
57+#endif
58 __pthread_mutex_lock (
59 pthread_mutex_t *mutex)
60 {
61@@ -477,7 +481,8 @@ strong_alias (__pthread_mutex_lock, __pthread_mutex_lock_internal)
62
63
64 #ifdef NO_INCR
65-void attribute_protected
66+void
67+attribute_hidden internal_function
68 __pthread_mutex_cond_lock_adjust (
69 pthread_mutex_t *mutex)
70 {
71--
721.7.0.4
73
diff --git a/main/libc0.9.32/0002-getservice-getservent_r-must-return-ERANGE-when-buff.patch b/main/libc0.9.32/0002-getservice-getservent_r-must-return-ERANGE-when-buff.patch
new file mode 100644
index 0000000000..29b8c3b3b0
--- /dev/null
+++ b/main/libc0.9.32/0002-getservice-getservent_r-must-return-ERANGE-when-buff.patch
@@ -0,0 +1,57 @@
1From 1d1fab81f09e2472921e0b8f1897655de5f9089c Mon Sep 17 00:00:00 2001
2From: Natanael Copa <natanael.copa@gmail.com>
3Date: Thu, 16 Sep 2010 11:37:39 +0000
4Subject: [PATCH 2/3] getservice: getservent_r must return ERANGE when buffer is too small
5
6This fixes issue introduced by 72e1a1ce186c39f07282398e2af9eb0253e60f15
7
8This should also fix the following testcase to exit with error rather
9than cause an endless loop.
10
11int main(void) {
12 if (getservbyname("non-existing", "udp") == NULL)
13 err(1, "getservbyname");
14 return 0;
15}
16
17Reported by Pirmin Walthert
18http://lists.uclibc.org/pipermail/uclibc/2010-August/044277.html
19
20Signed-off-by: Natanael Copa <natanael.copa@gmail.com>
21---
22 libc/inet/getservice.c | 5 ++---
23 1 files changed, 2 insertions(+), 3 deletions(-)
24
25diff --git a/libc/inet/getservice.c b/libc/inet/getservice.c
26index 1532df9..ccf9816 100644
27--- a/libc/inet/getservice.c
28+++ b/libc/inet/getservice.c
29@@ -69,7 +69,7 @@ int getservent_r(struct servent *result_buf,
30 char **serv_aliases;
31 char **tok = NULL;
32 const size_t aliaslen = sizeof(*serv_aliases) * MAXALIASES;
33- int ret = ENOENT;
34+ int ret = ERANGE;
35
36 *result = NULL;
37 if (buflen < aliaslen
38@@ -77,7 +77,7 @@ int getservent_r(struct servent *result_buf,
39 goto DONE_NOUNLOCK;
40
41 __UCLIBC_MUTEX_LOCK(mylock);
42-
43+ ret = ENOENT;
44 if (servp == NULL)
45 setservent(serv_stayopen);
46 if (servp == NULL)
47@@ -88,7 +88,6 @@ int getservent_r(struct servent *result_buf,
48 servp->line_len = buflen - aliaslen;
49 /* <name>[[:space:]]<port>/<proto>[[:space:]][<aliases>] */
50 if (!config_read(servp, &tok, MAXALIASES, 3, "# \t/", PARSE_NORMAL)) {
51- ret = ERANGE;
52 goto DONE;
53 }
54 result_buf->s_name = *(tok++);
55--
561.7.2.3
57
diff --git a/main/libc0.9.32/0003-config-parser-always-initialize-line-pointer.patch b/main/libc0.9.32/0003-config-parser-always-initialize-line-pointer.patch
new file mode 100644
index 0000000000..171eeee0bf
--- /dev/null
+++ b/main/libc0.9.32/0003-config-parser-always-initialize-line-pointer.patch
@@ -0,0 +1,30 @@
1From 1f134a1d5456148e212dbe6eb69ce7bee11dc1fb Mon Sep 17 00:00:00 2001
2From: Natanael Copa <natanael.copa@gmail.com>
3Date: Thu, 16 Sep 2010 11:51:21 +0000
4Subject: [PATCH 3/3] config parser: always initialize line pointer
5
6We must always initialize line pointer since data pointer might
7have changed due to a realloc (in getserv.c for example).
8
9Signed-off-by: Natanael Copa <natanael.copa@gmail.com>
10---
11 libc/misc/internals/parse_config.c | 3 +--
12 1 files changed, 1 insertions(+), 2 deletions(-)
13
14diff --git a/libc/misc/internals/parse_config.c b/libc/misc/internals/parse_config.c
15index 6734f35..6d3b6f4 100644
16--- a/libc/misc/internals/parse_config.c
17+++ b/libc/misc/internals/parse_config.c
18@@ -192,8 +192,7 @@ again:
19 return 0;
20 parser->allocated |= 1;
21 } /* else { assert(parser->data_len > 0); } */
22- if (parser->line == NULL)
23- parser->line = parser->data + parser->data_len;
24+ parser->line = parser->data + parser->data_len;
25 /*config_free_data(parser);*/
26
27 /* Read one line (handling continuations with backslash) */
28--
291.7.2.3
30
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index 11843bdfc1..83d89a5b7f 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -1,33 +1,41 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2_abiver=0.9.32 2_abiver=0.9.32
3pkgname=libc$_abiver 3pkgname=libc$_abiver
4_gitver=1008060645 4_gitver=1009151331
5pkgver=${_abiver}_alpha0_git$_gitver 5pkgver=${_abiver}_alpha0_git$_gitver
6pkgrel=4 6pkgrel=0
7pkgdesc="C library for developing embedded Linux systems" 7pkgdesc="C library for developing embedded Linux systems"
8url=http://uclibc.org 8url=http://uclibc.org
9license="LGPL-2" 9license="LGPL-2"
10 10options=
11subpackages="uclibc-dev:dev uclibc-utils:utils" 11subpackages="uclibc-dev:dev uclibc-utils:utils"
12depends_dev="linux-headers=>2.6.32" 12depends_dev="linux-headers=>2.6.32"
13#options="!strip"
14replaces=uclibc 13replaces=uclibc
15 14
15DEBUG=y
16if [ -n "$DEBUG" ]; then
17 options="!strip"
18fi
19
20
16_snapurl="http://git.uclibc.org/uClibc/snapshot/master.tar.bz2" 21_snapurl="http://git.uclibc.org/uClibc/snapshot/master.tar.bz2"
17_snapfile="$pkgname-$pkgver.tar.bz2" 22_snapfile="$pkgname-$pkgver.tar.bz2"
18source="http://build.alpinelinux.org:8010/distfiles/$_snapfile 23source="http://build.alpinelinux.org:8010/distfiles/$_snapfile
19 compat-stack-guard.patch 24 compat-stack-guard.patch
20 uclibc-libm-pic.patch 25 uclibc-libm-pic.patch
21 uclibc-resolv-tls.patch
22 0001-config-parser-fix-memory-corruption.patch
23 0001-nptl-fix-calling-convention-for-__pthread_mutex_cond.patch
24 0001-netdb-increase-line-size-for-etc-services.patch
25 0001-create-DEVEL_PREFIX-MULTILIB_DIR-dir-rather-than-DEV.patch 26 0001-create-DEVEL_PREFIX-MULTILIB_DIR-dir-rather-than-DEV.patch
26 getproto.patch 27
27 ld-tls.patch 28 0001-config-parser-do-not-assume-that-realloc-return-same.patch
29 0002-getservice-getservent_r-must-return-ERANGE-when-buff.patch
30 0003-config-parser-always-initialize-line-pointer.patch
31
28 uclibcconfig.x86 32 uclibcconfig.x86
29 uclibcconfig.i486 33 uclibcconfig.i486
30 " 34 "
35# uclibc-resolv-tls.patch
36# 0001-config-parser-fix-memory-corruption.patch
37# 0001-nptl-fix-calling-convention-for-__pthread_mutex_cond.patch
38# ld-tls.patch
31 39
32_config="$srcdir"/uclibcconfig.${ARCH:-x86} 40_config="$srcdir"/uclibcconfig.${ARCH:-x86}
33_builddir="$srcdir"/master 41_builddir="$srcdir"/master
@@ -73,6 +81,11 @@ build() {
73 _kh=KERNEL_HEADERS="$SYSROOT/include" 81 _kh=KERNEL_HEADERS="$SYSROOT/include"
74 fi 82 fi
75 cp "$_config" .config 83 cp "$_config" .config
84 if [ -n "$DEBUG" ]; then
85 sed -i -e 's/# DODEBUG is not set/DODEBUG=y' \
86 -e 's/DOSTRIP=y/# DOSTRIP is not set/' \
87 .config
88 fi
76 make silentoldconfig 89 make silentoldconfig
77 make -j1 pregen KERNEL_HEADERS="$SYSROOT"/usr/include \ 90 make -j1 pregen KERNEL_HEADERS="$SYSROOT"/usr/include \
78 CROSS="$CROSS" || return 1 91 CROSS="$CROSS" || return 1
@@ -104,15 +117,12 @@ utils() {
104 mv "$pkgdir"/usr/bin/* "$subpkgdir"/usr/bin/ 117 mv "$pkgdir"/usr/bin/* "$subpkgdir"/usr/bin/
105} 118}
106 119
107md5sums="2b3935c370307b806320e78883f9b07c libc0.9.32-0.9.32_alpha0_git1008060645.tar.bz2 120md5sums="966c830f294a8ab5069cc03a61e1b2ed libc0.9.32-0.9.32_alpha0_git1009151331.tar.bz2
1084d408f72142ce55a0754948cc9cfe447 compat-stack-guard.patch 1214d408f72142ce55a0754948cc9cfe447 compat-stack-guard.patch
1092f9739a980be24a842c57516155c7885 uclibc-libm-pic.patch 1222f9739a980be24a842c57516155c7885 uclibc-libm-pic.patch
110d08831b452acdeaa3037525ee617edab uclibc-resolv-tls.patch
111d351ca4e5c33f4a7a60d4f1d754db5c4 0001-config-parser-fix-memory-corruption.patch
112653b046611f98c990f1b52a28968ece3 0001-nptl-fix-calling-convention-for-__pthread_mutex_cond.patch
11339ac96d750ad058030f917912bfea466 0001-netdb-increase-line-size-for-etc-services.patch
1149dd8192227f54d6d3ccb49dc54137ff3 0001-create-DEVEL_PREFIX-MULTILIB_DIR-dir-rather-than-DEV.patch 1239dd8192227f54d6d3ccb49dc54137ff3 0001-create-DEVEL_PREFIX-MULTILIB_DIR-dir-rather-than-DEV.patch
11518afaad25c578bfbe1c7ddb0bea1228a getproto.patch 124ba6e0370d1fc19e5903696de412507ef 0001-config-parser-do-not-assume-that-realloc-return-same.patch
116b769ffe8e6df01328fc6afb4b50da1cd ld-tls.patch 12519d923997f9625ce6f16d8128bbcba65 0002-getservice-getservent_r-must-return-ERANGE-when-buff.patch
117e2eb3bb00a0fe4d6f3d5b5c56b027bab uclibcconfig.x86 12699b817778f4ef3a1b194740ea08990b4 0003-config-parser-always-initialize-line-pointer.patch
118e2eb3bb00a0fe4d6f3d5b5c56b027bab uclibcconfig.i486" 1272ca97ab4b49f920247f335184bb02c1c uclibcconfig.x86
1282ca97ab4b49f920247f335184bb02c1c uclibcconfig.i486"
diff --git a/main/libc0.9.32/ld-tls.patch b/main/libc0.9.32/ld-tls.patch
deleted file mode 100644
index 057191c57e..0000000000
--- a/main/libc0.9.32/ld-tls.patch
+++ /dev/null
@@ -1,16 +0,0 @@
1diff --git a/libpthread/nptl/Makefile.in b/libpthread/nptl/Makefile.in
2index 99a726a..3e9676a 100644
3--- a/libpthread/nptl/Makefile.in
4+++ b/libpthread/nptl/Makefile.in
5@@ -48,9 +48,9 @@ libc-shared-routines-y := $(addprefix $(libpthread_OUT)/,$(libc-shared-routines-
6 libc-static-routines-y := $(addprefix $(libpthread_OUT)/,$(libc-static-routines-y:.c=.o))
7 libc-shared-y += $(libc-shared-routines-y) $(libpthread_libc_OBJS:.o=.oS)
8 ifeq ($(DOPIC),y)
9-libc-static-y += $(libc-static-routines-y:.o=.os) $(libpthread_libc_a_OBJS:.o=.os) # $(libpthread_ld_tls_COBJ:.o=.os)
10+libc-static-y += $(libc-static-routines-y:.o=.os) $(libpthread_libc_a_OBJS:.o=.os) $(libpthread_ld_tls_COBJ:.o=.os)
11 else
12-libc-static-y += $(libc-static-routines-y) $(libpthread_libc_a_OBJS) # $(libpthread_ld_tls_COBJ)
13+libc-static-y += $(libc-static-routines-y) $(libpthread_libc_a_OBJS) $(libpthread_ld_tls_COBJ)
14 endif
15
16 librt-pt-routines-y := $(patsubst %.c,$(libpthread_pthread_OUT)/%.o,$(filter-out $(notdir $(libpthread_librt_OBJS:.o=.c)), $(librt-pt-routines-y)))
diff --git a/main/libc0.9.32/uclibc-resolv-tls.patch b/main/libc0.9.32/uclibc-resolv-tls.patch
deleted file mode 100644
index 45a228517b..0000000000
--- a/main/libc0.9.32/uclibc-resolv-tls.patch
+++ /dev/null
@@ -1,15 +0,0 @@
1diff --git a/libc/inet/resolv.c b/libc/inet/resolv.c
2index 320aec4..f8066d2 100644
3--- a/libc/inet/resolv.c
4+++ b/libc/inet/resolv.c
5@@ -2916,8 +2916,8 @@ static void res_sync_func(void)
6 __nameserver[n].sa4 = rp->nsaddr_list[n]; /* struct copy */
7 #endif
8 }
9- __resolv_timeout = rp->retrans;
10- __resolv_attempts = rp->retry;
11+ __resolv_timeout = rp->retrans ?: RES_TIMEOUT;
12+ __resolv_attempts = rp->retry ?: RES_DFLRETRY;
13 /* Extend and comment what program is known
14 * to use which _res.XXX member(s).
15
diff --git a/main/libc0.9.32/uclibcconfig.x86 b/main/libc0.9.32/uclibcconfig.x86
index 1368b58ec0..3baabc7718 100644
--- a/main/libc0.9.32/uclibcconfig.x86
+++ b/main/libc0.9.32/uclibcconfig.x86
@@ -1,7 +1,7 @@
1# 1#
2# Automatically generated make config: don't edit 2# Automatically generated make config: don't edit
3# Version: 0.9.32-git 3# Version: 0.9.32-git
4# Fri May 7 11:46:52 2010 4# Wed Sep 15 14:17:28 2010
5# 5#
6# TARGET_alpha is not set 6# TARGET_alpha is not set
7# TARGET_arm is not set 7# TARGET_arm is not set
@@ -51,7 +51,7 @@ CONFIG_486=y
51# CONFIG_WINCHIP2 is not set 51# CONFIG_WINCHIP2 is not set
52# CONFIG_CYRIXIII is not set 52# CONFIG_CYRIXIII is not set
53# CONFIG_NEHEMIAH is not set 53# CONFIG_NEHEMIAH is not set
54TARGET_SUBARCH="" 54TARGET_SUBARCH="i486"
55 55
56# 56#
57# Using ELF file format 57# Using ELF file format
@@ -219,6 +219,7 @@ UCLIBC_HAS_NFTW=y
219UCLIBC_HAS_FTW=y 219UCLIBC_HAS_FTW=y
220UCLIBC_HAS_GLOB=y 220UCLIBC_HAS_GLOB=y
221UCLIBC_HAS_GNU_GLOB=y 221UCLIBC_HAS_GNU_GLOB=y
222# UCLIBC_HAS_UTMPX is not set
222 223
223# 224#
224# Library Installation Options 225# Library Installation Options
@@ -249,8 +250,8 @@ UCLIBC_BUILD_NOEXECSTACK=y
249# 250#
250CROSS_COMPILER_PREFIX="" 251CROSS_COMPILER_PREFIX=""
251UCLIBC_EXTRA_CFLAGS="" 252UCLIBC_EXTRA_CFLAGS=""
252# DODEBUG is not set 253DODEBUG=y
253DOSTRIP=y 254# DOSTRIP is not set
254# DOASSERTS is not set 255# DOASSERTS is not set
255# SUPPORT_LD_DEBUG is not set 256# SUPPORT_LD_DEBUG is not set
256# SUPPORT_LD_DEBUG_EARLY is not set 257# SUPPORT_LD_DEBUG_EARLY is not set