aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-09-25 11:48:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-09-25 11:54:50 +0000
commitdb05468545190a3bc2a25ddd414bc2b2f659e343 (patch)
tree5b97481740100f78f21489400f3295e12be9cec4
parent37cc82121b8707e221dfbe95f0aa179b7ec78f03 (diff)
downloadalpine_aports-db05468545190a3bc2a25ddd414bc2b2f659e343.tar.bz2
alpine_aports-db05468545190a3bc2a25ddd414bc2b2f659e343.tar.xz
alpine_aports-db05468545190a3bc2a25ddd414bc2b2f659e343.zip
main/libc0.9.32: workaround for getprotobyname/getservbyname
we just increase bufsize for now. fixes #433 (cherry picked from commit ef54f83392012b97de706ed592897f6cd1d43f80)
-rw-r--r--main/libc0.9.32/APKBUILD4
-rw-r--r--main/libc0.9.32/bufsize.patch26
-rw-r--r--main/libc0.9.32/getproto.patch11
3 files changed, 29 insertions, 12 deletions
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index 12a01fa134..9d92dc76f4 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -3,7 +3,7 @@ _abiver=0.9.32
3pkgname=libc$_abiver 3pkgname=libc$_abiver
4_gitver=1009151331 4_gitver=1009151331
5pkgver=${_abiver}_alpha0_git$_gitver 5pkgver=${_abiver}_alpha0_git$_gitver
6pkgrel=1 6pkgrel=2
7pkgdesc="C library for developing embedded Linux systems" 7pkgdesc="C library for developing embedded Linux systems"
8url=http://uclibc.org 8url=http://uclibc.org
9license="LGPL-2" 9license="LGPL-2"
@@ -27,6 +27,7 @@ source="http://build.alpinelinux.org:8010/distfiles/$_snapfile
27 0002-getservice-getservent_r-must-return-ERANGE-when-buff.patch 27 0002-getservice-getservent_r-must-return-ERANGE-when-buff.patch
28 0003-config-parser-always-initialize-line-pointer.patch 28 0003-config-parser-always-initialize-line-pointer.patch
29 29
30 bufsize.patch
30 uclibcconfig.x86 31 uclibcconfig.x86
31 uclibcconfig.i486 32 uclibcconfig.i486
32 " 33 "
@@ -122,5 +123,6 @@ md5sums="966c830f294a8ab5069cc03a61e1b2ed libc0.9.32-0.9.32_alpha0_git100915133
122ba6e0370d1fc19e5903696de412507ef 0001-config-parser-do-not-assume-that-realloc-return-same.patch 123ba6e0370d1fc19e5903696de412507ef 0001-config-parser-do-not-assume-that-realloc-return-same.patch
12319d923997f9625ce6f16d8128bbcba65 0002-getservice-getservent_r-must-return-ERANGE-when-buff.patch 12419d923997f9625ce6f16d8128bbcba65 0002-getservice-getservent_r-must-return-ERANGE-when-buff.patch
12499b817778f4ef3a1b194740ea08990b4 0003-config-parser-always-initialize-line-pointer.patch 12599b817778f4ef3a1b194740ea08990b4 0003-config-parser-always-initialize-line-pointer.patch
126cf97d904c42c5fd165650472100b18a7 bufsize.patch
125cffecb42bdec2da7cac718fa66cacbbe uclibcconfig.x86 127cffecb42bdec2da7cac718fa66cacbbe uclibcconfig.x86
126cffecb42bdec2da7cac718fa66cacbbe uclibcconfig.i486" 128cffecb42bdec2da7cac718fa66cacbbe uclibcconfig.i486"
diff --git a/main/libc0.9.32/bufsize.patch b/main/libc0.9.32/bufsize.patch
new file mode 100644
index 0000000000..b52f155c64
--- /dev/null
+++ b/main/libc0.9.32/bufsize.patch
@@ -0,0 +1,26 @@
1diff --git a/libc/inet/getproto.c b/libc/inet/getproto.c
2index bcf507b..9858900 100644
3--- a/libc/inet/getproto.c
4+++ b/libc/inet/getproto.c
5@@ -28,7 +28,7 @@ aliases: case sensitive optional space or tab separated list of other names
6 __UCLIBC_MUTEX_STATIC(mylock, PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP);
7
8 #define MAXALIASES 35
9-#define BUFSZ (80) /* one line */
10+#define BUFSZ (256) /* one line */
11 #define SBUFSIZE (BUFSZ + 1 + (sizeof(char *) * MAXALIASES))
12
13 static parser_t *protop = NULL;
14diff --git a/libc/inet/getservice.c b/libc/inet/getservice.c
15index c38ff80..dbbc19c 100644
16--- a/libc/inet/getservice.c
17+++ b/libc/inet/getservice.c
18@@ -29,7 +29,7 @@ aliases: case sensitive optional space or tab separated list of other names
19 __UCLIBC_MUTEX_STATIC(mylock, PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP);
20
21 #define MAXALIASES 35
22-#define BUFSZ (80) /* one line */
23+#define BUFSZ (256) /* one line */
24 #define SBUFSIZE (BUFSZ + 1 + (sizeof(char *) * MAXALIASES))
25
26 static parser_t *servp = NULL;
diff --git a/main/libc0.9.32/getproto.patch b/main/libc0.9.32/getproto.patch
deleted file mode 100644
index c58847443a..0000000000
--- a/main/libc0.9.32/getproto.patch
+++ /dev/null
@@ -1,11 +0,0 @@
1--- ./libc/inet/getproto.c.orig
2+++ ./libc/inet/getproto.c
3@@ -28,7 +28,7 @@
4 __UCLIBC_MUTEX_STATIC(mylock, PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP);
5
6 #define MAXALIASES 35
7-#define BUFSZ (80) /* one line */
8+#define BUFSZ (180) /* one line */
9 #define SBUFSIZE (BUFSZ + 1 + (sizeof(char *) * MAXALIASES))
10
11 static parser_t *protop = NULL;