aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-10-27 09:07:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-10-27 09:07:37 +0000
commit7d68a7f2eac24a9fc1d53f75443db25328af991d (patch)
treef41b49ea40165be21d76b4fd42de0e538df9796f
parent51e88757d944832beadb24398ca7f50a8cac5ee3 (diff)
downloadalpine_aports-7d68a7f2eac24a9fc1d53f75443db25328af991d.tar.bz2
alpine_aports-7d68a7f2eac24a9fc1d53f75443db25328af991d.tar.xz
alpine_aports-7d68a7f2eac24a9fc1d53f75443db25328af991d.zip
main/busybox: fix for sort, don't depmod on kernel removal
-rw-r--r--main/busybox/APKBUILD4
-rw-r--r--main/busybox/busybox.trigger6
2 files changed, 8 insertions, 2 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index c0f40a95e2..d4e9648953 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -1,7 +1,7 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=busybox 2pkgname=busybox
3pkgver=1.17.3 3pkgver=1.17.3
4pkgrel=0 4pkgrel=1
5pkgdesc="Size optimized toolbox of many common UNIX utilities" 5pkgdesc="Size optimized toolbox of many common UNIX utilities"
6url=http://busybox.net 6url=http://busybox.net
7license="GPL-2" 7license="GPL-2"
@@ -10,6 +10,7 @@ install="$pkgname.post-install $pkgname.post-upgrade"
10subpackages="$pkgname-static" 10subpackages="$pkgname-static"
11triggers="busybox.trigger:/bin /usr/bin /sbin /usr/sbin /lib/modules/*" 11triggers="busybox.trigger:/bin /usr/bin /sbin /usr/sbin /lib/modules/*"
12source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2 12source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
13 http://busybox.net/downloads/fixes-1.17.3/busybox-1.17.3-sort.patch
13 $pkgname-1.11.1-bb.patch 14 $pkgname-1.11.1-bb.patch
14 busyboxconfig" 15 busyboxconfig"
15 16
@@ -68,5 +69,6 @@ static() {
68} 69}
69 70
70md5sums="a2ce1a951571da8c6e0eaf75b1acef60 busybox-1.17.3.tar.bz2 71md5sums="a2ce1a951571da8c6e0eaf75b1acef60 busybox-1.17.3.tar.bz2
726d9c722fdbefda5ed408da63dc6bbefe busybox-1.17.3-sort.patch
714c0f3b486eaa0674961b7ddcd0c60a9b busybox-1.11.1-bb.patch 734c0f3b486eaa0674961b7ddcd0c60a9b busybox-1.11.1-bb.patch
72403e0b9fe99a7a18c5b9ae91283a5f9a busyboxconfig" 74403e0b9fe99a7a18c5b9ae91283a5f9a busyboxconfig"
diff --git a/main/busybox/busybox.trigger b/main/busybox/busybox.trigger
index 8bdef2ba56..2f69f76ceb 100644
--- a/main/busybox/busybox.trigger
+++ b/main/busybox/busybox.trigger
@@ -4,7 +4,11 @@ do_bb_install=
4 4
5for i in "$@"; do 5for i in "$@"; do
6 case "$i" in 6 case "$i" in
7 /lib/modules/*) /bin/busybox depmod ${i#/lib/modules/};; 7 /lib/modules/*)
8 if [ -d "$i" ]; then
9 /bin/busybox depmod ${i#/lib/modules/}
10 fi
11 ;;
8 *) do_bb_install=yes;; 12 *) do_bb_install=yes;;
9 esac 13 esac
10done 14done