aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-10-26 15:04:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-10-26 15:04:12 +0000
commitb0050a9bb1e76b18c8a33b265f68d7e80163bf02 (patch)
treef78d9c8e540ef2578516a40011170521b4c2c912
parent002aa4f79827377f7e7977df7af8a0b95abee3da (diff)
downloadalpine_aports-b0050a9bb1e76b18c8a33b265f68d7e80163bf02.tar.bz2
alpine_aports-b0050a9bb1e76b18c8a33b265f68d7e80163bf02.tar.xz
alpine_aports-b0050a9bb1e76b18c8a33b265f68d7e80163bf02.zip
testing/iscs-scst-grsec: build fix for 2.6.35 kernel
-rw-r--r--testing/iscsi-scst-grsec/2.6.35.patch11
-rw-r--r--testing/iscsi-scst-grsec/APKBUILD4
2 files changed, 14 insertions, 1 deletions
diff --git a/testing/iscsi-scst-grsec/2.6.35.patch b/testing/iscsi-scst-grsec/2.6.35.patch
new file mode 100644
index 0000000000..54fde38221
--- /dev/null
+++ b/testing/iscsi-scst-grsec/2.6.35.patch
@@ -0,0 +1,11 @@
1--- ./kernel/conn.c.orig
2+++ ./kernel/conn.c
3@@ -86,7 +86,7 @@
4 switch (sk->sk_family) {
5 case AF_INET:
6 snprintf(buf, sizeof(buf),
7- "%u.%u.%u.%u", NIPQUAD(inet_sk(sk)->daddr));
8+ "%u.%u.%u.%u", NIPQUAD(inet_sk(sk)->inet_daddr));
9 break;
10 case AF_INET6:
11 #if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,29)
diff --git a/testing/iscsi-scst-grsec/APKBUILD b/testing/iscsi-scst-grsec/APKBUILD
index c8c95c158e..0320a5caaa 100644
--- a/testing/iscsi-scst-grsec/APKBUILD
+++ b/testing/iscsi-scst-grsec/APKBUILD
@@ -26,6 +26,7 @@ makedepends="linux-${_flavor}-dev=${_kernelver} scst-grsec-dev"
26subpackages= 26subpackages=
27source="http://downloads.sourceforge.net/scst/$_realname-$_realver.tar.gz 27source="http://downloads.sourceforge.net/scst/$_realname-$_realver.tar.gz
28 config.c.patch 28 config.c.patch
29 2.6.35.patch
29 " 30 "
30_ksrc=/usr/src/linux-headers-${_abi_release} 31_ksrc=/usr/src/linux-headers-${_abi_release}
31 32
@@ -57,4 +58,5 @@ package() {
57} 58}
58 59
59md5sums="56109c01e3d4421a36d6f47efa1fb0d5 iscsi-scst-1.0.1.1.tar.gz 60md5sums="56109c01e3d4421a36d6f47efa1fb0d5 iscsi-scst-1.0.1.1.tar.gz
6048e21e3466fd819418f29e3b2487f052 config.c.patch" 6148e21e3466fd819418f29e3b2487f052 config.c.patch
62d2490c86d9138226ec674997817a163b 2.6.35.patch"