aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-10-26 13:24:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-10-26 13:24:44 +0000
commite5412705b673d7a1650741b4c45d87ef915674f1 (patch)
treed77e5c2ee0bc127e581037c24ef918f87b96f1ea
parent6434bb6a29a04d2a043b94acca7d038a313d44a0 (diff)
downloadalpine_aports-e5412705b673d7a1650741b4c45d87ef915674f1.tar.bz2
alpine_aports-e5412705b673d7a1650741b4c45d87ef915674f1.tar.xz
alpine_aports-e5412705b673d7a1650741b4c45d87ef915674f1.zip
main/linux-grsec: fix localversion
it picked up the aports git repo by mistake
-rw-r--r--main/linux-grsec/APKBUILD4
-rw-r--r--main/linux-grsec/setlocalversion.patch11
2 files changed, 14 insertions, 1 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 37da9f8952..84665e374a 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
4pkgname=linux-${_flavor} 4pkgname=linux-${_flavor}
5pkgver=2.6.35.7 5pkgver=2.6.35.7
6_kernver=2.6.35 6_kernver=2.6.35
7pkgrel=1 7pkgrel=2
8pkgdesc="Linux kernel with grsecurity" 8pkgdesc="Linux kernel with grsecurity"
9url=http://grsecurity.net 9url=http://grsecurity.net
10depends="mkinitfs linux-firmware" 10depends="mkinitfs linux-firmware"
@@ -18,6 +18,7 @@ source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
18 0004-arp-flush-arp-cache-on-device-change.patch 18 0004-arp-flush-arp-cache-on-device-change.patch
19 r8169-fix-rx-checksum-offload.patch 19 r8169-fix-rx-checksum-offload.patch
20 r8169-add-gro-support.patch 20 r8169-add-gro-support.patch
21 setlocalversion.patch
21 kernelconfig.x86 22 kernelconfig.x86
22 " 23 "
23subpackages="$pkgname-dev linux-firmware:firmware" 24subpackages="$pkgname-dev linux-firmware:firmware"
@@ -143,4 +144,5 @@ md5sums="091abeb4684ce03d1d936851618687b6 linux-2.6.35.tar.bz2
143776adeeb5272093574f8836c5037dd7d 0004-arp-flush-arp-cache-on-device-change.patch 144776adeeb5272093574f8836c5037dd7d 0004-arp-flush-arp-cache-on-device-change.patch
1440ccecafd4123dcad0b0cd7787553d734 r8169-fix-rx-checksum-offload.patch 1450ccecafd4123dcad0b0cd7787553d734 r8169-fix-rx-checksum-offload.patch
145139b39da44ecb577275be53d7d365949 r8169-add-gro-support.patch 146139b39da44ecb577275be53d7d365949 r8169-add-gro-support.patch
1478c224ba0cdf0aa572c7eb50379435be4 setlocalversion.patch
146f6b46f11945c77d01679c87e95d512ee kernelconfig.x86" 148f6b46f11945c77d01679c87e95d512ee kernelconfig.x86"
diff --git a/main/linux-grsec/setlocalversion.patch b/main/linux-grsec/setlocalversion.patch
new file mode 100644
index 0000000000..d82eb170ab
--- /dev/null
+++ b/main/linux-grsec/setlocalversion.patch
@@ -0,0 +1,11 @@
1--- ./scripts/setlocalversion.orig
2+++ ./scripts/setlocalversion
3@@ -43,7 +43,7 @@
4 fi
5
6 # Check for git and a git repo.
7- if head=`git rev-parse --verify --short HEAD 2>/dev/null`; then
8+ if [ -d "$srctree"/.git ] && head=`git rev-parse --verify --short HEAD 2>/dev/null`; then
9
10 # If we are at a tagged commit (like "v2.6.30-rc6"), we ignore
11 # it, because this version is defined in the top level Makefile.