aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2010-11-01 08:30:33 +0000
committerLeonardo Arena <rnalrd@gmail.com>2010-11-01 08:30:33 +0000
commit49bb87ab33a6bccd8205f8b2467ed1a346230d8c (patch)
tree8deeb8fd70d5926c5280496ed3bdb736ee579534
parent18ae09e99e4ad3312b71e5f83a80e53c597e1a69 (diff)
downloadalpine_aports-49bb87ab33a6bccd8205f8b2467ed1a346230d8c.tar.bz2
alpine_aports-49bb87ab33a6bccd8205f8b2467ed1a346230d8c.tar.xz
alpine_aports-49bb87ab33a6bccd8205f8b2467ed1a346230d8c.zip
testing/perl-dbd-mysql: new aport
-rw-r--r--testing/perl-dbd-mysql/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/perl-dbd-mysql/APKBUILD b/testing/perl-dbd-mysql/APKBUILD
new file mode 100644
index 0000000000..61fb79aff0
--- /dev/null
+++ b/testing/perl-dbd-mysql/APKBUILD
@@ -0,0 +1,31 @@
1# Contributor: Jeff Bilyk <jbilyk at gmail>
2# Maintainer: Leonardo Arena <rnalrd@gmail.com>
3pkgname=perl-dbd-mysql
4_realpkgname=DBD-mysql
5pkgver=4.014
6pkgrel=0
7pkgdesc="Perl CPAN DBD::Mysql module"
8url="http://search.cpan.org/dist/${_realpkgname}"
9license="GPL PerlArtistic"
10depends="libmysqlclient perl perl-dbi"
11makedepends="perl perl-dev mysql-dev zlib-dev"
12source="http://www.cpan.org/authors/id/C/CA/CAPTTOFU/${_realpkgname}-$pkgver.tar.gz"
13
14_builddir="$srcdir"/${_realpkgname}-$pkgver
15
16prepare() {
17 return 0
18}
19
20build() {
21 cd "$_builddir"
22 PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
23 make || return 1
24}
25
26package() {
27 cd "$_builddir"
28 make DESTDIR="$pkgdir" install
29}
30
31md5sums="74f118a4984e6a49f8ece28e68caf543 DBD-mysql-4.014.tar.gz"