aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-12-21 10:34:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-01-07 12:39:48 +0000
commit60204f874164b38247e0d52e589dbe52c4daa178 (patch)
tree4da99a25de61ad7f5f8e43dd32c5739f7f4892d6
parent4eea38c402a02de9afc0456d94833d3e4816148d (diff)
downloadalpine_aports-60204f874164b38247e0d52e589dbe52c4daa178.tar.bz2
alpine_aports-60204f874164b38247e0d52e589dbe52c4daa178.tar.xz
alpine_aports-60204f874164b38247e0d52e589dbe52c4daa178.zip
main/openrc: apply patch from upstream. force root to be remounted as rw
also remove the .modloop hack. Basically, everytying in 'boot' runlevel is for bootstrapping the system. Dont expect things work if restart any of those services. ref #178 (cherry picked from commit a4cc593132e169168d5b701da879998f91f3744c)
-rw-r--r--main/openrc/0001-Fix-s-and-S.patch25
-rw-r--r--main/openrc/0001-Force-root-be-rw-before-localmount.patch26
-rw-r--r--main/openrc/APKBUILD10
-rw-r--r--main/openrc/localmount.patch12
4 files changed, 58 insertions, 15 deletions
diff --git a/main/openrc/0001-Fix-s-and-S.patch b/main/openrc/0001-Fix-s-and-S.patch
new file mode 100644
index 0000000000..1d3536d6f4
--- /dev/null
+++ b/main/openrc/0001-Fix-s-and-S.patch
@@ -0,0 +1,25 @@
1From 4d86d346354543f27058923587dd25f8c460363c Mon Sep 17 00:00:00 2001
2From: Roy Marples <roy@marples.name>
3Date: Fri, 26 Mar 2010 22:10:03 +0000
4Subject: [PATCH] Fix -s and -S.
5
6---
7 src/rc/rc.c | 2 +-
8 1 files changed, 1 insertions(+), 1 deletions(-)
9
10diff --git a/src/rc/rc.c b/src/rc/rc.c
11index 6d04b3d..ccafbe3 100644
12--- a/src/rc/rc.c
13+++ b/src/rc/rc.c
14@@ -773,7 +773,7 @@ handle_bad_signal(int sig)
15 #endif
16
17 #include "_usage.h"
18-#define getoptstring "o:" getoptstring_COMMON
19+#define getoptstring "o:s:S" getoptstring_COMMON
20 static const struct option longopts[] = {
21 { "override", 1, NULL, 'o' },
22 { "service", 1, NULL, 's' },
23--
241.7.3.4
25
diff --git a/main/openrc/0001-Force-root-be-rw-before-localmount.patch b/main/openrc/0001-Force-root-be-rw-before-localmount.patch
new file mode 100644
index 0000000000..3381d9f0dd
--- /dev/null
+++ b/main/openrc/0001-Force-root-be-rw-before-localmount.patch
@@ -0,0 +1,26 @@
1From c92e702f6dddab58a749f5fea5479ff2affeb498 Mon Sep 17 00:00:00 2001
2From: Natanael Copa <ncopa@alpinelinux.org>
3Date: Tue, 21 Dec 2010 10:29:37 +0000
4Subject: [PATCH] Force root be rw before localmount
5
6The service that pulls in root remount is mtab which we dont need/use.
7---
8 init.d/localmount.in | 2 +-
9 1 files changed, 1 insertions(+), 1 deletions(-)
10
11diff --git a/init.d/localmount.in b/init.d/localmount.in
12index a4d1116..2895894 100644
13--- a/init.d/localmount.in
14+++ b/init.d/localmount.in
15@@ -6,7 +6,7 @@ description="Mounts disks and swap according to /etc/fstab."
16
17 depend()
18 {
19- need fsck
20+ need fsck root
21 use lvm modules mtab
22 keyword -jail -openvz -prefix -vserver -lxc
23 }
24--
251.7.3.4
26
diff --git a/main/openrc/APKBUILD b/main/openrc/APKBUILD
index bbdf8d60a0..bf7bc6969c 100644
--- a/main/openrc/APKBUILD
+++ b/main/openrc/APKBUILD
@@ -1,7 +1,7 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=openrc 2pkgname=openrc
3pkgver=0.6.1 3pkgver=0.6.1
4pkgrel=2 4pkgrel=3
5pkgdesc="OpenRC manages the services, startup and shutdown of a host" 5pkgdesc="OpenRC manages the services, startup and shutdown of a host"
6url="http://roy.marples.name/openrc" 6url="http://roy.marples.name/openrc"
7license='BSD-2' 7license='BSD-2'
@@ -10,7 +10,10 @@ subpackages="$pkgname-doc $pkgname-dev"
10install="$pkgname.post-install $pkgname.post-upgrade" 10install="$pkgname.post-install $pkgname.post-upgrade"
11source="http://roy.marples.name/downloads/$pkgname/$pkgname-$pkgver.tar.bz2 11source="http://roy.marples.name/downloads/$pkgname/$pkgname-$pkgver.tar.bz2
12 openrc-0.4.3-mkmntdirs.patch 12 openrc-0.4.3-mkmntdirs.patch
13 localmount.patch 13
14 0001-Fix-s-and-S.patch
15 0001-Force-root-be-rw-before-localmount.patch
16
14 hostname.initd 17 hostname.initd
15 hwdrivers.initd 18 hwdrivers.initd
16 keymaps.initd 19 keymaps.initd
@@ -57,7 +60,8 @@ package() {
57 60
58md5sums="90aa095508b0e92b06eda43b641cba49 openrc-0.6.1.tar.bz2 61md5sums="90aa095508b0e92b06eda43b641cba49 openrc-0.6.1.tar.bz2
598c2c1c2ee0509b63966b7187a2079f4b openrc-0.4.3-mkmntdirs.patch 628c2c1c2ee0509b63966b7187a2079f4b openrc-0.4.3-mkmntdirs.patch
60fa1809cd59cc0559a163bc6adc7398f6 localmount.patch 63cb4b6e0f378600cbdbb58e905e9cab26 0001-Fix-s-and-S.patch
644fd036ff07ed9ad7fb76af6a3ffc0695 0001-Force-root-be-rw-before-localmount.patch
61c32e15b0858eef708497e7ee6355a055 hostname.initd 65c32e15b0858eef708497e7ee6355a055 hostname.initd
62b1e64885f301166df30be3e3cf5338ff hwdrivers.initd 66b1e64885f301166df30be3e3cf5338ff hwdrivers.initd
6333ca3e558c42cdd17adccbc7807298f7 keymaps.initd 6733ca3e558c42cdd17adccbc7807298f7 keymaps.initd
diff --git a/main/openrc/localmount.patch b/main/openrc/localmount.patch
deleted file mode 100644
index c80d640a21..0000000000
--- a/main/openrc/localmount.patch
+++ /dev/null
@@ -1,12 +0,0 @@
1diff -ru openrc-0.5.0.orig/init.d/localmount.in openrc-0.5.0/init.d/localmount.in
2--- openrc-0.5.0.orig/init.d/localmount.in 2009-10-09 09:08:43.000000000 +0000
3+++ openrc-0.5.0/init.d/localmount.in 2009-10-09 09:09:08.000000000 +0000
4@@ -31,7 +31,7 @@
5 {
6 # We never unmount / or /dev or $RC_SVCDIR
7 local x= no_umounts_r="/|/dev|/dev/.*|${RC_SVCDIR}"
8- no_umounts_r="${no_umounts_r}|/bin|/sbin|/lib|/libexec"
9+ no_umounts_r="${no_umounts_r}|/bin|/sbin|/lib|/libexec|/.modloop"
10 # RC_NO_UMOUNTS is an env var that can be set by plugins
11 OIFS=$IFS SIFS=${IFS-y}
12 IFS=$IFS: