aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2011-04-20 13:50:26 +0300
committerTimo Teräs <timo.teras@iki.fi>2011-04-20 13:52:26 +0300
commitd166b1f5032eaeb9dd9e72db948a170af4710a96 (patch)
tree7453e379fff87b034d769d749fee7bc3335e0d13
parentf7108a52947196e71078ba32ad93ede3b607db1e (diff)
downloadalpine_aports-d166b1f5032eaeb9dd9e72db948a170af4710a96.tar.bz2
alpine_aports-d166b1f5032eaeb9dd9e72db948a170af4710a96.tar.xz
alpine_aports-d166b1f5032eaeb9dd9e72db948a170af4710a96.zip
libc0.9.32: fix posix_fadvise64 on x86
-rw-r--r--main/libc0.9.32/0001-posix_fadvise64-fix-x86-implementation.patch53
-rw-r--r--main/libc0.9.32/APKBUILD4
2 files changed, 56 insertions, 1 deletions
diff --git a/main/libc0.9.32/0001-posix_fadvise64-fix-x86-implementation.patch b/main/libc0.9.32/0001-posix_fadvise64-fix-x86-implementation.patch
new file mode 100644
index 0000000000..382cc94aba
--- /dev/null
+++ b/main/libc0.9.32/0001-posix_fadvise64-fix-x86-implementation.patch
@@ -0,0 +1,53 @@
1From d4db9d07a970e27e3042d09892fbaeca5f40c1a8 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
3Date: Wed, 20 Apr 2011 13:45:36 +0300
4Subject: [PATCH] posix_fadvise64: fix x86 implementation
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Commit 73d59554144f429b1cf0d4d7fa7de42bdf59ad92 completely broke
10the x86 implementation of posix_fadvise64. It moved the first
11the assembly code retn instruction gets missing depending on the
12
13Technically the file has two implementaions for posix_fadvise64,
14one when __NR_fadvise64_64 is available, and second one if only
15__NR_fadvise64 is there. Fix the #ifdef's to be proper for that.
16
17Signed-off-by: Timo Teräs <timo.teras@iki.fi>
18---
19 libc/sysdeps/linux/i386/posix_fadvise64.S | 4 +++-
20 1 files changed, 3 insertions(+), 1 deletions(-)
21
22diff --git a/libc/sysdeps/linux/i386/posix_fadvise64.S b/libc/sysdeps/linux/i386/posix_fadvise64.S
23index b4aeff1..8a8947d 100644
24--- a/libc/sysdeps/linux/i386/posix_fadvise64.S
25+++ b/libc/sysdeps/linux/i386/posix_fadvise64.S
26@@ -22,7 +22,7 @@
27 #include <bits/errno.h>
28 #include <sys/syscall.h>
29
30-#if defined __NR_fadvise64_64
31+#if defined __NR_fadvise64_64 || defined __NR_fadvise64
32
33 /* Was named __libc_posix_fadvise64 for some inexplicable reason.
34 ** google says only uclibc has *__libc*_posix_fadviseXXX,
35@@ -35,6 +35,7 @@
36 .global posix_fadvise64
37 .type posix_fadvise64,%function
38 posix_fadvise64:
39+#if defined __NR_fadvise64_64
40 /* Save regs */
41 pushl %ebp
42 pushl %ebx
43@@ -91,6 +92,7 @@ overflow:
44
45 /* Returns 0 on success, else an error code. */
46 negl %eax
47+#endif
48
49 /* Successful; return the syscall's value. */
50 ret
51--
521.7.1
53
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index 915a64a70f..524f08aa2f 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libc$_abiver
4_gitver= 4_gitver=
5pkgver=0.9.32_rc3 5pkgver=0.9.32_rc3
6_ver=${pkgver/_/-} 6_ver=${pkgver/_/-}
7pkgrel=8 7pkgrel=9
8pkgdesc="C library for developing embedded Linux systems" 8pkgdesc="C library for developing embedded Linux systems"
9url=http://uclibc.org 9url=http://uclibc.org
10license="LGPL-2" 10license="LGPL-2"
@@ -30,6 +30,7 @@ source="http://uclibc.org/downloads/uClibc-${_ver}.tar.bz2
30 0001-malloc-standard-synchronize-on-fork.patch 30 0001-malloc-standard-synchronize-on-fork.patch
31 0001-resolv-fix-res_close-not-to-hang-with-ipv6.patch 31 0001-resolv-fix-res_close-not-to-hang-with-ipv6.patch
32 0001-utils-ldd-Check-for-returned-pointer-from-strrchr-no.patch 32 0001-utils-ldd-Check-for-returned-pointer-from-strrchr-no.patch
33 0001-posix_fadvise64-fix-x86-implementation.patch
33 uclibcconfig.x86 34 uclibcconfig.x86
34 uclibcconfig.x86_64 35 uclibcconfig.x86_64
35 uclibcconfig.i486 36 uclibcconfig.i486
@@ -133,6 +134,7 @@ b4fb68ad3d0e8331b1b40c30eb21dfdc 0002-stdlib-fix-arc4random-return-type-to-u_in
13330f27fe51fdc4d121166ad2af18dfb8d 0001-malloc-standard-synchronize-on-fork.patch 13430f27fe51fdc4d121166ad2af18dfb8d 0001-malloc-standard-synchronize-on-fork.patch
1342ab8c375fe1cd406319b4c5ef538da2b 0001-resolv-fix-res_close-not-to-hang-with-ipv6.patch 1352ab8c375fe1cd406319b4c5ef538da2b 0001-resolv-fix-res_close-not-to-hang-with-ipv6.patch
13512f6297249755d3996918485bbd6031d 0001-utils-ldd-Check-for-returned-pointer-from-strrchr-no.patch 13612f6297249755d3996918485bbd6031d 0001-utils-ldd-Check-for-returned-pointer-from-strrchr-no.patch
137100d026c2d7cf7fc5906229448c791d4 0001-posix_fadvise64-fix-x86-implementation.patch
136b878bcfe02bf7a886ca85620fb330f56 uclibcconfig.x86 138b878bcfe02bf7a886ca85620fb330f56 uclibcconfig.x86
1378048c16964e93d5971b8dff6726d5afa uclibcconfig.x86_64 1398048c16964e93d5971b8dff6726d5afa uclibcconfig.x86_64
138b878bcfe02bf7a886ca85620fb330f56 uclibcconfig.i486 140b878bcfe02bf7a886ca85620fb330f56 uclibcconfig.i486