aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-04-20 06:54:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-04-20 07:16:47 +0000
commitf7108a52947196e71078ba32ad93ede3b607db1e (patch)
treeb8f048fd8e5668ab0a677deb0f5f931703cb96f0
parent443af6fbde8be65de45228a926e021f8be852d39 (diff)
downloadalpine_aports-f7108a52947196e71078ba32ad93ede3b607db1e.tar.bz2
alpine_aports-f7108a52947196e71078ba32ad93ede3b607db1e.tar.xz
alpine_aports-f7108a52947196e71078ba32ad93ede3b607db1e.zip
main/thunar: upgrade to 1.3.0
-rw-r--r--main/thunar/APKBUILD36
-rw-r--r--main/thunar/thunar-sendto-audacious-playlist.desktop14
-rw-r--r--main/thunar/thunar-sendto-bluetooth.desktop13
3 files changed, 55 insertions, 8 deletions
diff --git a/main/thunar/APKBUILD b/main/thunar/APKBUILD
index 3f788af174..c12ffef3c0 100644
--- a/main/thunar/APKBUILD
+++ b/main/thunar/APKBUILD
@@ -1,23 +1,29 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=thunar 2pkgname=thunar
3pkgver=1.2.1 3pkgver=1.3.0
4pkgrel=0 4pkgrel=0
5pkgdesc="File manager for Xfce" 5pkgdesc="File manager for Xfce"
6url="http://thunar.xfce.org" 6url="http://thunar.xfce.org"
7arch="all" 7arch="all"
8license="GPL2 LGPL2" 8license="GPL2 LGPL2"
9subpackages="$pkgname-dev $pkgname-doc" 9subpackages="$pkgname-dev $pkgname-doc"
10depends="desktop-file-utils hicolor-icon-theme" 10depends="desktop-file-utils hicolor-icon-theme shared-mime-info"
11makedepends="libexif-dev xfce4-panel-dev exo-dev pcre-dev udev-dev 11makedepends="libexif-dev xfce4-panel-dev exo-dev pcre-dev udev-dev
12 libnotify-dev startup-notification-dev libxfce4ui-dev" 12 libnotify-dev startup-notification-dev libxfce4ui-dev dbus-glib-dev"
13install= 13install=
14source="http://archive.xfce.org/src/xfce/thunar/${pkgver%.*}/Thunar-$pkgver.tar.bz2" 14source="http://archive.xfce.org/src/xfce/thunar/${pkgver%.*}/Thunar-$pkgver.tar.bz2
15 thunar-sendto-audacious-playlist.desktop
16 thunar-sendto-bluetooth.desktop
17 "
15 18
16depends_dev="gtk+-dev glib-dev" 19depends_dev="gtk+-dev glib-dev exo-dev"
17_builddir="$srcdir"/Thunar-$pkgver 20_builddir="$srcdir"/Thunar-$pkgver
18 21
19prepare() { 22prepare() {
20 cd "$_builddir" 23 cd "$_builddir"
24 # fix icon in thunar-sendto-email.desktop
25 sed -i 's!internet-mail!mail-message-new!' \
26 plugins/thunar-sendto-email/thunar-sendto-email.desktop.in.in
21} 27}
22 28
23build() { 29build() {
@@ -28,14 +34,28 @@ build() {
28 --localstatedir=/var \ 34 --localstatedir=/var \
29 --disable-static \ 35 --disable-static \
30 --enable-exif \ 36 --enable-exif \
31 --enable-pcre 37 --enable-pcre \
38 --enable-dbus \
39 || return 1
32 make || return 1 40 make || return 1
33} 41}
34 42
35package() { 43package() {
36 cd "$_builddir" 44 cd "$_builddir"
45 local f
37 make DESTDIR="$pkgdir" install || return 1 46 make DESTDIR="$pkgdir" install || return 1
38 sed -i 's:x-directory/gnome-default-handler;::' "$pkgdir"/usr/share/applications/Thunar-folder-handler.desktop 47 sed -i -e 's:x-directory/gnome-default-handler;::' \
48 "$pkgdir"/usr/share/applications/Thunar-folder-handler.desktop
49 for f in $source; do
50 case $f in
51 thunar-sendto*.desktop)
52 install -m644 "$srcdir"/$f \
53 "$pkgdir"/usr/share/Thunar/sendto/ || return 1
54 ;;
55 esac
56 done
39} 57}
40 58
41md5sums="d8dce796890619d67aed0cd7ef84c7b1 Thunar-1.2.1.tar.bz2" 59md5sums="ab6f728384c0d925b40afae2f41268f3 Thunar-1.3.0.tar.bz2
605a1e2ed692f3f95113339f5646f83af3 thunar-sendto-audacious-playlist.desktop
611131368b7360a0132d5b36ff2cae898a thunar-sendto-bluetooth.desktop"
diff --git a/main/thunar/thunar-sendto-audacious-playlist.desktop b/main/thunar/thunar-sendto-audacious-playlist.desktop
new file mode 100644
index 0000000000..97f9853180
--- /dev/null
+++ b/main/thunar/thunar-sendto-audacious-playlist.desktop
@@ -0,0 +1,14 @@
1[Desktop Entry]
2Version=1.0
3Name=Audacious Playlist
4Name[de]=Audacious Wiedergabeliste
5GenericName=Audio Playlist
6GenericName[de]= Wiedergabeliste
7Comment=Enque files to playlist
8Comment[de]=Dateien zur Wiedergabeliste hinzufügen
9Exec=audacious -e %F
10TryExec=audacious
11Icon=audacious
12MimeType=audio/prs.sid;audio/x-flac;audio/x-it;audio/x-mod;audio/x-ms-wma;audio/x-musepack;audio/x-s3m;audio/x-stm;audio/x-xm;application/ogg;audio/x-vorbis+ogg;inode/directory;
13Terminal=false
14Type=Application
diff --git a/main/thunar/thunar-sendto-bluetooth.desktop b/main/thunar/thunar-sendto-bluetooth.desktop
new file mode 100644
index 0000000000..98899f69ab
--- /dev/null
+++ b/main/thunar/thunar-sendto-bluetooth.desktop
@@ -0,0 +1,13 @@
1[Desktop Entry]
2Version=1.0
3Name=Bluetooth OBEX Recipient
4Name[de]=Bluetooth OBEX Empfänger
5GenericName=Bluetooth Recipient
6GenericName[de]=Bluetooth Empfänger
7Comment=Send selected files via Bluetooth
8Comment[de]=Ausgewählte Dateien per Bluetooth senden
9Exec=bluetooth-sendto %F
10TryExec=bluetooth-sendto
11Icon=bluetooth
12Terminal=false
13Type=Application