aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2011-10-20 10:33:47 -0400
committerTimo Teräs <timo.teras@iki.fi>2011-10-20 10:33:47 -0400
commited5fe58cea4aa858d89166fe2cb730e47ff84201 (patch)
treeab35452758978d6534b8be7da3fb9eb6890b67bb
parent0f297032cdf827b77fdbafd3f831018c2aff8f8d (diff)
downloadalpine_aports-ed5fe58cea4aa858d89166fe2cb730e47ff84201.tar.bz2
alpine_aports-ed5fe58cea4aa858d89166fe2cb730e47ff84201.tar.xz
alpine_aports-ed5fe58cea4aa858d89166fe2cb730e47ff84201.zip
main/dahd-linux-grsec: re-enable with grsec compilation issues addressed
* turn off the constify plugin: it breaks the build * update zaphfc patch to define spinlock with proper syntax
-rw-r--r--main/dahdi-linux-grsec/APKBUILD10
-rw-r--r--main/dahdi-linux-grsec/dahdi-zaphfc.patch2
-rw-r--r--main/dahdi-linux-grsec/zaphfc-dahdi-flortz.diff2
3 files changed, 7 insertions, 7 deletions
diff --git a/main/dahdi-linux-grsec/APKBUILD b/main/dahdi-linux-grsec/APKBUILD
index d158205e61..0bc20dda36 100644
--- a/main/dahdi-linux-grsec/APKBUILD
+++ b/main/dahdi-linux-grsec/APKBUILD
@@ -21,7 +21,7 @@ _mypkgrel=1
21pkgrel=$(( $_kpkgrel + $_mypkgrel )) 21pkgrel=$(( $_kpkgrel + $_mypkgrel ))
22pkgdesc="Digium Asterisk Hardware Device Interface drivers $_dahdiver" 22pkgdesc="Digium Asterisk Hardware Device Interface drivers $_dahdiver"
23url="http://www.asterisk.org" 23url="http://www.asterisk.org"
24arch="" 24arch="all"
25license="GPL" 25license="GPL"
26depends="dahdi-linux linux-${_flavor}=${_kernelver}" 26depends="dahdi-linux linux-${_flavor}=${_kernelver}"
27# we need wget and tar because make install downloads firmware and uses fancy 27# we need wget and tar because make install downloads firmware and uses fancy
@@ -54,13 +54,13 @@ prepare() {
54build() { 54build() {
55 cd "$srcdir/$_realname-$_dahdiver" 55 cd "$srcdir/$_realname-$_dahdiver"
56 export GCC_SPECS=/usr/share/gcc/hardenednopie.specs 56 export GCC_SPECS=/usr/share/gcc/hardenednopie.specs
57 make KVERS="${_abi_release}" DYNFS="yes" MODULES_EXTRA="zaphfc" \ 57 make KVERS="${_abi_release}" DYNFS="yes" MODULES_EXTRA="zaphfc" CONSTIFY_PLUGIN= \
58 || return 1 58 || return 1
59} 59}
60 60
61package() { 61package() {
62 cd "$srcdir/$_realname-$_dahdiver" 62 cd "$srcdir/$_realname-$_dahdiver"
63 make KVERS="${_abi_release}" DYNFS="yes" MODULES_EXTRA="zaphfc" \ 63 make KVERS="${_abi_release}" DYNFS="yes" MODULES_EXTRA="zaphfc" CONSTIFY_PLUGIN= \
64 DESTDIR="$pkgdir" install-modules || return 1 64 DESTDIR="$pkgdir" install-modules || return 1
65 rm -rf "$pkgdir"/lib/firmware "$pkgdir"/usr/lib/hotplug/firmware \ 65 rm -rf "$pkgdir"/lib/firmware "$pkgdir"/usr/lib/hotplug/firmware \
66 "$pkgdir"/usr/include 66 "$pkgdir"/usr/include
@@ -81,7 +81,7 @@ md5sums="d7efc5ebc9bf81a5263321e5e9891fc1 dahdi-linux-2.5.0.1.tar.gz
81c78fb8d80f9efdffd950297c88ff9273 dahdi-depmod.patch 81c78fb8d80f9efdffd950297c88ff9273 dahdi-depmod.patch
823bb419ac598534cd4ad5248f23656001 dahdi-bri_dchan.patch 823bb419ac598534cd4ad5248f23656001 dahdi-bri_dchan.patch
839088ee5cd24f94b7f90c24e5ed6071e0 dahdi-2.5.0-bri-fixes.patch 839088ee5cd24f94b7f90c24e5ed6071e0 dahdi-2.5.0-bri-fixes.patch
84a822c092f0548cd13f5e8d8cba053af6 dahdi-zaphfc.patch 84c6308ea8aaafba0a9d7f9825d7c9dcf8 dahdi-zaphfc.patch
85291c5c44c86ab02443a742415461ddca zaphfc-dahdi-flortz.diff 85035a6d91b2fb56a9b76a60a2e494fe9e zaphfc-dahdi-flortz.diff
860fdcd8c8c93bc1fe33c0af12b6cc6b05 zaphfc-dahdi-2.4.0.patch 860fdcd8c8c93bc1fe33c0af12b6cc6b05 zaphfc-dahdi-2.4.0.patch
879ed23321512274c6c5c5b76af0411e38 zaphfc-dahdi-2.5.0.patch" 879ed23321512274c6c5c5b76af0411e38 zaphfc-dahdi-2.5.0.patch"
diff --git a/main/dahdi-linux-grsec/dahdi-zaphfc.patch b/main/dahdi-linux-grsec/dahdi-zaphfc.patch
index b711c07ff9..3e6c7e0a36 100644
--- a/main/dahdi-linux-grsec/dahdi-zaphfc.patch
+++ b/main/dahdi-linux-grsec/dahdi-zaphfc.patch
@@ -77,7 +77,7 @@ Index: dahdi-linux-2.1.0/drivers/dahdi/zaphfc.c
77+static int modes = 0; // all TE 77+static int modes = 0; // all TE
78+static int debug = 0; 78+static int debug = 0;
79+static struct pci_dev *multi_hfc = NULL; 79+static struct pci_dev *multi_hfc = NULL;
80+static spinlock_t registerlock = SPIN_LOCK_UNLOCKED; 80+static DEFINE_SPINLOCK(registerlock);
81+ 81+
82+void hfc_shutdownCard(struct hfc_card *hfctmp) { 82+void hfc_shutdownCard(struct hfc_card *hfctmp) {
83+ unsigned long flags; 83+ unsigned long flags;
diff --git a/main/dahdi-linux-grsec/zaphfc-dahdi-flortz.diff b/main/dahdi-linux-grsec/zaphfc-dahdi-flortz.diff
index 719accdc69..f1ecc093af 100644
--- a/main/dahdi-linux-grsec/zaphfc-dahdi-flortz.diff
+++ b/main/dahdi-linux-grsec/zaphfc-dahdi-flortz.diff
@@ -164,7 +164,7 @@ Index: dahdi-linux-2.1.0.4/drivers/dahdi/zaphfc.c
164+static int jitterbuffer = 1; 164+static int jitterbuffer = 1;
165 static int debug = 0; 165 static int debug = 0;
166 static struct pci_dev *multi_hfc = NULL; 166 static struct pci_dev *multi_hfc = NULL;
167 static spinlock_t registerlock = SPIN_LOCK_UNLOCKED; 167 static DEFINE_SPINLOCK(registerlock);
168 168
169-void hfc_shutdownCard(struct hfc_card *hfctmp) { 169-void hfc_shutdownCard(struct hfc_card *hfctmp) {
170- unsigned long flags; 170- unsigned long flags;