aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-10-25 14:28:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-10-25 18:54:03 +0000
commit4911943cce67c63321cc08411e04d049c8033659 (patch)
tree38a3979d7c611fd17bb40323af7968ec188ce332
parent0a31cde9be610db83a7e7c139879038f244cd2d3 (diff)
downloadalpine_aports-4911943cce67c63321cc08411e04d049c8033659.tar.bz2
alpine_aports-4911943cce67c63321cc08411e04d049c8033659.tar.xz
alpine_aports-4911943cce67c63321cc08411e04d049c8033659.zip
main/mesa: upgrade to 7.11
-rw-r--r--main/mesa/APKBUILD59
-rw-r--r--main/mesa/Mesa-7.10.1-nouveau-compile.patch139
2 files changed, 39 insertions, 159 deletions
diff --git a/main/mesa/APKBUILD b/main/mesa/APKBUILD
index 40cbe65f7e..8bb47f286a 100644
--- a/main/mesa/APKBUILD
+++ b/main/mesa/APKBUILD
@@ -1,6 +1,6 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=mesa 2pkgname=mesa
3pkgver=7.10.3 3pkgver=7.11
4pkgrel=0 4pkgrel=0
5pkgdesc="Mesa DRI OpenGL library" 5pkgdesc="Mesa DRI OpenGL library"
6url="http://www.mesa3d.org" 6url="http://www.mesa3d.org"
@@ -18,21 +18,21 @@ subpackages="$pkgname-dev
18 $pkgname-dri-tdfx:tdfx 18 $pkgname-dri-tdfx:tdfx
19 $pkgname-dri-unichrome:unichrome 19 $pkgname-dri-unichrome:unichrome
20 $pkgname-dri-nouveau:nouveau 20 $pkgname-dri-nouveau:nouveau
21 $pkgname-egl 21 $pkgname-dri-vmwgfx:vmwgfx
22 $pkgname-egl $pkgname-glu $pkgname-gl $pkgname-gles
22 " 23 "
23 24
24makedepends="pkgconfig libdrm-dev libxxf86vm-dev libxdamage-dev expat-dev 25depends_dev="libdrm-dev dri2proto libx11-dev libxext-dev libxxf86vm-dev
25 dri2proto xextproto libx11-dev glproto python libxt-dev makedepend 26 libxdamage-dev libxfixes-dev libxcb-dev glproto"
26 talloc-dev py-libxml2 flex bison" 27makedepends="$depends_dev expat-dev xextproto python libxt-dev makedepend
28 talloc-dev py-libxml2 flex bison llvm-dev"
27source="ftp://ftp.freedesktop.org/pub/mesa/$pkgver/MesaLib-$pkgver.tar.bz2 29source="ftp://ftp.freedesktop.org/pub/mesa/$pkgver/MesaLib-$pkgver.tar.bz2
28 mesa-7.10-uclibc.patch 30 mesa-7.10-uclibc.patch
29 mesa-7.10-uclibc-glsl.patch 31 mesa-7.10-uclibc-glsl.patch
30 mesa-7.10-uclibc-gallium.patch 32 mesa-7.10-uclibc-gallium.patch
31 Mesa-7.10.1-nouveau-compile.patch
32 " 33 "
34# Mesa-7.10.1-nouveau-compile.patch
33 35
34depends_dev="libdrm-dev dri2proto libx11-dev libxext-dev libxxf86vm-dev
35 libxdamage-dev libxfixes-dev libxcb-dev glproto"
36 36
37_dri_driverdir=/usr/lib/xorg/modules/dri 37_dri_driverdir=/usr/lib/xorg/modules/dri
38 38
@@ -58,7 +58,7 @@ prepare() {
58 58
59dev() { 59dev() {
60 default_dev; 60 default_dev;
61 depends="$depends_dev mesa mesa-egl" 61 depends="$depends_dev mesa mesa-egl mesa-gl mesa-glu mesa-gles"
62} 62}
63 63
64build() { 64build() {
@@ -69,12 +69,10 @@ build() {
69 --disable-asm \ 69 --disable-asm \
70 --disable-glx-tls \ 70 --disable-glx-tls \
71 --with-driver=dri \ 71 --with-driver=dri \
72 --with-state-trackers=dri,glx,egl \
73 --enable-xcb \ 72 --enable-xcb \
74 --enable-egl \ 73 --enable-egl \
75 --enable-gles2 \ 74 --enable-gles2 \
76 --enable-gallium-nouveau \ 75 --with-gallium-drivers=i915,i965,nouveau,r300,r600,svga,swrast \
77 --enable-gallium-swrast \
78 --disable-gallium-egl \ 76 --disable-gallium-egl \
79 --disable-glut \ 77 --disable-glut \
80 --disable-glw || return 1 78 --disable-glw || return 1
@@ -93,11 +91,32 @@ package() {
93 91
94egl() { 92egl() {
95 replaces="mesa" 93 replaces="mesa"
96 pkgdesc="Mesa OpenGLES support library and modules" 94 pkgdesc="Mesa libEGL runtime libraries"
97
98 install -d "$subpkgdir"/usr/lib 95 install -d "$subpkgdir"/usr/lib
99 mv "$pkgdir"/usr/lib/libEGL.so* "$subpkgdir"/usr/lib/ 96 mv "$pkgdir"/usr/lib/libEGL.so* "$subpkgdir"/usr/lib/
100 mv "$pkgdir"/usr/lib/egl "$subpkgdir"/usr/lib/egl 97}
98
99gl() {
100 replaces="mesa"
101 pkgdesc="Mesa libGL runtime libraries"
102 install -d "$subpkgdir"/usr/lib
103 mv "$pkgdir"/usr/lib/libGL.so* "$subpkgdir"/usr/lib/
104}
105
106glu() {
107 replaces="mesa"
108 pkgdesc="Mesa libGLU runtime libraries"
109 install -d "$subpkgdir"/usr/lib
110 mv "$pkgdir"/usr/lib/libGLU.so* "$subpkgdir"/usr/lib/
111}
112
113gles() {
114 replaces="mesa"
115 pkgdesc="Mesa libGLESv2 runtime libraries"
116 install -d "$subpkgdir"/usr/lib
117 mv "$pkgdir"/usr/lib/libGLESv2.so* \
118 "$pkgdir"/usr/lib/libglapi.so.* \
119 "$subpkgdir"/usr/lib/
101} 120}
102 121
103_mv_dri() { 122_mv_dri() {
@@ -120,11 +139,11 @@ savage() { _mv_dri savage_dri; }
120sis() { _mv_dri sis_dri; } 139sis() { _mv_dri sis_dri; }
121tdfx() { _mv_dri tdfx_dri; } 140tdfx() { _mv_dri tdfx_dri; }
122unichrome() { _mv_dri unichrome_dri; } 141unichrome() { _mv_dri unichrome_dri; }
123nouveau() { _mv_dri nouveau_dri; } 142nouveau() { _mv_dri nouveau_dri nouveau_vieux_dri; }
124swrast() { _mv_dri swrast_dri; } 143swrast() { _mv_dri swrast_dri swrastg_dri; }
144vmwgfx() { _mv_dri vmwgfx_dri; }
125 145
126md5sums="8c38fe8266be8e1ed1d84076ba5a703b MesaLib-7.10.3.tar.bz2 146md5sums="ff03aca82d0560009a076a87c888cf13 MesaLib-7.11.tar.bz2
1279c8c161f954f0d08895cd9d45e63f498 mesa-7.10-uclibc.patch 1479c8c161f954f0d08895cd9d45e63f498 mesa-7.10-uclibc.patch
12803e9685b0d714e915c35fd0fb5fde810 mesa-7.10-uclibc-glsl.patch 14803e9685b0d714e915c35fd0fb5fde810 mesa-7.10-uclibc-glsl.patch
12990a2ea438ff328443a0436a91a74d518 mesa-7.10-uclibc-gallium.patch 14990a2ea438ff328443a0436a91a74d518 mesa-7.10-uclibc-gallium.patch"
13034e3d4bb5f16bae55929958083087c0a Mesa-7.10.1-nouveau-compile.patch"
diff --git a/main/mesa/Mesa-7.10.1-nouveau-compile.patch b/main/mesa/Mesa-7.10.1-nouveau-compile.patch
deleted file mode 100644
index 96dafceb07..0000000000
--- a/main/mesa/Mesa-7.10.1-nouveau-compile.patch
+++ /dev/null
@@ -1,139 +0,0 @@
1--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_clear.c.ark 2011-04-11 10:26:00.717291484 +0200
2+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_clear.c 2011-04-11 10:26:05.600624698 +0200
3@@ -24,6 +24,8 @@
4 #include "pipe/p_defines.h"
5 #include "pipe/p_state.h"
6
7+#include <nouveau/nv04_pushbuf.h>
8+
9 #include "nv50_context.h"
10
11 void
12--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_context.c.ark 2011-04-11 10:25:55.913958268 +0200
13+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_context.c 2011-04-11 10:26:00.663958154 +0200
14@@ -23,6 +23,8 @@
15 #include "draw/draw_context.h"
16 #include "pipe/p_defines.h"
17
18+#include <nouveau/nv04_pushbuf.h>
19+
20 #include "nv50_context.h"
21 #include "nv50_screen.h"
22 #include "nv50_resource.h"
23--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_push.c.ark 2011-04-11 10:25:50.250625073 +0200
24+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_push.c 2011-04-11 10:25:55.873958269 +0200
25@@ -4,6 +4,8 @@
26 #include "util/u_format.h"
27 #include "util/u_split_prim.h"
28
29+#include <nouveau/nv04_pushbuf.h>
30+
31 #include "nv50_context.h"
32 #include "nv50_resource.h"
33
34--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_query.c.ark 2011-04-11 10:25:44.790625206 +0200
35+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_query.c 2011-04-11 10:25:50.183958407 +0200
36@@ -23,6 +23,8 @@
37 #include "pipe/p_context.h"
38 #include "util/u_inlines.h"
39
40+#include <nouveau/nv04_pushbuf.h>
41+
42 #include "nv50_context.h"
43
44 struct nv50_query {
45--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_screen.c.ark 2011-04-11 10:25:32.790625497 +0200
46+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_screen.c 2011-04-11 10:25:38.633958688 +0200
47@@ -23,6 +23,8 @@
48 #include "util/u_format_s3tc.h"
49 #include "pipe/p_screen.h"
50
51+#include <nouveau/nv04_pushbuf.h>
52+
53 #include "nv50_context.h"
54 #include "nv50_screen.h"
55 #include "nv50_resource.h"
56--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_shader_state.c.ark 2011-04-11 10:25:38.710625354 +0200
57+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_shader_state.c 2011-04-11 10:25:44.713958540 +0200
58@@ -26,6 +26,8 @@
59 #include "pipe/p_state.h"
60 #include "util/u_inlines.h"
61
62+#include <nouveau/nv04_pushbuf.h>
63+
64 #include "nv50_context.h"
65
66 static void
67--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_state_validate.c.ark 2011-04-11 10:25:27.520625626 +0200
68+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_state_validate.c 2011-04-11 10:25:32.737292166 +0200
69@@ -22,6 +22,7 @@
70
71 #include "util/u_format.h"
72
73+#include <nouveau/nv04_pushbuf.h>
74 #include "nv50_context.h"
75 #include "nv50_resource.h"
76 #include "nouveau/nouveau_stateobj.h"
77--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_surface.c.ark 2011-04-11 10:25:22.407292417 +0200
78+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_surface.c 2011-04-11 10:25:27.450625628 +0200
79@@ -22,6 +22,7 @@
80
81 #define __NOUVEAU_PUSH_H__
82 #include <stdint.h>
83+#include <nouveau/nv04_pushbuf.h>
84 #include "nouveau/nouveau_pushbuf.h"
85 #include "nv50_context.h"
86 #include "nv50_resource.h"
87--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_transfer.c.ark 2011-04-11 10:25:14.903959267 +0200
88+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_transfer.c 2011-04-11 10:25:22.353959086 +0200
89@@ -4,6 +4,8 @@
90 #include "util/u_format.h"
91 #include "util/u_math.h"
92
93+#include <nouveau/nv04_pushbuf.h>
94+
95 #include "nv50_context.h"
96 #include "nv50_transfer.h"
97 #include "nv50_resource.h"
98--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_vbo.c.ark 2011-04-11 10:25:01.717292921 +0200
99+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_vbo.c 2011-04-11 10:25:14.850625935 +0200
100@@ -26,6 +26,8 @@
101 #include "util/u_format.h"
102 #include "util/u_split_prim.h"
103
104+#include <nouveau/nv04_pushbuf.h>
105+
106 #include "nv50_context.h"
107 #include "nv50_resource.h"
108
109--- Mesa-7.10.1/src/gallium/drivers/nvfx/nv04_2d.c.ark 2011-04-11 10:23:22.800628664 +0200
110+++ Mesa-7.10.1/src/gallium/drivers/nvfx/nv04_2d.c 2011-04-11 10:25:01.640626257 +0200
111@@ -39,6 +39,7 @@
112 #include <nouveau/nouveau_bo.h>
113 #include <nouveau/nouveau_notifier.h>
114 #include <nouveau/nouveau_grobj.h>
115+#include <nouveau/nv04_pushbuf.h>
116 #include "nv04_2d.h"
117
118 #include "nouveau/nv_object.xml.h"
119--- Mesa-7.10.1/src/gallium/drivers/nvfx/nvfx_screen.c.ark 2011-04-11 10:27:59.380621927 +0200
120+++ Mesa-7.10.1/src/gallium/drivers/nvfx/nvfx_screen.c 2011-04-11 10:28:02.833955176 +0200
121@@ -3,6 +3,7 @@
122 #include "util/u_format_s3tc.h"
123 #include "util/u_simple_screen.h"
124
125+#include <nouveau/nv04_pushbuf.h>
126 #include "nouveau/nouveau_screen.h"
127 #include "nouveau/nv_object.xml.h"
128 #include "nvfx_context.h"
129--- Mesa-7.10.1/src/mesa/drivers/dri/nouveau/nv04_context.c.ark 2011-04-11 10:27:27.220622711 +0200
130+++ Mesa-7.10.1/src/mesa/drivers/dri/nouveau/nv04_context.c 2011-04-11 11:09:24.147228063 +0200
131@@ -24,6 +24,8 @@
132 *
133 */
134
135+#include <stdint.h>
136+#include <nouveau/nv04_pushbuf.h>
137 #include "nouveau_driver.h"
138 #include "nouveau_context.h"
139 #include "nouveau_fbo.h"