aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-10-25 16:51:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-10-25 18:54:07 +0000
commitb5c0890914ac3debe6d569fdcd25c88d57ea6865 (patch)
tree1c0e2cc1787da1923dc6e2c88df938df135cec64
parentfb1ef2c33ecb16bc986503dd88414f8433bbe98d (diff)
downloadalpine_aports-b5c0890914ac3debe6d569fdcd25c88d57ea6865.tar.bz2
alpine_aports-b5c0890914ac3debe6d569fdcd25c88d57ea6865.tar.xz
alpine_aports-b5c0890914ac3debe6d569fdcd25c88d57ea6865.zip
main/bsnes: upgrade to 0.83
-rw-r--r--main/bsnes/APKBUILD6
-rw-r--r--main/bsnes/nall-strlcpy.patch44
2 files changed, 25 insertions, 25 deletions
diff --git a/main/bsnes/APKBUILD b/main/bsnes/APKBUILD
index 7b4e8121f8..0916f07e7c 100644
--- a/main/bsnes/APKBUILD
+++ b/main/bsnes/APKBUILD
@@ -1,7 +1,7 @@
1# Contributor: William Pitcock <nenolod@dereferenced.org> 1# Contributor: William Pitcock <nenolod@dereferenced.org>
2# Maintainer: William Pitcock <nenolod@dereferenced.org> 2# Maintainer: William Pitcock <nenolod@dereferenced.org>
3pkgname=bsnes 3pkgname=bsnes
4pkgver=0.78 4pkgver=0.83
5_x=${pkgver%.*} 5_x=${pkgver%.*}
6_y=${pkgver#*.} 6_y=${pkgver#*.}
7_pkgver="v${_x}${_y}" 7_pkgver="v${_x}${_y}"
@@ -40,6 +40,6 @@ package() {
40 make DESTDIR="$pkgdir" prefix=/usr profile=performance install || return 1 40 make DESTDIR="$pkgdir" prefix=/usr profile=performance install || return 1
41} 41}
42 42
43md5sums="19c07dc9be18bf3314f4e7122c00f16e bsnes_v078-source.tar.bz2 43md5sums="a1f017f5276ec5be0bc553db2b7e2241 bsnes_v083-source.tar.bz2
44d5017142f2cbccac878bbfc799b3445f nall-strlcpy.patch 4411d7129c769add65a4b03ef9193729f2 nall-strlcpy.patch
4507caea846bf49ee6f5deaf999dffbd5f no-pulseaudio.patch" 4507caea846bf49ee6f5deaf999dffbd5f no-pulseaudio.patch"
diff --git a/main/bsnes/nall-strlcpy.patch b/main/bsnes/nall-strlcpy.patch
index dd4a005a63..fa0859d448 100644
--- a/main/bsnes/nall-strlcpy.patch
+++ b/main/bsnes/nall-strlcpy.patch
@@ -1,31 +1,31 @@
1--- bsnes_v077-source/bsnes/snes/system/serialization.cpp 1--- ./bsnes/ui/tools/state-manager.cpp.orig
2+++ bsnes_v077-source/bsnes/snes/system/serialization.cpp 2+++ ./bsnes/ui/tools/state-manager.cpp
3@@ -7,7 +7,7 @@ 3@@ -135,7 +135,7 @@
4 char profile[16], description[512]; 4 string StateManager::slotLoadDescription(unsigned n) {
5 memset(&profile, 0, sizeof profile); 5 if(slot[n].capacity() == 0) return "(empty)";
6 memset(&description, 0, sizeof description); 6 char text[DescriptionLength];
7- strlcpy(profile, Info::Profile, sizeof profile); 7- strlcpy(text, (const char*)slot[n].data() + HeaderLength, DescriptionLength);
8+ nall::strlcpy(profile, Info::Profile, sizeof profile); 8+ nall::strlcpy(text, (const char*)slot[n].data() + HeaderLength, DescriptionLength);
9
10 s.integer(signature);
11 s.integer(version);
12--- bsnes_v077-source/bsnes/ui/tools/state-manager.cpp
13+++ bsnes_v077-source/bsnes/ui/tools/state-manager.cpp
14@@ -130,7 +130,7 @@
15 string StateManager::slotLoadDescription(unsigned i) {
16 if(slot[i].capacity() == 0) return "(empty)";
17 char text[512];
18- strlcpy(text, (const char*)slot[i].data() + HeaderLength, 512);
19+ nall::strlcpy(text, (const char*)slot[i].data() + HeaderLength, 512);
20 return text; 9 return text;
21 } 10 }
22 11
23@@ -138,7 +138,7 @@ 12@@ -143,7 +143,7 @@
24 if(stateList.selected() == false) return; 13 if(stateList.selected() == false) return;
25 string text = descEdit.text(); 14 string text = descEdit.text();
26 if(slot[stateList.selection()].capacity() > 0) { 15 if(slot[stateList.selection()].capacity() > 0) {
27- strlcpy((char*)slot[stateList.selection()].data() + HeaderLength, (const char*)text, 512); 16- strlcpy((char*)slot[stateList.selection()].data() + HeaderLength, (const char*)text, DescriptionLength);
28+ nall::strlcpy((char*)slot[stateList.selection()].data() + HeaderLength, (const char*)text, 512); 17+ nall::strlcpy((char*)slot[stateList.selection()].data() + HeaderLength, (const char*)text, DescriptionLength);
29 } 18 }
30 refresh(); 19 refresh();
31 } 20 }
21--- ./bsnes/snes/system/serialization.cpp.orig
22+++ ./bsnes/snes/system/serialization.cpp
23@@ -7,7 +7,7 @@
24 char description[512], profile[16];
25 memset(&description, 0, sizeof description);
26 memset(&profile, 0, sizeof profile);
27- strlcpy(profile, Info::Profile, sizeof profile);
28+ nall::strlcpy(profile, Info::Profile, sizeof profile);
29
30 s.integer(signature);
31 s.integer(version);