aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2011-10-26 12:16:31 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2011-10-26 12:16:31 +0000
commitc7a609b0b54e39e05fbde10d7d6367ab635abe41 (patch)
tree24a1186f30ed792a72f23c06d47a064317d0e898
parente6cc361bd87ad72b64ec8c80f38b29c1837e7351 (diff)
downloadalpine_aports-c7a609b0b54e39e05fbde10d7d6367ab635abe41.tar.bz2
alpine_aports-c7a609b0b54e39e05fbde10d7d6367ab635abe41.tar.xz
alpine_aports-c7a609b0b54e39e05fbde10d7d6367ab635abe41.zip
testing/gitolite: new aport
-rw-r--r--testing/gitolite/APKBUILD47
-rw-r--r--testing/gitolite/configuration.patch27
2 files changed, 74 insertions, 0 deletions
diff --git a/testing/gitolite/APKBUILD b/testing/gitolite/APKBUILD
new file mode 100644
index 0000000000..86059331ab
--- /dev/null
+++ b/testing/gitolite/APKBUILD
@@ -0,0 +1,47 @@
1# Contributor: Carlo Landmeter <clandmeter@gmail.com>
2# Maintainer:
3pkgname=gitolite
4pkgver=2.1
5pkgrel=0
6pkgdesc="A centralized git server, with very fine-grained access control and many powerful features."
7url="http://github.com/sitaramc/gitolite"
8arch="noarch"
9license="GPL2"
10depends="git perl"
11depends_dev=""
12makedepends="$depends_dev"
13install=""
14subpackages="$pkgname-doc"
15source="saveas-https://github.com/sitaramc/gitolite/tarball/v2.1/gitolite-2.1.tar.gz
16 configuration.patch"
17
18_builddir="$srcdir"/sitaramc-gitolite-871ed28
19
20prepare() {
21 local i
22 cd "$_builddir"
23 for i in $source; do
24 case $i in
25 *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
26 esac
27 done
28}
29
30build() {
31 cd "$_builddir"
32}
33
34package() {
35 cd "$_builddir"
36 mkdir -p "$pkgdir"/usr/bin \
37 "$pkgdir"/etc/gitolite \
38 "$pkgdir"/usr/share/gitolite/hooks \
39 "$pkgdir"/usr/share/doc/gitolite
40 mv src/* "$pkgdir"/usr/bin/
41 mv conf/* "$pkgdir"/etc/gitolite/
42 mv hooks/* "$pkgdir"/usr/share/gitolite/hooks/
43 mv doc/* "$pkgdir"/usr/share/doc/gitolite/
44}
45
46md5sums="33e0f6f384cf0596aed974fa563b50c3 gitolite-2.1.tar.gz
47b4603bb37d3a746a1508bd7528464ba4 configuration.patch"
diff --git a/testing/gitolite/configuration.patch b/testing/gitolite/configuration.patch
new file mode 100644
index 0000000000..403dc4e261
--- /dev/null
+++ b/testing/gitolite/configuration.patch
@@ -0,0 +1,27 @@
1diff --git a/conf/example.gitolite.rc b/conf/example.gitolite.rc
2index d800357..95c5a24 100644
3--- a/conf/example.gitolite.rc
4+++ b/conf/example.gitolite.rc
5@@ -19,8 +19,8 @@ $GL_CONF_COMPILED="$GL_ADMINDIR/conf/gitolite.conf-compiled.pm";
6 # DO NOT CHANGE THE NEXT FOUR LINES UNLESS YOU REALLY KNOW WHAT YOU'RE DOING.
7 # These variables are set automatically by the install method you choose.
8 # (PACKAGE MAINTAINERS: PLEASE READ doc/packaging.mkd)
9-# $GL_PACKAGE_CONF = "";
10-# $GL_PACKAGE_HOOKS = "";
11+$GL_PACKAGE_CONF = "/etc/gitolite";
12+$GL_PACKAGE_HOOKS = "/usr/share/gitolite/hooks";
13
14 # ------------------------------------------------------------------------------
15 # most often used/changed variables
16diff --git a/src/gl-setup b/src/gl-setup
17index fd8357b..59de183 100755
18--- a/src/gl-setup
19+++ b/src/gl-setup
20@@ -1,6 +1,6 @@
21 #!/bin/sh
22
23-GL_PACKAGE_CONF=/tmp/share/gitolite/conf
24+GL_PACKAGE_CONF=/etc/gitolite
25 # must be the same as the value for the same variable in
26 # $GL_PACKAGE_CONF/example.gitolite.rc. Sorry about the catch-22 :)
27