aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-04 08:00:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-04 10:54:24 +0000
commit444f6067d59a88b5e8d6346099e864efb231606c (patch)
tree532a535e7b0c2ee72a1ea01a3553c9c8b23d7fe0
parent0dbd42c94d6d598b20bf553b733732854b0c173c (diff)
downloadalpine_aports-444f6067d59a88b5e8d6346099e864efb231606c.tar.bz2
alpine_aports-444f6067d59a88b5e8d6346099e864efb231606c.tar.xz
alpine_aports-444f6067d59a88b5e8d6346099e864efb231606c.zip
main/busybox: remove relocated symlinks
(cherry picked from commit b60e57c4f819be22d4691d4a0feff7f2e4931cdd)
-rw-r--r--main/busybox/APKBUILD2
-rw-r--r--main/busybox/busybox.post-upgrade10
2 files changed, 7 insertions, 5 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index fcfb6088c2..e942e696a1 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -1,7 +1,7 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=busybox 2pkgname=busybox
3pkgver=1.19.3 3pkgver=1.19.3
4pkgrel=2 4pkgrel=3
5_bbsuidver=0.6 5_bbsuidver=0.6
6pkgdesc="Size optimized toolbox of many common UNIX utilities" 6pkgdesc="Size optimized toolbox of many common UNIX utilities"
7url=http://busybox.net 7url=http://busybox.net
diff --git a/main/busybox/busybox.post-upgrade b/main/busybox/busybox.post-upgrade
index c55561cc11..268f22d408 100644
--- a/main/busybox/busybox.post-upgrade
+++ b/main/busybox/busybox.post-upgrade
@@ -1,9 +1,11 @@
1#!/bin/sh 1#!/bin/sh
2 2
3# /bin/install has moved to /usr/bin/install, but we need remove old link 3# remove links that has been relocated
4if [ -L /bin/install ] && [ "$(readlink /bin/install)" = "/bin/busybox" ]; then 4for link in /bin/install /bin/ip /bin/vi /usr/bin/lspci; do
5 rm /bin/install 5 if [ -L "$link" ] && [ "$(readlink $link)" = "/bin/busybox" ]; then
6fi 6 rm "$link"
7 fi
8done
7 9
8# We need the symlinks early 10# We need the symlinks early
9exec /bin/busybox --install -s 11exec /bin/busybox --install -s