aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-10 14:54:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-10 14:55:12 +0000
commitaec8070d40f61980210134fec4b6ef9ba937a5a7 (patch)
treeea9980df9f21620dcb492b61cd7dd4ea33838769
parenta9f1aa0785594722dbcebdf6b8c243a6c616a269 (diff)
downloadalpine_aports-aec8070d40f61980210134fec4b6ef9ba937a5a7.tar.bz2
alpine_aports-aec8070d40f61980210134fec4b6ef9ba937a5a7.tar.xz
alpine_aports-aec8070d40f61980210134fec4b6ef9ba937a5a7.zip
main/heimdal: security fix (CVE-2011-4862)
fixes #913 (cherry picked from commit f81ee55cee797b4203340cebc3f15691ac93faeb)
-rw-r--r--main/heimdal/APKBUILD6
-rw-r--r--main/heimdal/telnetd.patch14
2 files changed, 18 insertions, 2 deletions
diff --git a/main/heimdal/APKBUILD b/main/heimdal/APKBUILD
index 6fb47a1652..cd760c3f56 100644
--- a/main/heimdal/APKBUILD
+++ b/main/heimdal/APKBUILD
@@ -2,7 +2,7 @@
2# Contributor: Natanael Copa <ncopa@alpinelinux.org> 2# Contributor: Natanael Copa <ncopa@alpinelinux.org>
3pkgname=heimdal 3pkgname=heimdal
4pkgver=1.4 4pkgver=1.4
5pkgrel=9 5pkgrel=10
6pkgdesc="An implementation of Kerberos 5" 6pkgdesc="An implementation of Kerberos 5"
7arch="all" 7arch="all"
8url="http://www.h5l.org/" 8url="http://www.h5l.org/"
@@ -21,6 +21,7 @@ source="http://ftp4.de.freesbie.org/pub/misc/heimdal/src/$pkgname-$pkgver.tar.gz
21005_all_heimdal-suid_fix.patch 21005_all_heimdal-suid_fix.patch
22014_all_heimdal-path.patch 22014_all_heimdal-path.patch
23heimdal-1.4-make.patch 23heimdal-1.4-make.patch
24telnetd.patch
24" 25"
25 26
26_builddir="$srcdir/$pkgname-$pkgver" 27_builddir="$srcdir/$pkgname-$pkgver"
@@ -172,4 +173,5 @@ md5sums="31d08bbf47a77827fe97ef3f52b4c9c4 heimdal-1.4.tar.gz
1722feec3924ee5230b54175b4d4000c872 003_all_heimdal-rxapps.patch 1732feec3924ee5230b54175b4d4000c872 003_all_heimdal-rxapps.patch
17345aeb207f360f9f4e9e0fabc8bfeecbc 005_all_heimdal-suid_fix.patch 17445aeb207f360f9f4e9e0fabc8bfeecbc 005_all_heimdal-suid_fix.patch
1748208ae8c0b6ff5ab4f64af1693e9e396 014_all_heimdal-path.patch 1758208ae8c0b6ff5ab4f64af1693e9e396 014_all_heimdal-path.patch
175fa1753ec676029cd59a3ef24da55c144 heimdal-1.4-make.patch" 176fa1753ec676029cd59a3ef24da55c144 heimdal-1.4-make.patch
177f320b91692b872e28f446f9cf1bc68bf telnetd.patch"
diff --git a/main/heimdal/telnetd.patch b/main/heimdal/telnetd.patch
new file mode 100644
index 0000000000..9c4d10386c
--- /dev/null
+++ b/main/heimdal/telnetd.patch
@@ -0,0 +1,14 @@
1Index: crypto/heimdal/appl/telnet/libtelnet/encrypt.c
2===================================================================
3--- appl/telnet/libtelnet/encrypt.c (revision 228798)
4+++ appl/telnet/libtelnet/encrypt.c (working copy)
5@@ -736,6 +736,9 @@
6 int dir = kp->dir;
7 int ret = 0;
8
9+ if (len > MAXKEYLEN)
10+ len = MAXKEYLEN;
11+
12 if (!(ep = (*kp->getcrypt)(*kp->modep))) {
13 if (len == 0)
14 return;