aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-18 16:16:36 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-18 15:30:52 +0000
commitfbae5800c59a95522d4460080d9ab73c1493d868 (patch)
tree0ba0a7a4336aaec8420e5785d1614f9309af56f1
parent2c3d9526e3dde610d973b20dd4083d5174123e35 (diff)
downloadalpine_aports-fbae5800c59a95522d4460080d9ab73c1493d868.tar.bz2
alpine_aports-fbae5800c59a95522d4460080d9ab73c1493d868.tar.xz
alpine_aports-fbae5800c59a95522d4460080d9ab73c1493d868.zip
main/djbdns: fix tinydns on 64 bit - including uint32.h
The jumbo patch includes the 32bit version of the generated header files. This might break 64 bit builds depending on unpacking timestamps etc. We fix it by removing the generated headers, including uint32.h fixes #933 (cherry picked from commit 9522f53d78e887a4081f028662e6ae9bda6a04c7)
-rw-r--r--main/djbdns/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/main/djbdns/APKBUILD b/main/djbdns/APKBUILD
index 148ab2ec3d..f47a180bf4 100644
--- a/main/djbdns/APKBUILD
+++ b/main/djbdns/APKBUILD
@@ -1,7 +1,7 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=djbdns 2pkgname=djbdns
3pkgver=1.05 3pkgver=1.05
4pkgrel=40 4pkgrel=42
5pkgdesc="Excellent high-performance DNS services" 5pkgdesc="Excellent high-performance DNS services"
6url="http://cr.yp.to/djbdns.html" 6url="http://cr.yp.to/djbdns.html"
7arch="all" 7arch="all"
@@ -34,6 +34,9 @@ prepare() {
34 *.diff.gz) msg $i; gunzip -c "$srcdir"/$i | patch -p1 || return 1;; 34 *.diff.gz) msg $i; gunzip -c "$srcdir"/$i | patch -p1 || return 1;;
35 esac 35 esac
36 done 36 done
37 # remove all the generated headers. they came with the jumbo patch and should
38 # never have been there...
39 sed -n 's/^\([a-z0-9]\+\.h\):.*/\1/gp' Makefile Makefile.sig | xargs rm -f
37} 40}
38 41
39build() { 42build() {