aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-01-18 08:36:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-01-18 08:36:58 +0000
commit23407f9a3c95e1319f3cba8b93a2962028262852 (patch)
tree540072a5d096f0e45de3e430057ca3521b008149
parent9ed11261308c77e3ad54c6dd2a26aa3d7664b809 (diff)
downloadalpine_aports-23407f9a3c95e1319f3cba8b93a2962028262852.tar.bz2
alpine_aports-23407f9a3c95e1319f3cba8b93a2962028262852.tar.xz
alpine_aports-23407f9a3c95e1319f3cba8b93a2962028262852.zip
main/ruby-activesupport: security upgrade to 2.3.15 (CVE-2013-0156)
fixes #1574
-rw-r--r--main/ruby-activesupport/APKBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/main/ruby-activesupport/APKBUILD b/main/ruby-activesupport/APKBUILD
index 24df309d59..fee5b8c6b8 100644
--- a/main/ruby-activesupport/APKBUILD
+++ b/main/ruby-activesupport/APKBUILD
@@ -1,8 +1,8 @@
1# Contributor: Carlo Landmeter <clandmeter@gmail.com> 1# Contributor: Carlo Landmeter <clandmeter@gmail.com>
2# Maintainer: 2# Maintainer:
3pkgname=ruby-activesupport 3pkgname=ruby-activesupport
4_realname=activesupport 4_gemname=activesupport
5pkgver=2.3.11 5pkgver=2.3.15
6pkgrel=0 6pkgrel=0
7pkgdesc="Utility classes and extension to the standard library" 7pkgdesc="Utility classes and extension to the standard library"
8url="https://rubyforge.org/projects/activesupport/" 8url="https://rubyforge.org/projects/activesupport/"
@@ -13,20 +13,27 @@ depends_dev=
13makedepends="$depends_dev rubygems" 13makedepends="$depends_dev rubygems"
14install="" 14install=""
15subpackages="" 15subpackages=""
16source="" 16source="http://gems.rubyforge.org/gems/$_gemname-$pkgver.gem"
17 17
18_builddir="$srcdir"/$_realname-$pkgver 18_builddir="$srcdir"/$_realname-$pkgver
19 19
20build() { 20build() {
21 mkdir -p "$_builddir" || return 1 21 mkdir -p "$_builddir" || return 1
22 local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')" 22 local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
23 gem install $_realname -v $pkgver -i "$_builddir"$_gemdir \ 23 local _geminstdir=$_gemdir/gems/$_gemname-$pkgver
24
25 gem install --local -i "$_builddir"$_gemdir \
24 --ignore-dependencies --verbose \ 26 --ignore-dependencies --verbose \
25 --no-rdoc --no-ri || return 1 27 --no-rdoc --no-ri \
26 rm -rf "$_builddir"$_gemdir/cache/ 28 "$srcdir"/$_gemname-$pkgver.gem || return 1
29 rm -rf "$_builddir"/$_gemdir/cache \
30 "$_builddir"/$_geminstdir/ext \
31 "$_builddir"/$_geminstdir/.require_paths
27} 32}
28 33
29package() { 34package() {
30 mkdir -p "$pkgdir" || return 1 35 mkdir -p "$pkgdir" || return 1
31 cp -ra "$_builddir"/* "$pkgdir"/ || return 1 36 cp -ra "$_builddir"/* "$pkgdir"/ || return 1
32} 37}
38
39md5sums="e85d00c8d7e535e71551b744006a13bc activesupport-2.3.15.gem"