aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoger Pau Monne <roger.pau@citrix.com>2013-01-11 18:06:24 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2013-01-14 16:42:01 +0000
commit5b4cf2b15d5a62c8ce00284410a099239d6935d2 (patch)
tree72d3979aa3ed5bae9b387b71f830cf23c50c421d
parent3fe73e04397a3ed9c88e92deef2e0c09ed2a5f28 (diff)
downloadalpine_aports-5b4cf2b15d5a62c8ce00284410a099239d6935d2.tar.bz2
alpine_aports-5b4cf2b15d5a62c8ce00284410a099239d6935d2.tar.xz
alpine_aports-5b4cf2b15d5a62c8ce00284410a099239d6935d2.zip
for-2.4-xen: add XSA-33 patch
-rw-r--r--main/xen/APKBUILD4
-rw-r--r--main/xen/xsa33-4.1.patch21
2 files changed, 24 insertions, 1 deletions
diff --git a/main/xen/APKBUILD b/main/xen/APKBUILD
index e5eba0809b..39033477e9 100644
--- a/main/xen/APKBUILD
+++ b/main/xen/APKBUILD
@@ -3,7 +3,7 @@
3# Maintainer: William Pitcock <nenolod@dereferenced.org> 3# Maintainer: William Pitcock <nenolod@dereferenced.org>
4pkgname=xen 4pkgname=xen
5pkgver=4.1.4 5pkgver=4.1.4
6pkgrel=0 6pkgrel=1
7pkgdesc="Xen hypervisor" 7pkgdesc="Xen hypervisor"
8url="http://www.xen.org/" 8url="http://www.xen.org/"
9arch="x86 x86_64" 9arch="x86 x86_64"
@@ -22,6 +22,7 @@ source="http://bits.xensource.com/oss-xen/release/$pkgver/$pkgname-$pkgver.tar.g
22 define_fsimage_dir.patch 22 define_fsimage_dir.patch
23 librt.patch 23 librt.patch
24 busybox-sed.patch 24 busybox-sed.patch
25 xsa33-4.1.patch
25 26
26 xenstored.initd 27 xenstored.initd
27 xenstored.confd 28 xenstored.confd
@@ -121,6 +122,7 @@ b973dc1ffcc6872e222b36f3b7b4836b fix_bswap_blktap2.patch
1210bb8a435020a5a49b38b1a447fb69977 define_fsimage_dir.patch 1220bb8a435020a5a49b38b1a447fb69977 define_fsimage_dir.patch
122fa06495a175571f4aa3b6cb88937953e librt.patch 123fa06495a175571f4aa3b6cb88937953e librt.patch
1231bea3543ddc712330527b62fd9ff6520 busybox-sed.patch 1241bea3543ddc712330527b62fd9ff6520 busybox-sed.patch
12525ba4efc5eee29daa12855fbadce84f8 xsa33-4.1.patch
1246e5739dad7e2bd1b625e55ddc6c782b7 xenstored.initd 1266e5739dad7e2bd1b625e55ddc6c782b7 xenstored.initd
125b017ccdd5e1c27bbf1513e3569d4ff07 xenstored.confd 127b017ccdd5e1c27bbf1513e3569d4ff07 xenstored.confd
126ed262f15fb880badb53575539468646c xenconsoled.initd 128ed262f15fb880badb53575539468646c xenconsoled.initd
diff --git a/main/xen/xsa33-4.1.patch b/main/xen/xsa33-4.1.patch
new file mode 100644
index 0000000000..d0bdeb44ac
--- /dev/null
+++ b/main/xen/xsa33-4.1.patch
@@ -0,0 +1,21 @@
1VT-d: fix interrupt remapping source validation for devices behind
2legacy bridges
3
4Using SVT_VERIFY_BUS here doesn't make sense; native Linux also
5uses SVT_VERIFY_SID_SQ here instead.
6
7This is XSA-33 / CVE-2012-5634.
8
9Signed-off-by: Jan Beulich <jbeulich@suse.com>
10
11--- a/xen/drivers/passthrough/vtd/intremap.c
12+++ b/xen/drivers/passthrough/vtd/intremap.c
13@@ -499,7 +499,7 @@ static void set_msi_source_id(struct pci_dev *pdev, struct iremap_entry *ire)
14 set_ire_sid(ire, SVT_VERIFY_BUS, SQ_ALL_16,
15 (bus << 8) | pdev->bus);
16 else if ( pdev_type(bus, devfn) == DEV_TYPE_LEGACY_PCI_BRIDGE )
17- set_ire_sid(ire, SVT_VERIFY_BUS, SQ_ALL_16,
18+ set_ire_sid(ire, SVT_VERIFY_SID_SQ, SQ_ALL_16,
19 PCI_BDF2(bus, devfn));
20 }
21 break;