aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-11-05 19:39:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-11-05 19:39:43 +0000
commite1a75a0227cc4a0a507328ef31051ccc0e83b623 (patch)
tree7268532f882ed357662c75de3616d4848f2f1d62
parent89d385775cd9723a848618b5c019086752f3e3e1 (diff)
downloadalpine_aports-e1a75a0227cc4a0a507328ef31051ccc0e83b623.tar.bz2
alpine_aports-e1a75a0227cc4a0a507328ef31051ccc0e83b623.tar.xz
alpine_aports-e1a75a0227cc4a0a507328ef31051ccc0e83b623.zip
main/alpine-conf: upgrade to 2.12.0
fixes #1463
-rw-r--r--main/alpine-conf/0001-lbu-check-permissions-when-generating-apkovl.patch28
-rw-r--r--main/alpine-conf/0001-lbu-do-not-use-xargs.patch65
-rw-r--r--main/alpine-conf/0001-setup-xen-dom0-update-to-upcoming-4.2.patch53
-rw-r--r--main/alpine-conf/APKBUILD12
4 files changed, 3 insertions, 155 deletions
diff --git a/main/alpine-conf/0001-lbu-check-permissions-when-generating-apkovl.patch b/main/alpine-conf/0001-lbu-check-permissions-when-generating-apkovl.patch
deleted file mode 100644
index 7eceeaa8c7..0000000000
--- a/main/alpine-conf/0001-lbu-check-permissions-when-generating-apkovl.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From 9a18a800011faf018ff49220ae368c673c690bdc Mon Sep 17 00:00:00 2001
2From: Natanael Copa <ncopa@alpinelinux.org>
3Date: Tue, 17 Jul 2012 10:52:54 +0000
4Subject: [PATCH] lbu: check permissions when generating apkovl
5
6We want include files and dirs that have changed permissions.
7
8ref #1241
9---
10 lbu.in | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/lbu.in b/lbu.in
14index 3fa157e..a0e68ed 100644
15--- a/lbu.in
16+++ b/lbu.in
17@@ -278,7 +278,7 @@ If <dirname> nor <filename> is not specified, a package named
18 }
19
20 _gen_filelist() {
21- apk audit --backup --quiet --recursive
22+ apk audit --backup --quiet --recursive --check-permissions
23 }
24
25 cmd_package() {
26--
271.7.11.2
28
diff --git a/main/alpine-conf/0001-lbu-do-not-use-xargs.patch b/main/alpine-conf/0001-lbu-do-not-use-xargs.patch
deleted file mode 100644
index 42dac49861..0000000000
--- a/main/alpine-conf/0001-lbu-do-not-use-xargs.patch
+++ /dev/null
@@ -1,65 +0,0 @@
1From 15245c4a0eb62b0e1bcbac5063391e0d57a53799 Mon Sep 17 00:00:00 2001
2From: Natanael Copa <ncopa@alpinelinux.org>
3Date: Wed, 4 Jul 2012 08:09:21 +0200
4Subject: [PATCH] lbu: do not use xargs
5
6xargs will execute the command twice if the buffer becomes long enough.
7This will break tar.
8
9We also use -z instead of piping via gzip while here.
10
11ref #1240
12---
13 lbu.in | 14 ++++----------
14 1 file changed, 4 insertions(+), 10 deletions(-)
15
16diff --git a/lbu.in b/lbu.in
17index 67ad578..3fa157e 100644
18--- a/lbu.in
19+++ b/lbu.in
20@@ -281,10 +281,6 @@ _gen_filelist() {
21 apk audit --backup --quiet --recursive
22 }
23
24-_gen_filelist_0() {
25- _gen_filelist | tr '\n' '\0'
26-}
27-
28 cmd_package() {
29 local pkg="$1"
30 local rc=0
31@@ -311,7 +307,7 @@ cmd_package() {
32
33 tmppkg="$tmpdir/$(basename $pkg)"
34
35- local tar_create="tar -c --no-recursion"
36+ local tar_create="tar -c --no-recursion -T -"
37
38 cd "${ROOT:-/}"
39 # remove old package.list
40@@ -325,19 +321,17 @@ cmd_package() {
41 echo "Archiving the following files:" >&2
42 # we dont want to mess the tar output with the
43 # password prompt. Lets get the tar output first.
44- _gen_filelist_0 | xargs -0 $tar_create -v > /dev/null
45+ _gen_filelist | $tar_create -v > /dev/null
46 rc=$?
47 fi
48 if [ $rc -eq 0 ]; then
49 if [ -z "$ENCRYPTION" ]; then
50- _gen_filelist_0 | xargs -0 $tar_create \
51- | gzip -c >"$tmppkg"
52+ _gen_filelist | $tar_create -z >"$tmppkg"
53 rc=$?
54 else
55 set -- enc "-$ENCRYPTION" -salt
56 [ -n "$PASSWORD" ] && set -- "$@" -pass pass:"$PASSWORD"
57- _gen_filelist_0 | xargs -0 $tar_create \
58- | gzip -c \
59+ _gen_filelist | $tar_create -z \
60 | $OPENSSL "$@" > "$tmppkg"
61 rc=$?
62 fi
63--
641.7.11.1
65
diff --git a/main/alpine-conf/0001-setup-xen-dom0-update-to-upcoming-4.2.patch b/main/alpine-conf/0001-setup-xen-dom0-update-to-upcoming-4.2.patch
deleted file mode 100644
index 55a33f2c25..0000000000
--- a/main/alpine-conf/0001-setup-xen-dom0-update-to-upcoming-4.2.patch
+++ /dev/null
@@ -1,53 +0,0 @@
1From b007e51d7d776d7f31e7e300b7af5f56cfac18c4 Mon Sep 17 00:00:00 2001
2From: Roger Pau Monne <roger.pau@citrix.com>
3Date: Thu, 13 Sep 2012 15:18:59 +0100
4Subject: [PATCH] setup-xen-dom0: update to upcoming 4.2
5
6New version of Xen (4.2) doesn't require udev, so update the
7script to reflect those changes. Also, only include a module
8in /etc/modules if we can load it successfully.
9---
10 setup-xen-dom0.in | 20 +++++++-------------
11 1 file changed, 7 insertions(+), 13 deletions(-)
12
13diff --git a/setup-xen-dom0.in b/setup-xen-dom0.in
14index a9c993a..0e7b3b3 100644
15--- a/setup-xen-dom0.in
16+++ b/setup-xen-dom0.in
17@@ -3,26 +3,20 @@
18 # simple script to setup basic xen dom0
19
20 # kernel modules
21-for mod in xen_netback xen_blkback xenfs xen-platform-pci xen_wdt tun; do
22- modprobe $mod
23- grep -q -w $mod /etc/modules || echo $mod >> /etc/modules
24+for mod in xen_netback xen_blkback xenfs xen_pciback xen_wdt tun; do
25+ if modprobe $mod; then
26+ grep -q -w $mod /etc/modules || echo $mod >> /etc/modules
27+ fi
28 done
29
30 # install packages
31-apk add -q xen udev
32+apk add -q xen
33
34 # setup and start services
35-rc-update -q del mdev sysinit
36-rc-update -q add udev sysinit
37-for svc in udev-postmount xenstored xenconsoled; do
38+for svc in xenstored xenconsoled xenqemu; do
39 rc-update -q add $svc default
40 done
41
42-if ! rc-service -q udev status; then
43- rc-service udev start
44- rc-service udev-postmount start
45-fi
46-
47 rc-service xenstored start
48 rc-service xenconsoled start
49-
50+rc-service xenqemu start
51--
521.7.12
53
diff --git a/main/alpine-conf/APKBUILD b/main/alpine-conf/APKBUILD
index 3dbe0061ed..f0a4df7ca5 100644
--- a/main/alpine-conf/APKBUILD
+++ b/main/alpine-conf/APKBUILD
@@ -1,14 +1,11 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=alpine-conf 2pkgname=alpine-conf
3pkgver=2.11.2 3pkgver=2.12.0
4pkgrel=3 4pkgrel=0
5pkgdesc="Alpine configuration management scripts" 5pkgdesc="Alpine configuration management scripts"
6url=http://git.alpinelinux.org/cgit/$pkgname 6url=http://git.alpinelinux.org/cgit/$pkgname
7depends="openrc" 7depends="openrc"
8source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2 8source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
9 0001-lbu-do-not-use-xargs.patch
10 0001-lbu-check-permissions-when-generating-apkovl.patch
11 0001-setup-xen-dom0-update-to-upcoming-4.2.patch
12 " 9 "
13 10
14arch="all" 11arch="all"
@@ -39,7 +36,4 @@ package() {
39 ln -s lbu "$pkgdir"/sbin/lbu_$i 36 ln -s lbu "$pkgdir"/sbin/lbu_$i
40 done 37 done
41} 38}
42md5sums="47e37f6211817acc12aa637798da0437 alpine-conf-2.11.2.tar.bz2 39md5sums="4038a3be9a785ead649d913e208e2bd8 alpine-conf-2.12.0.tar.bz2"
43a49569f9eb9bfa630efaca4988bde07c 0001-lbu-do-not-use-xargs.patch
4497db0e60d1fd534a613e3d6cbca23a14 0001-lbu-check-permissions-when-generating-apkovl.patch
45f2f36e9b99c6102c0acc9978d049be2d 0001-setup-xen-dom0-update-to-upcoming-4.2.patch"