aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-05-29 14:45:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-05-29 14:52:45 +0000
commit92d7e22319f0abda71cc238aaf88b533bae1b57f (patch)
tree7cc164f31cc19b9986a8b38a8a59b7e72bfd7e63
parent4e4e4710c181fe08b879815ec8129cc402560ded (diff)
downloadalpine_aports-92d7e22319f0abda71cc238aaf88b533bae1b57f.tar.bz2
alpine_aports-92d7e22319f0abda71cc238aaf88b533bae1b57f.tar.xz
alpine_aports-92d7e22319f0abda71cc238aaf88b533bae1b57f.zip
main/abuild: upgrade to 2.14.3
(cherry picked from commit 453635e2122d4c367db3da152a6a752a496fb3f6)
-rw-r--r--main/abuild/0001-buildrepo-avoid-using-i-as-loop-variable.patch52
-rw-r--r--main/abuild/APKBUILD17
2 files changed, 6 insertions, 63 deletions
diff --git a/main/abuild/0001-buildrepo-avoid-using-i-as-loop-variable.patch b/main/abuild/0001-buildrepo-avoid-using-i-as-loop-variable.patch
deleted file mode 100644
index 0fe58e6110..0000000000
--- a/main/abuild/0001-buildrepo-avoid-using-i-as-loop-variable.patch
+++ /dev/null
@@ -1,52 +0,0 @@
1From 67e769e605a09338b1234b2a9503305ebd632832 Mon Sep 17 00:00:00 2001
2From: Natanael Copa <ncopa@alpinelinux.org>
3Date: Fri, 26 Apr 2013 21:05:40 +0200
4Subject: [PATCH] buildrepo: avoid using 'i' as loop variable
5
6some apkbuilds use it in global context
7---
8 buildrepo.in | 12 ++++++------
9 1 file changed, 6 insertions(+), 6 deletions(-)
10
11diff --git a/buildrepo.in b/buildrepo.in
12index 7707049..a37ab8d 100755
13--- a/buildrepo.in
14+++ b/buildrepo.in
15@@ -20,7 +20,7 @@ fi
16 usage() {
17 echo "usage: $program [-a APORTSDIR] [-d REPODIR] [-hp] [-l LOGPREFIX ]"
18 echo " [-r DEPREPO] REPOSITORY..."
19-
20+
21 echo "options:"
22 echo " -a Set the aports base dir to APORTSDIR instead of $aportsdir"
23 echo " -d Set destination repository base dir to REPODIR instead of $repodir"
24@@ -87,10 +87,10 @@ list_needbuild() {
25 # first we try copy everything possible and find out which we need
26 # to rebuild. By doing this we might save us for rebuilding
27 # needed when running 'abuild -R'
28- for i in */APKBUILD; do
29- [ -f "$aportsdir/$repo/$i" ] || continue
30+ for apkbuild in */APKBUILD; do
31+ [ -f "$aportsdir/$repo/$apkbuild" ] || continue
32 export REPODEST="$repodir"
33- cd "$aportsdir/$repo"/${i%/*} || return 1
34+ cd "$aportsdir/$repo"/${apkbuild%/*} || return 1
35 pkgname=
36 pkgver=
37 pkgrel=
38@@ -118,9 +118,9 @@ list_needbuild() {
39 echo ">>> Copying " $pkgs >&2
40 cp -p -l $pkgs "$repodir/$repo/$CARCH"/ 2>/dev/null \
41 || cp -p $pkgs "$repodir/$repo/$CARCH"/ \
42- || echo "$i"
43+ || echo "$apkbuild"
44 else
45- echo "$i"
46+ echo "$apkbuild"
47 fi
48 done
49 }
50--
511.8.2.1
52
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index b66acea749..afbdeb86c4 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -1,9 +1,9 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgdesc="Script to build Alpine Packages" 2pkgdesc="Script to build Alpine Packages"
3pkgname=abuild 3pkgname=abuild
4pkgver=2.14.2 4pkgver=2.14.3
5_ver=${pkgver%_git*} 5_ver=${pkgver%_git*}
6pkgrel=1 6pkgrel=0
7url=http://git.alpinelinux.org/cgit/abuild/ 7url=http://git.alpinelinux.org/cgit/abuild/
8depends="fakeroot file sudo pax-utils openssl apk-tools>=2.0.7-r1 8depends="fakeroot file sudo pax-utils openssl apk-tools>=2.0.7-r1
9 abuildhelper curl libc-utils" 9 abuildhelper curl libc-utils"
@@ -13,9 +13,7 @@ subpackages="apkbuild-cpan:cpan"
13pkggroups="abuild" 13pkggroups="abuild"
14arch="all" 14arch="all"
15license=GPL-2 15license=GPL-2
16source="http://git.alpinelinux.org/cgit/abuild/snapshot/abuild-$_ver.tar.bz2 16source="http://dev.alpinelinux.org/archive/abuild/abuild-$pkgver.tar.xz"
17 0001-buildrepo-avoid-using-i-as-loop-variable.patch
18 "
19 17
20_builddir="$srcdir/$pkgname-$_ver" 18_builddir="$srcdir/$pkgname-$_ver"
21prepare() { 19prepare() {
@@ -52,9 +50,6 @@ cpan() {
52 mv "$pkgdir"/usr/bin/apkbuild-cpan "$subpkgdir"/usr/bin/ 50 mv "$pkgdir"/usr/bin/apkbuild-cpan "$subpkgdir"/usr/bin/
53} 51}
54 52
55md5sums="28b88233f7cece810ed9008647f1b0a2 abuild-2.14.2.tar.bz2 53md5sums="38e58e3c22598913d18e25d532f43316 abuild-2.14.3.tar.xz"
56b159d73dfddf2994e7469d749a94ff2a 0001-buildrepo-avoid-using-i-as-loop-variable.patch" 54sha256sums="581f71bbf1d3de0e016dcbf130ce36061fa15ef890f5ebddb6c9c4b8aa3ba3a5 abuild-2.14.3.tar.xz"
57sha256sums="37192e3dbe148620341925059f57188b0f3635a60c74e5614fb7914741cb7d89 abuild-2.14.2.tar.bz2 55sha512sums="298cf587b18779d733650df442c91fd0b851c54c00f2ffcb6236eda844dde00310e2da1d4a673ac969b3bcf35387e91fd619ce608c4123067477fa9636699034 abuild-2.14.3.tar.xz"
58276746a44b52cd46cef295dbd993716ddabc9da46e4e2db5e813ee0e900577c8 0001-buildrepo-avoid-using-i-as-loop-variable.patch"
59sha512sums="8f9cea29f8d1c8472ef7c4771789b995ce5422ee87f8262aa60c118b7a198b7c7b17c9120e3de98e410f14427fbac020920076a9b387943e638af10859db1648 abuild-2.14.2.tar.bz2
609b2894e2d5050c532bfb1e4c2ff22f0edd8cf4d4a27c4dd7d60e1269c4ec130d70bd9a04a4f84c697a44d140d98c2ed543e0d99899a26e673a3fd4b642de572b 0001-buildrepo-avoid-using-i-as-loop-variable.patch"