aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-08-12 14:50:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-08-28 11:57:21 +0000
commit72e8e8a38a569b2bcf30bac906fddde43b66d997 (patch)
tree2ee63f0de4d8fefa0aea942c5f713a533a3fea89
parent2acfc84cf952a50fad4c3d533a2047c5c3fb40d9 (diff)
downloadalpine_aports-72e8e8a38a569b2bcf30bac906fddde43b66d997.tar.bz2
alpine_aports-72e8e8a38a569b2bcf30bac906fddde43b66d997.tar.xz
alpine_aports-72e8e8a38a569b2bcf30bac906fddde43b66d997.zip
main/bonding: set link status to down
in case bonded interface is 'manual' fixes #2219
-rw-r--r--main/bonding/APKBUILD10
-rwxr-xr-xmain/bonding/bonding.post-down5
2 files changed, 12 insertions, 3 deletions
diff --git a/main/bonding/APKBUILD b/main/bonding/APKBUILD
index 4cdb755f25..236240408e 100644
--- a/main/bonding/APKBUILD
+++ b/main/bonding/APKBUILD
@@ -5,7 +5,7 @@
5 5
6pkgname=bonding 6pkgname=bonding
7pkgver=2.6 7pkgver=2.6
8pkgrel=2 8pkgrel=3
9pkgdesc="Scripts for network interface bonding" 9pkgdesc="Scripts for network interface bonding"
10url="http://wiki.alpinelinux.org/wiki/Bonding" 10url="http://wiki.alpinelinux.org/wiki/Bonding"
11arch="noarch" 11arch="noarch"
@@ -40,4 +40,10 @@ package() {
40 40
41md5sums="e5b1ba826edd950bcf7bedf8cd550e9e bonding.pre-up 41md5sums="e5b1ba826edd950bcf7bedf8cd550e9e bonding.pre-up
4268e64f483be3f8730a4c522f1e63e92d bonding.up 4268e64f483be3f8730a4c522f1e63e92d bonding.up
43c5f6d07415118aa21d8e4730f9f18cab bonding.post-down" 43f94e3a116adf466f6b801a320bdc53ca bonding.post-down"
44sha256sums="d8613d3ca76bc69545487fd9d50eb3f6b6c2e81e22c170236531d8e3f04d9eb9 bonding.pre-up
45237a571c9a1e36d9871764ea3415d7ab0d6718718a22549a0a4b14576ed21b6f bonding.up
46d24e1061ffd123d10cd9d19b00a70a46e54b7f98ee56cc1eb4b04c1fc2d72b8e bonding.post-down"
47sha512sums="88d0566242b172c60b66bd62ce1b5c9f01e5d3b79a2caa7eea8f2ec0255158f449392a54348dd5c375d14f4d8fa6182333c2154582c7eab7f3e8f4a7adce900a bonding.pre-up
485c81b2891c281df2df4c98a560f776b857e4b6b20ac733858683d87fb7b1ac57423f57003cfdcfac24c8257de31062c4596270e9482b8d35d517e29f2bac0951 bonding.up
49c6b6f06d1c0a7be1022feb18cdcc55780cad2200ac0121f276527442becb7d75a7850b809ae9c6d5b914a1a03f791bd65c088f1289ce0e28b5a02bd86e3868de bonding.post-down"
diff --git a/main/bonding/bonding.post-down b/main/bonding/bonding.post-down
index 8dd4c07e93..5b62d8b923 100755
--- a/main/bonding/bonding.post-down
+++ b/main/bonding/bonding.post-down
@@ -19,7 +19,7 @@ sysfs_remove_all()
19 # Called with: 19 # Called with:
20 # $1 = target filename 20 # $1 = target filename
21 read values < "/sys/class/net/$IFACE/bonding/$1" 21 read values < "/sys/class/net/$IFACE/bonding/$1"
22 for value in $values ; do 22 for value in $values ; do
23 echo "-$value" > "/sys/class/net/$IFACE/bonding/$1" 23 echo "-$value" > "/sys/class/net/$IFACE/bonding/$1"
24 done 24 done
25} 25}
@@ -62,3 +62,6 @@ for slave in $slaves ; do
62 echo "-$slave" > "$BOND_PARAMS/slaves" 2> /dev/null 62 echo "-$slave" > "$BOND_PARAMS/slaves" 2> /dev/null
63 fi 63 fi
64done 64done
65
66# make sure that the link is set to down
67ip link set dev $IFACE down