aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-08-28 08:54:31 +0300
committerTimo Teräs <timo.teras@iki.fi>2013-08-28 08:54:31 +0300
commitc2912a2ede76ed4150051cd9ab560c57bfc37df7 (patch)
tree1a8980cc5b50636586eaaf7b20a3c53e9a7dc33e
parentd7900c5a9ee1bc30d64b5c1e0d4ee2ed97c9d2cb (diff)
downloadalpine_aports-c2912a2ede76ed4150051cd9ab560c57bfc37df7.tar.bz2
alpine_aports-c2912a2ede76ed4150051cd9ab560c57bfc37df7.tar.xz
alpine_aports-c2912a2ede76ed4150051cd9ab560c57bfc37df7.zip
main/asterisk: security upgrade to 11.5.1
AST-2013-004: Remote Crash From Late Arriving SIP ACK With SDP AST-2013-005: Remote Crash when Invalid SDP is sent in SIP Request also cherry-pick all packaging fixes from master
-rw-r--r--main/asterisk/APKBUILD56
1 files changed, 43 insertions, 13 deletions
diff --git a/main/asterisk/APKBUILD b/main/asterisk/APKBUILD
index f1a41e948d..46cce3b923 100644
--- a/main/asterisk/APKBUILD
+++ b/main/asterisk/APKBUILD
@@ -1,7 +1,7 @@
1# Contributor: Timo Teras <timo.teras@iki.fi> 1# Contributor: Timo Teras <timo.teras@iki.fi>
2# Maintainer: Timo Teras <timo.teras@iki.fi> 2# Maintainer: Timo Teras <timo.teras@iki.fi>
3pkgname=asterisk 3pkgname=asterisk
4pkgver=11.4.0 4pkgver=11.5.1
5pkgrel=0 5pkgrel=0
6pkgdesc="Asterisk: A Module Open Source PBX System" 6pkgdesc="Asterisk: A Module Open Source PBX System"
7pkgusers="asterisk" 7pkgusers="asterisk"
@@ -13,12 +13,14 @@ depends=
13makedepends="autoconf automake libtool ncurses-dev popt-dev newt-dev zlib-dev 13makedepends="autoconf automake libtool ncurses-dev popt-dev newt-dev zlib-dev
14 postgresql-dev unixodbc-dev dahdi-tools-dev libpri-dev tar 14 postgresql-dev unixodbc-dev dahdi-tools-dev libpri-dev tar
15 freetds-dev openssl-dev lua-dev alsa-lib-dev spandsp-dev tiff-dev 15 freetds-dev openssl-dev lua-dev alsa-lib-dev spandsp-dev tiff-dev
16 libresample sqlite-dev wget speex-dev libogg-dev bluez-dev" 16 libresample sqlite-dev wget speex-dev libogg-dev bluez-dev curl-dev
17 libedit-dev libsrtp-dev util-linux-dev"
17install="$pkgname.pre-install $pkgname.pre-upgrade" 18install="$pkgname.pre-install $pkgname.pre-upgrade"
18subpackages="$pkgname-dev $pkgname-doc $pkgname-pgsql $pkgname-odbc 19subpackages="$pkgname-dev $pkgname-doc $pkgname-pgsql $pkgname-odbc
19 $pkgname-tds $pkgname-fax $pkgname-sample-config:sample 20 $pkgname-tds $pkgname-fax $pkgname-sample-config:sample
20 $pkgname-sounds-moh:sound_moh $pkgname-sounds-en:sound_en 21 $pkgname-sounds-moh:sound_moh $pkgname-sounds-en:sound_en
21 $pkgname-mobile" 22 $pkgname-mobile $pkgname-curl:_curl $pkgname-srtp $pkgname-dahdi
23 $pkgname-speex $pkgname-alsa"
22 24
23_download="http://downloads.asterisk.org/pub/telephony/asterisk/releases" 25_download="http://downloads.asterisk.org/pub/telephony/asterisk/releases"
24_z=${pkgver##*.} 26_z=${pkgver##*.}
@@ -65,16 +67,27 @@ prepare() {
65 67
66build() { 68build() {
67 cd "$_builddir" 69 cd "$_builddir"
68 SHA1SUM="$PWD"/build_tools/sha1sum-sh ./configure --prefix=/usr \ 70 SHA1SUM="$PWD"/build_tools/sha1sum-sh ./configure \
71 --build=$CBUILD \
72 --host=$CHOST \
73 --prefix=/usr \
69 --sysconfdir=/etc \ 74 --sysconfdir=/etc \
70 --mandir=/usr/share/man \ 75 --mandir=/usr/share/man \
71 --infodir=/usr/share/info \ 76 --infodir=/usr/share/info \
72 --libdir=/usr/lib \ 77 --libdir=/usr/lib \
73 --localstatedir=/var \ 78 --localstatedir=/var \
74 --disable-xmldoc --with-gsm=internal \ 79 --disable-xmldoc \
75 --without-iconv --with-popt --with-z --with-newt \ 80 --with-gsm=internal \
76 --with-unixodbc --with-postgres --with-tds \ 81 --without-iconv \
77 --with-dahdi --with-pri --with-tonezone \ 82 --with-popt \
83 --with-z \
84 --with-newt \
85 --with-unixodbc \
86 --with-postgres \
87 --with-tds \
88 --with-dahdi \
89 --with-pri \
90 --with-tonezone \
78 --with-resample \ 91 --with-resample \
79 --with-sqlite3 \ 92 --with-sqlite3 \
80 --with-speex \ 93 --with-speex \
@@ -82,6 +95,9 @@ build() {
82 --without-x11 \ 95 --without-x11 \
83 --with-spandsp \ 96 --with-spandsp \
84 --with-bluetooth \ 97 --with-bluetooth \
98 --with-libcurl \
99 --with-libedit \
100 --with-srtp \
85 || return 1 101 || return 1
86 102
87 # and figure out which modules to build 103 # and figure out which modules to build
@@ -89,12 +105,12 @@ build() {
89 make menuselect.makeopts 105 make menuselect.makeopts
90 # enable chan_mobile 106 # enable chan_mobile
91 sed -i -e '/^MENUSELECT_ADDONS=/s/chan_mobile//' menuselect.makeopts 107 sed -i -e '/^MENUSELECT_ADDONS=/s/chan_mobile//' menuselect.makeopts
92 make ASTCFLAGS="$CFLAGS" ASTLDFLAGS="$LDFLAGS" || return 1 108 make ASTCFLAGS="$CFLAGS" ASTLDFLAGS="$LDFLAGS" LDCONFIG_FLAGS="-n" || return 1
93} 109}
94 110
95package() { 111package() {
96 cd "$_builddir" 112 cd "$_builddir"
97 make -j1 DESTDIR="$pkgdir" install 113 make -j1 DESTDIR="$pkgdir" LDCONFIG_FLAGS="-n" install
98 114
99 install -d "$pkgdir"/var/run/asterisk 115 install -d "$pkgdir"/var/run/asterisk
100 install -d "$pkgdir"/var/lib/asterisk 116 install -d "$pkgdir"/var/lib/asterisk
@@ -168,6 +184,17 @@ mobile() {
168 _find_and_move '*_mobile*' 184 _find_and_move '*_mobile*'
169} 185}
170 186
187_curl() {
188 depends=
189 install=
190 _find_and_move '*_curl*'
191}
192
193srtp() { _find_and_move '*_srtp*'; }
194dahdi() { _find_and_move '*_dahdi*'; }
195speex() { _find_and_move '*_speex*'; }
196alsa() { _find_and_move '*_alsa*'; }
197
171sample() { 198sample() {
172 arch="noarch" 199 arch="noarch"
173 pkgdesc="Sample configuration files for asterisk" 200 pkgdesc="Sample configuration files for asterisk"
@@ -198,7 +225,8 @@ sound_en() {
198 chown -R asterisk:asterisk "$subpkgdir"/var/*/asterisk 225 chown -R asterisk:asterisk "$subpkgdir"/var/*/asterisk
199} 226}
200 227
201md5sums="f2654567261f194f537bd2fbb97c9117 asterisk-11.4.0.tar.gz 228md5sums="34ca88eeb50580823ec6e38d4c0ad0dc asterisk-11.5.0.tar.gz
22958a724b620c5a9d9e92029e229b189e6 asterisk-11.5.1-patch.gz
202837fc3bc835699462a8d2a7a16b9b6a3 100-uclibc-daemon.patch 230837fc3bc835699462a8d2a7a16b9b6a3 100-uclibc-daemon.patch
2036e1129e30c4fd2c25c86c81685a485a9 101-caps-uclibc.patch 2316e1129e30c4fd2c25c86c81685a485a9 101-caps-uclibc.patch
204bc6713f5434e07b79d3afdd155461d72 ASTERISK-18995.patch 232bc6713f5434e07b79d3afdd155461d72 ASTERISK-18995.patch
@@ -207,7 +235,8 @@ bc6713f5434e07b79d3afdd155461d72 ASTERISK-18995.patch
20774cd25a5638a94ef51e9f4ede2fd28f2 asterisk.initd 23574cd25a5638a94ef51e9f4ede2fd28f2 asterisk.initd
208ed31d7ba37bcf8b0346dcf8593c395f0 asterisk.confd 236ed31d7ba37bcf8b0346dcf8593c395f0 asterisk.confd
2093e65172275684373e1a25c8a11224411 asterisk.logrotate" 2373e65172275684373e1a25c8a11224411 asterisk.logrotate"
210sha256sums="081ba8de5f349ff23de8e000d8cda38a2ca34858174e9379b2662a732557e9d4 asterisk-11.4.0.tar.gz 238sha256sums="a82c1ddd9fb1d98f0dab6e0255a127fb7c7eaa687b3d515182458244062b4194 asterisk-11.5.0.tar.gz
239e742cc28cd160ba2bf8af6733ff0940316b0dc8e2b1163edbd404d8178522579 asterisk-11.5.1-patch.gz
2116f56ea997513c10fa39835e8dd11fbfb4ec0bb23f4b771963e56691b15a5c003 100-uclibc-daemon.patch 2406f56ea997513c10fa39835e8dd11fbfb4ec0bb23f4b771963e56691b15a5c003 100-uclibc-daemon.patch
212c2ef786e9a8082fe8ba7b4eb2f130925cb823d100ec567909ad465c279e335bf 101-caps-uclibc.patch 241c2ef786e9a8082fe8ba7b4eb2f130925cb823d100ec567909ad465c279e335bf 101-caps-uclibc.patch
2137a7140156ae7fc7e833035db1e428db8d90159579cd2678c4b5cc829ded47485 ASTERISK-18995.patch 2427a7140156ae7fc7e833035db1e428db8d90159579cd2678c4b5cc829ded47485 ASTERISK-18995.patch
@@ -216,7 +245,8 @@ d657634d4c96f42ac1a8b7103104185e8cd9d5a59e5214cc1658e01805975ce8 ASTERISK-19109
21613bcc98f2a78d4dd41e810232979eb83044e9166302bfb5b971315f2a82af36f asterisk.initd 24513bcc98f2a78d4dd41e810232979eb83044e9166302bfb5b971315f2a82af36f asterisk.initd
217d221148583b57f9c37d7160f2493f0d204ad11f7abb17e3a3534e108ad5452d7 asterisk.confd 246d221148583b57f9c37d7160f2493f0d204ad11f7abb17e3a3534e108ad5452d7 asterisk.confd
21877b253b6db71460acf9a51e87ad4c8582027a46db01a4c50fb048bada58c19d1 asterisk.logrotate" 24777b253b6db71460acf9a51e87ad4c8582027a46db01a4c50fb048bada58c19d1 asterisk.logrotate"
219sha512sums="482ad6a252d8b660b01b5eb5d9cdff86289a8eb8bdc7f69f150441a612b6e0a3652ad237bfbbecc38602fa9b888d7dc8aa9011b23fbeb442ff93d3129eea773b asterisk-11.4.0.tar.gz 248sha512sums="595d6c2ecbbc9a057ff601c4337fff276eae089d58d97036f9a676686dfe3b2cbaf8739f2f788416bb947a97465100cbf261030c3d17175025eec25761f0cd58 asterisk-11.5.0.tar.gz
249b9a3dedc0d8b93ae252539e94249d3dcb011d2f8562fc7eef12004def396b6b0de7a19dc77574e26cf2231e38d4758242b27d0ea4efe5c4a14de7d35610f4659 asterisk-11.5.1-patch.gz
22024a0d3c0ae86117ead8d2e35fc9a5945e04b9f80f3baf122337c8361c015e5ad904c206579962aefe3eb35a1fbf269515228ae5f34a801d7725d73dc235cf831 100-uclibc-daemon.patch 25024a0d3c0ae86117ead8d2e35fc9a5945e04b9f80f3baf122337c8361c015e5ad904c206579962aefe3eb35a1fbf269515228ae5f34a801d7725d73dc235cf831 100-uclibc-daemon.patch
221601681b9a33e77b33a0393a494c4140aa6c1f174c514093242a4081661bb7f78b6af867100996c97f3bf12e8dd10873dd3e116b61e2a0e04832f4ee470664368 101-caps-uclibc.patch 251601681b9a33e77b33a0393a494c4140aa6c1f174c514093242a4081661bb7f78b6af867100996c97f3bf12e8dd10873dd3e116b61e2a0e04832f4ee470664368 101-caps-uclibc.patch
22242b2385d88e72473fe34c63e1be8cdf7f37688649fe5bf033b5ba17627008b771aec8f0a583e9ad483a20f9e1f7c33922cb42bf5b73adc68aa43fd46c5da1daa ASTERISK-18995.patch 25242b2385d88e72473fe34c63e1be8cdf7f37688649fe5bf033b5ba17627008b771aec8f0a583e9ad483a20f9e1f7c33922cb42bf5b73adc68aa43fd46c5da1daa ASTERISK-18995.patch