aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2013-10-01 14:51:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-02 05:57:13 +0000
commit429ad3fe6ec3e064b8c84d7705376a9afff60ac5 (patch)
treef35dbba5bdf43b48e982f21618e5e1ff13590d0a
parent1d2193550c35bcefbd957b165390fc9e75d5a1ab (diff)
downloadalpine_aports-429ad3fe6ec3e064b8c84d7705376a9afff60ac5.tar.bz2
alpine_aports-429ad3fe6ec3e064b8c84d7705376a9afff60ac5.tar.xz
alpine_aports-429ad3fe6ec3e064b8c84d7705376a9afff60ac5.zip
main/ruby-redmine-unicorn: new aport
-rw-r--r--main/ruby-redmine-unicorn/APKBUILD56
-rw-r--r--main/ruby-redmine-unicorn/redmine.conf.rb.sample103
-rw-r--r--main/ruby-redmine-unicorn/unicorn.confd4
-rw-r--r--main/ruby-redmine-unicorn/unicorn.initd44
4 files changed, 207 insertions, 0 deletions
diff --git a/main/ruby-redmine-unicorn/APKBUILD b/main/ruby-redmine-unicorn/APKBUILD
new file mode 100644
index 0000000000..54f1c6914c
--- /dev/null
+++ b/main/ruby-redmine-unicorn/APKBUILD
@@ -0,0 +1,56 @@
1# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
2_gemname=unicorn
3pkgname=ruby-redmine-$_gemname
4pkgver=4.6.3
5pkgrel=0
6pkgdesc="Unicorn is an HTTP server for Rack applications"
7url="http://unicorn.bogomips.org"
8arch="all"
9license="MIT"
10depends="ruby ruby-kgio ruby-redmine-rack ruby-raindrops"
11depends_dev="ruby-dev"
12makedepends="$depends_dev ruby"
13install=""
14subpackages=""
15source="http://gems.rubyforge.org/gems/$_gemname-$pkgver.gem
16 redmine.conf.rb.sample
17 unicorn.initd
18 unicorn.confd"
19
20_builddir="$srcdir"/$_realname-$pkgver
21build() {
22 return 0
23}
24
25package() {
26 local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
27 local _geminstdir=$_gemdir/gems/$_gemname-$pkgver
28 mkdir -p "$pkgdir" || return 1
29
30 gem install --local --install-dir "$pkgdir"/$_gemdir \
31 --ignore-dependencies --verbose --no-rdoc --no-ri \
32 "$srcdir"/$_gemname-$pkgver.gem || return 1
33 rm -rf "$pkgdir"/$_gemdir/cache \
34 "$pkgdir"/$_geminstdir/ext \
35 "$pkgdir"/$_geminstdir/.require_paths
36 install -Dm644 "$srcdir"/$_gemname.confd \
37 "$pkgdir"/etc/conf.d/$_gemname
38 install -D -m755 "$srcdir"/$_gemname.initd \
39 "$pkgdir"/etc/init.d/$_gemname
40 # install sample redmine config
41 install -D -m644 "$srcdir"/redmine.conf.rb.sample \
42 "$pkgdir"/etc/unicorn/redmine.conf.rb.sample
43}
44
45md5sums="2e627fe7977eb48b02a2b580ff67583c unicorn-4.6.3.gem
46416e6d6c3e5f9f191d1e8c3975b0d4f5 redmine.conf.rb.sample
473b788ff54077428658e7044fb54c8364 unicorn.initd
480745d4e1605ff961c83773613c68347d unicorn.confd"
49sha256sums="fd0b12148a24acfd8bf28a0322e4116061e64e271253e077999e4ec531a74966 unicorn-4.6.3.gem
5087a565f79a3f4b0544880af67c66e28fa0afdca9576191e725853da1159ec1f1 redmine.conf.rb.sample
516fc8d9b2dfbb1cf7113b6e7fb49991a675e20705410a47ceb7a95af2ae557f29 unicorn.initd
528b6c5aff19eb8234192f8df79f5c8c7a2325f8f26a90af97271bf126269dc93c unicorn.confd"
53sha512sums="a3a2a45751a4226d97cb3948587de89fa30fedae6000b6d272171495919432b8298614ca97ff176df136304e19e7e3eba903d5554a0211fa520ad8123f137611 unicorn-4.6.3.gem
5411abdc40c406e88c71feeb1bd6282534552f782398b694907e6afb266361e30091f4e9645e3ae9cc14bae68a4909cb087bbf0f6c13c3e26b41518565e942492d redmine.conf.rb.sample
55b7d510fa9043d4023e8ad3590b4e019aaf8f072aaa39205736d5205defffd4d7e3b714e3e41180cd5ac36cef59795b73755edaf151eb5f886f910915f8a5c668 unicorn.initd
5640931b0f41f8f19ed2bfee726c6abdf40e9ca03940ca6fa4db0c468b59409b99506dbad47316dec528ae7173b6bd3856ba80be1f45fa3995ed18efefed1c4ce1 unicorn.confd"
diff --git a/main/ruby-redmine-unicorn/redmine.conf.rb.sample b/main/ruby-redmine-unicorn/redmine.conf.rb.sample
new file mode 100644
index 0000000000..6b47bd1356
--- /dev/null
+++ b/main/ruby-redmine-unicorn/redmine.conf.rb.sample
@@ -0,0 +1,103 @@
1# Sample verbose configuration file for Unicorn (not Rack)
2#
3# This configuration file documents many features of Unicorn
4# that may not be needed for some applications. See
5# http://unicorn.bogomips.org/examples/unicorn.conf.minimal.rb
6# for a much simpler configuration file.
7#
8# See http://unicorn.bogomips.org/Unicorn/Configurator.html for complete
9# documentation.
10
11# Use at least one worker per core if you're on a dedicated server,
12# more will usually help for _short_ waits on databases/caches.
13worker_processes 2
14
15# Since Unicorn is never exposed to outside clients, it does not need to
16# run on the standard HTTP port (80), there is no reason to start Unicorn
17# as root unless it's from system init scripts.
18# If running the master process as root and the workers as an unprivileged
19# user, do this to switch euid/egid in the workers (also chowns logs):
20# user "unprivileged_user", "unprivileged_group"
21user "redmine", "redmine"
22
23# Help ensure your application will always spawn in the symlinked
24# "current" directory that Capistrano sets up.
25working_directory "/usr/share/webapps/redmine" # available in 0.94.0+
26
27# listen on both a Unix domain socket and a TCP port,
28# we use a shorter backlog for quicker failover when busy
29listen "/var/run/unicorn.sock", :backlog => 64
30listen 8080, :tcp_nopush => true
31
32# nuke workers after 30 seconds instead of 60 seconds (the default)
33#timeout 30
34
35# feel free to point this anywhere accessible on the filesystem
36pid "/var/run/unicorn.pid"
37
38# By default, the Unicorn logger will write to stderr.
39# Additionally, ome applications/frameworks log to stderr or stdout,
40# so prevent them from going to /dev/null when daemonized here:
41stderr_path "/var/log/redmine/unicorn.log"
42stdout_path "/var/log/redmine/unicorn.log"
43
44# combine Ruby 2.0.0dev or REE with "preload_app true" for memory savings
45# http://rubyenterpriseedition.com/faq.html#adapt_apps_for_cow
46preload_app true
47GC.respond_to?(:copy_on_write_friendly=) and
48 GC.copy_on_write_friendly = true
49
50# Enable this flag to have unicorn test client connections by writing the
51# beginning of the HTTP headers before calling the application. This
52# prevents calling the application for connections that have disconnected
53# while queued. This is only guaranteed to detect clients on the same
54# host unicorn runs on, and unlikely to detect disconnects even on a
55# fast LAN.
56#check_client_connection false
57
58before_fork do |server, worker|
59 # the following is highly recomended for Rails + "preload_app true"
60 # as there's no need for the master process to hold a connection
61 defined?(ActiveRecord::Base) and
62 ActiveRecord::Base.connection.disconnect!
63
64 # The following is only recommended for memory/DB-constrained
65 # installations. It is not needed if your system can house
66 # twice as many worker_processes as you have configured.
67 #
68 # # This allows a new master process to incrementally
69 # # phase out the old master process with SIGTTOU to avoid a
70 # # thundering herd (especially in the "preload_app false" case)
71 # # when doing a transparent upgrade. The last worker spawned
72 # # will then kill off the old master process with a SIGQUIT.
73 # old_pid = "#{server.config[:pid]}.oldbin"
74 # if old_pid != server.pid
75 # begin
76 # sig = (worker.nr + 1) >= server.worker_processes ? :QUIT : :TTOU
77 # Process.kill(sig, File.read(old_pid).to_i)
78 # rescue Errno::ENOENT, Errno::ESRCH
79 # end
80 # end
81 #
82 # Throttle the master from forking too quickly by sleeping. Due
83 # to the implementation of standard Unix signal handlers, this
84 # helps (but does not completely) prevent identical, repeated signals
85 # from being lost when the receiving process is busy.
86 # sleep 1
87end
88
89after_fork do |server, worker|
90 # per-process listener ports for debugging/admin/migrations
91 # addr = "127.0.0.1:#{9293 + worker.nr}"
92 # server.listen(addr, :tries => -1, :delay => 5, :tcp_nopush => true)
93
94 # the following is *required* for Rails + "preload_app true",
95 defined?(ActiveRecord::Base) and
96 ActiveRecord::Base.establish_connection
97
98 # if preload_app is true, then you may also want to check and
99 # restart any other shared sockets/descriptors such as Memcached,
100 # and Redis. TokyoCabinet file handles are safe to reuse
101 # between any number of forked children (assuming your kernel
102 # correctly implements pread()/pwrite() system calls)
103end
diff --git a/main/ruby-redmine-unicorn/unicorn.confd b/main/ruby-redmine-unicorn/unicorn.confd
new file mode 100644
index 0000000000..28e3df1a21
--- /dev/null
+++ b/main/ruby-redmine-unicorn/unicorn.confd
@@ -0,0 +1,4 @@
1# unicorn configuration file
2CONF=""
3# app enviorment. ie developement,production
4ENV="production"
diff --git a/main/ruby-redmine-unicorn/unicorn.initd b/main/ruby-redmine-unicorn/unicorn.initd
new file mode 100644
index 0000000000..228023cd38
--- /dev/null
+++ b/main/ruby-redmine-unicorn/unicorn.initd
@@ -0,0 +1,44 @@
1#!/sbin/runscript
2
3gem_path=$(gem env gemdir)
4name="unicorn_rails"
5start_script="$gem_path/bin/$name"
6
7depend() {
8 use logger dns
9 need net
10 after firewall
11}
12
13start() {
14 checkconfig || return 1
15
16 ebegin "Starting unicorn"
17 start-stop-daemon --start --quiet \
18 $start_script -- \
19 -D -E $ENV -c $CONF
20 eend $?
21}
22
23stop() {
24 ebegin "Stopping unicorn"
25 start-stop-daemon --stop \
26 --name $name
27 eend $?
28 sleep 1
29}
30
31
32reload() {
33 ebegin "Reload unicorn"
34 start-stop-daemon --signal USR2 \
35 --name $name
36 eend $?
37}
38
39checkconfig() {
40 if [ -z "$CONF" ]; then
41 eerror "No configuration file set in confd!"
42 return 1
43 fi
44}