aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-10-16 10:26:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-17 10:51:42 +0000
commite75371b16c21a9311b8a29d146b8d1f730db9e7a (patch)
tree3ff02da9d548684b50ca324a83b1d48c45479291
parent1d852694b81f7bb63e89fddd9785f7beb86d2964 (diff)
downloadalpine_aports-e75371b16c21a9311b8a29d146b8d1f730db9e7a.tar.bz2
alpine_aports-e75371b16c21a9311b8a29d146b8d1f730db9e7a.tar.xz
alpine_aports-e75371b16c21a9311b8a29d146b8d1f730db9e7a.zip
main/openjdk6: upgrade to icedtea 1.11.13
* update pkgver to include java version, build and icedtea version * do not build ecj, instead use the javac from java-gcj-compat * remove jaxws, jaxp and jaf drop zips as they are not used * enable x86_64 build again (apparently using java-gcj-compat fixes things) * minor other clean ups Includes also security fixes from 1.11.12 (2013-07-10) - S6741606, CVE-2013-2407: Integrate Apache Santuario - S7158805, CVE-2013-2445: Better rewriting of nested subroutine calls - S7170730, CVE-2013-2451: Improve Windows network stack support. - S8000638, CVE-2013-2450: Improve deserialization - S8000642, CVE-2013-2446: Better handling of objects for transportation - S8001032: Restrict object access - S8001033, CVE-2013-2452: Refactor network address handling in virtual machine identifiers - S8001034, CVE-2013-1500: Memory management improvements - S8001038, CVE-2013-2444: Resourcefully handle resources - S8001043: Clarify definition restrictions - S8001309: Better handling of annotation interfaces - S8001318, CVE-2013-2447: Socket.getLocalAddress not consistent with InetAddress.getLocalHost - S8001330, CVE-2013-2443: Improve on checking order - S8003703, CVE-2013-2412: Update RMI connection dialog box - S8004584: Augment applet contextualization - S8005007: Better glyph processing - S8006328, CVE-2013-2448: Improve robustness of sound classes - S8006611: Improve scripting - S8007467: Improve robustness of JMX internal APIs - S8007471: Improve MBean notifications - S8007812, CVE-2013-2455: (reflect) Class.getEnclosingMethod problematic for some classes - S8008120, CVE-2013-2457: Improve JMX class checking - S8008124, CVE-2013-2453: Better compliance testing - S8008128: Better API coherence for JMX - S8008132, CVE-2013-2456: Better serialization support - S8008585: Better JMX data handling - S8008593: Better URLClassLoader resource management - S8008603: Improve provision of JMX providers - S8008611: Better handling of annotations in JMX - S8008615: Improve robustness of JMX internal APIs - S8008623: Better handling of MBeanServers - S8008744, CVE-2013-2407: Rework part of fix for JDK-6741606 - S8008982: Adjust JMX for underlying interface changes - S8009004: Better implementation of RMI connections - S8009013: Better handling of T2K glyphs - S8009034: Improve resulting notifications in JMX - S8009038: Improve JMX notification support - S8009067: Improve storing keys in KeyStore - S8009071, CVE-2013-2459: Improve shape handling - S8009235: Improve handling of TSA data - S8011243, CVE-2013-2470: Improve ImagingLib - S8011248, CVE-2013-2471: Better Component Rasters - S8011253, CVE-2013-2472: Better Short Component Rasters - S8011257, CVE-2013-2473: Better Byte Component Rasters - S8012375, CVE-2013-1571: Improve Javadoc framing - S8012421: Better positioning of PairPositioning - S8012438, CVE-2013-2463: Better image validation - S8012597, CVE-2013-2465: Better image channel verification - S8012601, CVE-2013-2469: Better validation of image layouts - S8014281, CVE-2013-2461: Better checking of XML signature - S8015997: Additional improvement in Javadoc framing (cherry picked from commit 1f99ba57e5946f21d43f2d235856af8a174ccc74) Conflicts: main/openjdk6/APKBUILD
-rw-r--r--main/openjdk6/APKBUILD106
1 files changed, 40 insertions, 66 deletions
diff --git a/main/openjdk6/APKBUILD b/main/openjdk6/APKBUILD
index 7e46ec429f..456100e752 100644
--- a/main/openjdk6/APKBUILD
+++ b/main/openjdk6/APKBUILD
@@ -1,9 +1,10 @@
1# Contributor: Timo Teras <timo.teras@iki.fi> 1# Contributor: Timo Teras <timo.teras@iki.fi>
2# Maintainer: Timo Teras <timo.teras@iki.fi> 2# Maintainer: Timo Teras <timo.teras@iki.fi>
3pkgname=openjdk6 3pkgname=openjdk6
4pkgver=1.6.0_p24 4_icedteaver=1.11.13
5icedteaver=1.11.11 5_openjdkbuild=24
6pkgrel=8 6pkgver=6.$_openjdkbuild.$_icedteaver
7pkgrel=0
7pkgdesc="Sun OpenJDK 6 via IcedTea" 8pkgdesc="Sun OpenJDK 6 via IcedTea"
8url="http://icedtea.classpath.org/" 9url="http://icedtea.classpath.org/"
9arch="x86 x86_64" 10arch="x86 x86_64"
@@ -17,36 +18,33 @@ makedepends="java-gcj-compat findutils tar zip paxctl gawk pkgconfig util-linux
17 gtk+2.0-dev ca-certificates libxslt zip" 18 gtk+2.0-dev ca-certificates libxslt zip"
18install="" 19install=""
19 20
21BOOTSTRAP_JAVA_HOME=/usr/lib/jvm/java-1.5-gcj/
22OPENJDK_VERSION=b$_openjdkbuild
23OPENJDK_DATE=14_nov_2011
24RHINO_VER=1_7R3
25ANT_VER=1.8.2
26
20case $CARCH in 27case $CARCH in
21x86) _arch=i386;; 28x86) _jarch=i386;;
22x86_64) _arch=amd64;; 29x86_64) _jarch=amd64;;
30arm) _jarch=arm;;
23esac 31esac
24 32
25_jrelib="/usr/lib/jvm/java-1.6-openjdk/jre/lib/$_arch" 33INSTALL_BASE=/usr/lib/jvm/java-1.6-openjdk
34
26# exclude xawt from ldpath to avoid duplicate provides for libmawt.so (also in 35# exclude xawt from ldpath to avoid duplicate provides for libmawt.so (also in
27# headless). 36# headless).
28# infuture this should be a virtual provides 37# infuture this should be a virtual provides
38_jrelib="$INSTALL_BASE/jre/lib/$_jarch"
29ldpath="$_jrelib:$_jrelib/native_threads:$_jrelib/headless:$_jrelib/server:$_jrelib/jli" 39ldpath="$_jrelib:$_jrelib/native_threads:$_jrelib/headless:$_jrelib/server:$_jrelib/jli"
30
31somask="libjvm.so" 40somask="libjvm.so"
32 41
33subpackages="$pkgname-jre-lib:jrelib $pkgname-jre $pkgname-jre-base:jrebase 42subpackages="$pkgname-jre-lib:jrelib $pkgname-jre $pkgname-jre-base:jrebase
34 $pkgname-doc:doc" 43 $pkgname-doc:doc"
35BOOTSTRAP_JAVA_HOME=/usr/lib/jvm/java-1.5-gcj/
36OPENJDK_VERSION=b24
37OPENJDK_DATE=14_nov_2011
38RHINO_VER=1_7R3
39ANT_VER=1.8.2
40JAXWS_DROP_ZIP=jdk6-jaxws2_1_6-2011_06_13.zip
41JAXP_DROP_ZIP=jaxp144_03.zip
42JAF_DROP_ZIP=jdk6-jaf-b20.zip
43source="http://download.java.net/openjdk/jdk6/promoted/$OPENJDK_VERSION/openjdk-6-src-$OPENJDK_VERSION-$OPENJDK_DATE.tar.gz 44source="http://download.java.net/openjdk/jdk6/promoted/$OPENJDK_VERSION/openjdk-6-src-$OPENJDK_VERSION-$OPENJDK_DATE.tar.gz
44 http://icedtea.classpath.org/download/source/icedtea6-$icedteaver.tar.gz 45 http://icedtea.classpath.org/download/source/icedtea6-$_icedteaver.tar.gz
45 http://archive.apache.org/dist/ant/binaries/apache-ant-$ANT_VER-bin.tar.gz 46 http://archive.apache.org/dist/ant/binaries/apache-ant-$ANT_VER-bin.tar.gz
46 ftp://ftp.mozilla.org/pub/mozilla.org/js/rhino$RHINO_VER.zip 47 ftp://ftp.mozilla.org/pub/mozilla.org/js/rhino$RHINO_VER.zip
47 http://icedtea.classpath.org/download/drops/$JAXWS_DROP_ZIP
48 http://icedtea.classpath.org/download/drops/$JAXP_DROP_ZIP
49 http://icedtea.classpath.org/download/drops/$JAF_DROP_ZIP
50 build-paxctl.patch 48 build-paxctl.patch
51 icedtea-hotspot-uclibc-fixes.patch 49 icedtea-hotspot-uclibc-fixes.patch
52 icedtea-jdk-fix-ipv6-init.patch 50 icedtea-jdk-fix-ipv6-init.patch
@@ -58,44 +56,30 @@ source="http://download.java.net/openjdk/jdk6/promoted/$OPENJDK_VERSION/openjdk-
58 icedtea-jdk-early-paxctl.patch 56 icedtea-jdk-early-paxctl.patch
59 " 57 "
60 58
61_builddir="$srcdir/icedtea6-$icedteaver" 59_builddir="$srcdir/icedtea6-$_icedteaver"
62INSTALL_BASE=/usr/lib/jvm/java-1.6-openjdk
63CPU=`uname -m | sed -e 's/i.86/i386/g' -e 's/x86_64/amd64/g'`
64 60
65unpack() { 61unpack() {
66 if [ -z "$force" ]; then 62 if [ -z "$force" ]; then
67 md5check || return 1 63 verify || return 1
68 initdcheck || return 1 64 initdcheck || return 1
69 fi 65 fi
70 mkdir -p "$srcdir" 66 mkdir -p "$srcdir"
71 msg "Unpacking sources..." 67 msg "Unpacking sources..."
72 tar -C "$srcdir" -zxf icedtea6-$icedteaver.tar.gz || return 1 68 tar -C "$srcdir" -zxf icedtea6-$_icedteaver.tar.gz || return 1
73 tar -C "$srcdir" -zxf apache-ant-$ANT_VER-bin.tar.gz || return 1 69 tar -C "$srcdir" -zxf apache-ant-$ANT_VER-bin.tar.gz || return 1
74 unzip -o -q "rhino$RHINO_VER.zip" -d "$srcdir" || return 1 70 unzip -o -q "rhino$RHINO_VER.zip" -d "$srcdir" || return 1
75} 71}
76 72
77prepare() { 73prepare() {
78 cd "$_builddir" 74 cd "$_builddir"
75
79 # Busybox sha256 does not support longopts 76 # Busybox sha256 does not support longopts
80 sed -e "s/--check/-c/g" -i Makefile.am 77 sed -e "s/--check/-c/g" -i Makefile.am
81 # gcj is broke after strict linking
82 sed -e "s/-o native-ecj/-o native-ecj -lgcj/g" -i Makefile.am
83 78
84 for patch in $source; do 79 for patch in $source; do
85 case $patch in 80 case $patch in
86 icedtea-*.patch) 81 icedtea-*.patch)
87 case $patch in 82 cp ../$patch patches
88 *uclibc*)
89 if [ "$ALPINE_LIBC" != "eglibc" ]; then
90 cp ../$patch patches
91 _dpatches="$_dpatches patches/$patch"
92 fi
93 ;;
94 *)
95 cp ../$patch patches
96 _dpatches="$_dpatches patches/$patch"
97 ;;
98 esac
99 ;; 83 ;;
100 *.patch) 84 *.patch)
101 msg "Applying patch $patch" 85 msg "Applying patch $patch"
@@ -103,21 +87,23 @@ prepare() {
103 ;; 87 ;;
104 esac 88 esac
105 done 89 done
106 export DISTRIBUTION_PATCHES="$_dpatches"
107} 90}
108 91
109build() { 92build() {
93 [ -z "$JOBS" ] && export JOBS=`echo $MAKEFLAGS | sed -n -e 's/.*-j\([0-9]\+\).*/\1/p'`
110 export JAVA_HOME=$BOOTSTRAP_JAVA_HOME 94 export JAVA_HOME=$BOOTSTRAP_JAVA_HOME
111 export PATH=$JAVA_HOME/bin:$srcdir/apache-ant-$ANT_VER/bin:$PATH 95 export PATH=$JAVA_HOME/bin:$srcdir/apache-ant-$ANT_VER/bin:$PATH
112 96 export DISTRIBUTION_PATCHES=""
113 if [ -z "$JOBS" ]; then 97
114 JOBS=`echo $MAKEFLAGS | sed -n -e 's/.*-j\([0-9]\+\).*/\1/p'` 98 local patch
115 fi 99 for patch in $source; do
116 if [ "$JOBS" ]; then 100 case $patch in
117 confjobs="--with-parallel-jobs=$JOBS" 101 icedtea-*.patch)
118 else 102 export DISTRIBUTION_PATCHES="$DISTRIBUTION_PATCHES patches/$patch"
119 confjobs="" 103 ;;
120 fi 104 esac
105 done
106 echo "icedtea patches: $DISTRIBUTION_PATCHES"
121 107
122 cd "$_builddir" 108 cd "$_builddir"
123 sh autogen.sh 109 sh autogen.sh
@@ -127,13 +113,10 @@ build() {
127 --infodir=/usr/share/info \ 113 --infodir=/usr/share/info \
128 --localstatedir=/var \ 114 --localstatedir=/var \
129 --disable-dependency-tracking \ 115 --disable-dependency-tracking \
116 --with-parallel-jobs=${JOBS:-2} \
130 --enable-cacerts \ 117 --enable-cacerts \
131 --with-ca-dir=/etc/ssl/certs \ 118 --with-ca-dir=/etc/ssl/certs \
132 --with-gcj $confjobs \
133 --with-openjdk-src-zip=$srcdir/openjdk-6-src-$OPENJDK_VERSION-$OPENJDK_DATE.tar.gz \ 119 --with-openjdk-src-zip=$srcdir/openjdk-6-src-$OPENJDK_VERSION-$OPENJDK_DATE.tar.gz \
134 --with-jaxp-drop-zip=$srcdir/$JAXP_DROP_ZIP \
135 --with-jaf-drop-zip=$srcdir/$JAF_DROP_ZIP \
136 --with-jaxws-drop-zip=$srcdir/$JAXWS_DROP_ZIP \
137 --with-jdk-home=$BOOTSTRAP_JAVA_HOME \ 120 --with-jdk-home=$BOOTSTRAP_JAVA_HOME \
138 --with-ant-home=$srcdir/apache-ant-$ANT_VER \ 121 --with-ant-home=$srcdir/apache-ant-$ANT_VER \
139 --with-rhino=$srcdir/rhino$RHINO_VER/js.jar \ 122 --with-rhino=$srcdir/rhino$RHINO_VER/js.jar \
@@ -197,8 +180,8 @@ jre() {
197 for A in jre/bin/policytool \ 180 for A in jre/bin/policytool \
198 bin/appletviewer \ 181 bin/appletviewer \
199 bin/policytool \ 182 bin/policytool \
200 jre/lib/$CPU/xawt \ 183 jre/lib/$_jarch/xawt \
201 jre/lib/$CPU/libsplashscreen.so ; do 184 jre/lib/$_jarch/libsplashscreen.so ; do
202 dirname=${A%/*} 185 dirname=${A%/*}
203 mkdir -p "$subpkgdir"/$INSTALL_BASE/$dirname 186 mkdir -p "$subpkgdir"/$INSTALL_BASE/$dirname
204 mv "$pkgdir"/$INSTALL_BASE/$A "$subpkgdir"/$INSTALL_BASE/$dirname 187 mv "$pkgdir"/$INSTALL_BASE/$A "$subpkgdir"/$INSTALL_BASE/$dirname
@@ -213,12 +196,9 @@ doc() {
213} 196}
214 197
215md5sums="0eabdd360169144336e50081b8d01001 openjdk-6-src-b24-14_nov_2011.tar.gz 198md5sums="0eabdd360169144336e50081b8d01001 openjdk-6-src-b24-14_nov_2011.tar.gz
216fd9749b16f88c4f67920d2ffc0964a83 icedtea6-1.11.11.tar.gz 199d89b34cc7b525593b6efb8af32b132f4 icedtea6-1.11.13.tar.gz
217afb0c7950a663f94e65da9f3be676d8f apache-ant-1.8.2-bin.tar.gz 200afb0c7950a663f94e65da9f3be676d8f apache-ant-1.8.2-bin.tar.gz
21899d94103662a8d0b571e247a77432ac5 rhino1_7R3.zip 20199d94103662a8d0b571e247a77432ac5 rhino1_7R3.zip
2198fd91b09b643a19a912b8a75e7a7a9d5 jdk6-jaxws2_1_6-2011_06_13.zip
2209eea471ad474040265c688858fcf09aa jaxp144_03.zip
221bc95c133620bd68c161cac9891592901 jdk6-jaf-b20.zip
222f8a7c115a478ba784353606b8607a34d build-paxctl.patch 202f8a7c115a478ba784353606b8607a34d build-paxctl.patch
223dc6a1e28a97d897d7a1057c11696727d icedtea-hotspot-uclibc-fixes.patch 203dc6a1e28a97d897d7a1057c11696727d icedtea-hotspot-uclibc-fixes.patch
224250b0807b59762670954b132e8f8dfba icedtea-jdk-fix-ipv6-init.patch 204250b0807b59762670954b132e8f8dfba icedtea-jdk-fix-ipv6-init.patch
@@ -229,12 +209,9 @@ c4bb40d5b1ff690b27900c5cd06bc1e5 icedtea-jdk-no-lib-nsl-uclibc.patch
229d014431e70cdabb82a75e4b9ae4c28a9 icedtea-jdk-no-soname.patch 209d014431e70cdabb82a75e4b9ae4c28a9 icedtea-jdk-no-soname.patch
2307eda2c7837b14793076e7675c756be0c icedtea-jdk-early-paxctl.patch" 2107eda2c7837b14793076e7675c756be0c icedtea-jdk-early-paxctl.patch"
231sha256sums="f84e7f0938f4939660ff8f9c2aa164d301faa8a519f2324ceb05ad34b2e09227 openjdk-6-src-b24-14_nov_2011.tar.gz 211sha256sums="f84e7f0938f4939660ff8f9c2aa164d301faa8a519f2324ceb05ad34b2e09227 openjdk-6-src-b24-14_nov_2011.tar.gz
2326db6124645686ab5e91d2952d8b601bc0789b8fd5f1af86e46a5242ec60dc8e6 icedtea6-1.11.11.tar.gz 2123101efa8dd7c0470c375e41cd2adbaae63f6fb65d357b2033069f4f468b3ea08 icedtea6-1.11.13.tar.gz
233664f48cfc9c4a9a832ec1dd9d2bed5229c0a9561e489dcb88841d75d3c2c7cf9 apache-ant-1.8.2-bin.tar.gz 213664f48cfc9c4a9a832ec1dd9d2bed5229c0a9561e489dcb88841d75d3c2c7cf9 apache-ant-1.8.2-bin.tar.gz
234885b46e24fe5af23ad3712c5e08e8d97d6d92a4b89e1be860e8fe88e4a3dacd1 rhino1_7R3.zip 214885b46e24fe5af23ad3712c5e08e8d97d6d92a4b89e1be860e8fe88e4a3dacd1 rhino1_7R3.zip
235229040544e791f44906e8e7b6f6faf503c730a5d854275135f3925490d5c3be3 jdk6-jaxws2_1_6-2011_06_13.zip
236c1a5348e17b330a7e4b18431e61a40efd2ba99a7da71102cf2c604478ef96012 jaxp144_03.zip
23778c7b5c9d6271e88ee46abadd018a61f1e9645f8936cc8df1617e5f4f5074012 jdk6-jaf-b20.zip
238b7d6bab5394cd0023b6737aeb0ff90569058d151185916ac2f80f5266c468312 build-paxctl.patch 215b7d6bab5394cd0023b6737aeb0ff90569058d151185916ac2f80f5266c468312 build-paxctl.patch
239f4b06c01b664922a6d7785d90bb888fe4665ae9ed6ae76c5484314821fd2cc2d icedtea-hotspot-uclibc-fixes.patch 216f4b06c01b664922a6d7785d90bb888fe4665ae9ed6ae76c5484314821fd2cc2d icedtea-hotspot-uclibc-fixes.patch
240632683ec88a6fb250ef043aae9cace605d0c669b7058f8c47b62b09b03ecc6c5 icedtea-jdk-fix-ipv6-init.patch 217632683ec88a6fb250ef043aae9cace605d0c669b7058f8c47b62b09b03ecc6c5 icedtea-jdk-fix-ipv6-init.patch
@@ -245,12 +222,9 @@ f83dea0ee1d11deceb45d643cf0cce84099775de88b972e3ea979a8529bf4c85 icedtea6-1.9.7
2456c0bbe710395c4ced1359ab279be6a7c36da5bfb9fd60dc47d920f06a0456d82 icedtea-jdk-no-soname.patch 2226c0bbe710395c4ced1359ab279be6a7c36da5bfb9fd60dc47d920f06a0456d82 icedtea-jdk-no-soname.patch
24613876be6f6ec792894d51b20f261b76db878d330eec7d4a2dcb17f0f1909a7e6 icedtea-jdk-early-paxctl.patch" 22313876be6f6ec792894d51b20f261b76db878d330eec7d4a2dcb17f0f1909a7e6 icedtea-jdk-early-paxctl.patch"
247sha512sums="a965efa2fbe95a32988f78f1e51c42321ff42c1e631d5062aff204ba42839d6e05455f1ae039540e38ec947b50a635984cd3302eb09e81962575510309374e05 openjdk-6-src-b24-14_nov_2011.tar.gz 224sha512sums="a965efa2fbe95a32988f78f1e51c42321ff42c1e631d5062aff204ba42839d6e05455f1ae039540e38ec947b50a635984cd3302eb09e81962575510309374e05 openjdk-6-src-b24-14_nov_2011.tar.gz
24830afa752889f43dcf81b89e0e8c810894675f91ddae50cf38a034b53b5bd33be327bbf5eb21ece8ab0aafd088204827500fd5f160eb23d8d64857b38089a7891 icedtea6-1.11.11.tar.gz 22590970145e41a7caea2a6ebb1c5f92b72d544dc71b033568c72f981e4479722bc460eb09151304878277cb5632d39b15165ae6b9fb8628b6a700f0fce69516f4c icedtea6-1.11.13.tar.gz
249869ab792b95c98ee62d748ffc991d78138482c8e2191f0a07c4d6629ad983768b40bef6f2d1370f6c0ab007c1de73f440293c1101eaf1fd82cf40de140c4b020 apache-ant-1.8.2-bin.tar.gz 226869ab792b95c98ee62d748ffc991d78138482c8e2191f0a07c4d6629ad983768b40bef6f2d1370f6c0ab007c1de73f440293c1101eaf1fd82cf40de140c4b020 apache-ant-1.8.2-bin.tar.gz
25077964485481e22d20459ea094c773e1930c5ef22d69bc449375a1ead31f340b3a652e2dd85c645e210be1abc8e623aeb560a5dc81629f388322af270ce868d36 rhino1_7R3.zip 22777964485481e22d20459ea094c773e1930c5ef22d69bc449375a1ead31f340b3a652e2dd85c645e210be1abc8e623aeb560a5dc81629f388322af270ce868d36 rhino1_7R3.zip
251643266da495f239aca1a08ba85af337e5ab50e5b859bffbccab64cf1c4099cae641d9741a20ca59c599c1285266a79489dec190d7fb15daa88c82b69ce97dbd6 jdk6-jaxws2_1_6-2011_06_13.zip
252fe65d396d0a57bc2b5dd2d8b00b0ecea860d4e5a5c9cb489bc5b9d7abd90861dedd26088184de93807646277c23d3712e8af79e56251f079ef22ed5a3b8f9a90 jaxp144_03.zip
25322fef9e0fdde82f141151d426d26316d7c23fd4cc2132ef191f38ea9420ebb3126670b0456ab4de83896307eab48bab0c46aaf0485f39e89cb57dac3215d499a jdk6-jaf-b20.zip
25441bfdb08e74cbcc70eac9e6721d886d8e35cd77c19988bd812fa16f71819efa2e8101d8a41a9ae62094069282739a835209a66c8dea6e259a86aee8368c60643 build-paxctl.patch 22841bfdb08e74cbcc70eac9e6721d886d8e35cd77c19988bd812fa16f71819efa2e8101d8a41a9ae62094069282739a835209a66c8dea6e259a86aee8368c60643 build-paxctl.patch
255dc5a72ef92cd31e9ba4870ad2126f619932bae5918b6f6ad22af59dbc3e77a70fc27ba37909df0612f70922dfec6a58464469a18ed7a77d902c4a5038e086900 icedtea-hotspot-uclibc-fixes.patch 229dc5a72ef92cd31e9ba4870ad2126f619932bae5918b6f6ad22af59dbc3e77a70fc27ba37909df0612f70922dfec6a58464469a18ed7a77d902c4a5038e086900 icedtea-hotspot-uclibc-fixes.patch
25648533f87fc2cf29d26b259be0df51087d2fe5b252e72d00c6ea2f4add7b0fb113141718c116279c5905e03f64a1118082e719393786811367cf4d472b5d36774 icedtea-jdk-fix-ipv6-init.patch 23048533f87fc2cf29d26b259be0df51087d2fe5b252e72d00c6ea2f4add7b0fb113141718c116279c5905e03f64a1118082e719393786811367cf4d472b5d36774 icedtea-jdk-fix-ipv6-init.patch