aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-29 13:42:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-29 13:43:46 +0000
commit853f2871416a49e7dbe31d0bca29cbbcc9114878 (patch)
treecbca9be4179ce0da7ef73420afc11ab8dedf9051
parent22e63da01a59489436f8d9a52337195a6e7083bc (diff)
downloadalpine_aports-853f2871416a49e7dbe31d0bca29cbbcc9114878.tar.bz2
alpine_aports-853f2871416a49e7dbe31d0bca29cbbcc9114878.tar.xz
alpine_aports-853f2871416a49e7dbe31d0bca29cbbcc9114878.zip
main/obexd: remove. merged into bluez 5
http://www.bluez.org/release-of-bluez-5-0/
-rw-r--r--main/obexd/APKBUILD59
-rw-r--r--main/obexd/include-unistd.h.patch11
2 files changed, 0 insertions, 70 deletions
diff --git a/main/obexd/APKBUILD b/main/obexd/APKBUILD
deleted file mode 100644
index ab25b29b96..0000000000
--- a/main/obexd/APKBUILD
+++ /dev/null
@@ -1,59 +0,0 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=obexd
3pkgver=0.46
4pkgrel=1
5pkgdesc="D-Bus service for Obex Server"
6url="http://www.bluez.org/"
7arch="all"
8license="GPL2"
9depends="!obex-data-server"
10subpackages="$pkgname-client"
11makedepends="dbus-glib-dev openobex-dev glib-dev bluez-dev libical-dev"
12source="http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2
13 include-unistd.h.patch"
14
15prepare() {
16 local i
17 cd "$_builddir"
18 update_config_sub || return 1
19 for i in $source; do
20 case $i in
21 *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
22 esac
23 done
24}
25
26build() {
27 cd "$srcdir"/$pkgname-$pkgver
28 ./configure \
29 --build=$CBUILD \
30 --host=$CHOST \
31 --prefix=/usr \
32 --libexecdir=/usr/lib/obexd \
33 || return 1
34 make || return 1
35}
36
37package() {
38 cd "$srcdir"/$pkgname-$pkgver
39 make DESTDIR="$pkgdir" install
40}
41
42_mv_files() {
43 local i
44 for i in "$@"; do
45 mkdir -p "$subpkgdir"/${i%/*}
46 mv "$pkgdir"/$i "$subpkgdir"/$i || return 1
47 done
48}
49
50client() {
51 pkgdesc="D-Bus service for Obex Client access"
52 depends=
53 cd "$pkgdir"
54 _mv_files usr/lib/obexd/obex-client \
55 usr/share/dbus-*/services/obex-client.service
56}
57
58md5sums="625f0417d119437429c9cce29479cfa4 obexd-0.46.tar.bz2
59be080a04628bf1c53f86ba205d99161a include-unistd.h.patch"
diff --git a/main/obexd/include-unistd.h.patch b/main/obexd/include-unistd.h.patch
deleted file mode 100644
index 921407d257..0000000000
--- a/main/obexd/include-unistd.h.patch
+++ /dev/null
@@ -1,11 +0,0 @@
1--- a/obexd-0.46/mas.c.orig
2+++ b/obexd-0.46/plugins/mas.c
3@@ -30,6 +30,7 @@
4 #include <glib.h>
5 #include <fcntl.h>
6 #include <inttypes.h>
7+#include <unistd.h>
8
9 #include <gobex/gobex.h>
10
11