aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2019-02-27 10:03:52 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-02-27 10:04:46 +0000
commit27bde63026102059c4aff7e9c3149a91f2fd9b83 (patch)
tree15202825052be9db7256102547abbec0b63dd04a
parent2a394ee3ed6123aa559de4afc458fc6529c9b342 (diff)
downloadalpine_aports-27bde63026102059c4aff7e9c3149a91f2fd9b83.tar.bz2
alpine_aports-27bde63026102059c4aff7e9c3149a91f2fd9b83.tar.xz
alpine_aports-27bde63026102059c4aff7e9c3149a91f2fd9b83.zip
testing/drone: new aport
This is a first step at adding drone to aports and is no way a finished product.
-rw-r--r--testing/drone/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/drone/APKBUILD b/testing/drone/APKBUILD
new file mode 100644
index 0000000000..d96045ea75
--- /dev/null
+++ b/testing/drone/APKBUILD
@@ -0,0 +1,45 @@
1# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
2# Maintainer:
3pkgname=drone
4pkgver=0.9_git20190226
5pkgrel=0
6_sha=07f7fdd9830c32222db2e880a13d5fbb6ecee1a7
7pkgdesc="Container-Native, Continuous Delivery Platform"
8url="https://drone.io/"
9arch="all"
10license="custom"
11makedepends="go"
12options="!check"
13_commands="
14 $pkgname-agent:_pkg
15 $pkgname-controller:_pkg
16 $pkgname-server:_pkg
17"
18subpackages="
19 $_commands
20 $pkgname-doc
21 "
22source="$pkgname-$pkgver.tar.gz::https://github.com/drone/drone/archive/$_sha.tar.gz"
23builddir="$srcdir/$pkgname-$_sha"
24
25build() {
26 cd "$builddir"
27 export GO111MODULE=on
28 for pkg in $_commands; do
29 go build -o bin/${pkg%%:*} ./cmd/${pkg%%:*}
30 done
31}
32
33package() {
34 install -Dm 644 "$builddir"/LICENSE \
35 "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
36}
37
38_pkg() {
39 pkgdesc="$pkgdesc ($subpkgname)"
40 install_if="$pkgname"
41 install -Dm775 "$builddir"/bin/$subpkgname \
42 "$subpkgdir"/usr/bin/$subpkgname
43}
44
45sha512sums="9278f238842bbdb988ecc950e311377aa15385c778df110e06b2452d116d7f93f49ffe663926bb7eb68313aa05a388701bdf734686835a64961302251e395208 drone-0.9_git20190226.tar.gz"