aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-02-26 21:54:50 +0200
committerprspkt <prspkt@protonmail.com>2019-02-26 23:32:25 +0200
commitb4eafe396c7cb9ab97e86af9b12f1b06aa1ef464 (patch)
tree1a8b09e73184477e130fba97d4fcbabcdffbd2bb
parent5075582b1544bfe9c33386943f72ff9bd74e2a98 (diff)
downloadalpine_aports-b4eafe396c7cb9ab97e86af9b12f1b06aa1ef464.tar.bz2
alpine_aports-b4eafe396c7cb9ab97e86af9b12f1b06aa1ef464.tar.xz
alpine_aports-b4eafe396c7cb9ab97e86af9b12f1b06aa1ef464.zip
community/libcec: clarify license, modernize
-rw-r--r--community/libcec/APKBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/community/libcec/APKBUILD b/community/libcec/APKBUILD
index 1d789c6fe9..8fdccb5195 100644
--- a/community/libcec/APKBUILD
+++ b/community/libcec/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=1
6pkgdesc="libcec for the Pulse-Eight USB-CEC adapter" 6pkgdesc="libcec for the Pulse-Eight USB-CEC adapter"
7url="https://github.com/Pulse-Eight/libcec" 7url="https://github.com/Pulse-Eight/libcec"
8arch="all" 8arch="all"
9license="GPL" 9license="GPL-2.0-or-later"
10depends="" 10depends=""
11depends_dev="eudev-dev python3-dev libxrandr-dev swig" 11depends_dev="eudev-dev python3-dev libxrandr-dev swig"
12makedepends="$depends_dev p8-platform-dev cmake" 12makedepends="$depends_dev p8-platform-dev cmake"
@@ -29,19 +29,17 @@ build() {
29 cmake -DCMAKE_BUILD_TYPE=Release \ 29 cmake -DCMAKE_BUILD_TYPE=Release \
30 -DBUILD_SHARED_LIBS=1 \ 30 -DBUILD_SHARED_LIBS=1 \
31 -DCMAKE_INSTALL_PREFIX=/usr \ 31 -DCMAKE_INSTALL_PREFIX=/usr \
32 .. || return 1 32 ..
33 make || return 1 33 make
34} 34}
35 35
36package() { 36package() {
37 cd "$builddir/build" 37 cd "$builddir/build"
38 make DESTDIR="$pkgdir" install || return 1 38 make DESTDIR="$pkgdir" install
39 39
40 # Add cec directory to sys.path to get rid of issue https://github.com/Pulse-Eight/libcec/issues/316 40 # Add cec directory to sys.path to get rid of issue https://github.com/Pulse-Eight/libcec/issues/316
41 python_dir=$(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())") 41 python_dir=$(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")
42 echo "cec" > "${pkgdir}${python_dir}/cec.pth" 42 echo "cec" > "${pkgdir}${python_dir}/cec.pth"
43} 43}
44 44
45md5sums="47892140fbda566f6a6f944b52eb44fd libcec-4.0.2.tar.gz"
46sha256sums="b8b8dd31f3ebdd5472f03ab7d401600ea0d959b1288b9ca24bf457ef60e2ba27 libcec-4.0.2.tar.gz"
47sha512sums="7bb80965cd1bef713f59bff136dc4a7f1172c4a9bdb8e2f59c6bcc5b74110848c0b2912263280ea68177908a688127e8d7208fc43ce6e65d589343b85395a0bb libcec-4.0.2.tar.gz" 45sha512sums="7bb80965cd1bef713f59bff136dc4a7f1172c4a9bdb8e2f59c6bcc5b74110848c0b2912263280ea68177908a688127e8d7208fc43ce6e65d589343b85395a0bb libcec-4.0.2.tar.gz"