aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-05-08 09:49:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-08 09:49:03 +0000
commit363bf6d28774aff396c1095ecf93c049576bcc95 (patch)
treecba2ba9fceb301db0326da35dee52504553e1283
parentf132727c38e89d0179e686ae74eb80754ae82214 (diff)
downloadalpine_aports-363bf6d28774aff396c1095ecf93c049576bcc95.tar.bz2
alpine_aports-363bf6d28774aff396c1095ecf93c049576bcc95.tar.xz
alpine_aports-363bf6d28774aff396c1095ecf93c049576bcc95.zip
main/ipfw: purge. it is unmaintained and dead upstream
-rw-r--r--main/ipfw/APKBUILD53
-rw-r--r--main/ipfw/no-sysctl.patch21
-rw-r--r--main/ipfw/remove-werror.patch10
-rw-r--r--main/ipfw/type-correctness.patch37
4 files changed, 0 insertions, 121 deletions
diff --git a/main/ipfw/APKBUILD b/main/ipfw/APKBUILD
deleted file mode 100644
index 8d489b80fd..0000000000
--- a/main/ipfw/APKBUILD
+++ /dev/null
@@ -1,53 +0,0 @@
1# Contributor:
2# Maintainer:
3pkgname=ipfw
4_realver=20130607
5pkgver=3.0_git${_realver}
6pkgrel=1
7pkgdesc="BSD ipfw firewall and dummynet suite (linux-grsec modules)"
8url="http://info.iet.unipi.it/~luigi/dummynet/"
9arch="all"
10license="BSD"
11depends=""
12makedepends="bsd-compat-headers"
13install=
14source="http://info.iet.unipi.it/~luigi/doc/${_realver}-${pkgname}3.tgz
15 no-sysctl.patch
16 type-correctness.patch
17 remove-werror.patch"
18subpackages=""
19
20_builddir="$srcdir/ipfw3-2012"
21prepare() {
22 local i
23 cd "$_builddir"
24 for i in $source; do
25 case $i in
26 *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
27 esac
28 done
29}
30
31build() {
32 cd "$_builddir"
33 make ipfw
34}
35
36package() {
37 cd "$_builddir"
38 mkdir -p "$pkgdir/usr/sbin"
39 install -D -m755 ipfw/ipfw "$pkgdir/usr/sbin/ipfw"
40}
41
42md5sums="004e65e6d545a89c4dcc3e741e287444 20130607-ipfw3.tgz
4377b842449998afdbce62cedca529f7f0 no-sysctl.patch
44a5fd21099c3733d52164189e30abf5ce type-correctness.patch
45e136911cde9e86b7ddcda4fe4af766ab remove-werror.patch"
46sha256sums="7dc80437b137e629f8ef3a7889b24ffbd1c27274e9cce15fd1f3b2c8620c6d64 20130607-ipfw3.tgz
47b7f3b61af1a6dd88dc01662ef524da886d1f2c4684bdfe023cb6ffe2e9da63de no-sysctl.patch
48ed1e32908b748c0fed5e3eaf5d07cd7df7b67e01fe051796d1b0ca290455009d type-correctness.patch
49c8fd8b2fdb25ebe639e7312d6dfd70d3320cd6d43357bb40e9361f05c9de7620 remove-werror.patch"
50sha512sums="6c4c2c7d4795094b9ff72212394e7dee44e5f9e09e97021b5ac9c3fad6de5a32b1d608ae9572da17f62cb37d076d89ab26859c61255d03d6bce22ca527f2c8ec 20130607-ipfw3.tgz
51e32f7bcff5b36b0405f678d3144472f8d7c76321a66a71b4515e266c35dc99378a358fd8f92eab748988e9c94fccb03f61a86acfa43b1a550a14c79a9f059715 no-sysctl.patch
52653d9cc30cedf012cfda8835750b05123e208e61aad5692c6b1714708fbfdc5d04f89e2b7c7a99819cdb607703bdad4507a613bbca6e16f3a439877a320a5b16 type-correctness.patch
5351a1092842c2a1f81c67de8893620ef52c62669141174539d39bb2d88c814327aa6b2900df4d5022aecdd0f9d50e552e9d989cea3bf58945ffcf2a946c9c12dc remove-werror.patch"
diff --git a/main/ipfw/no-sysctl.patch b/main/ipfw/no-sysctl.patch
deleted file mode 100644
index 1007728296..0000000000
--- a/main/ipfw/no-sysctl.patch
+++ /dev/null
@@ -1,21 +0,0 @@
1--- ipfw3-2012.orig/ipfw/dummynet.c
2+++ ipfw3-2012/ipfw/dummynet.c
3@@ -17,8 +17,6 @@
4
5 #include <sys/types.h>
6 #include <sys/socket.h>
7-/* XXX there are several sysctl leftover here */
8-#include <sys/sysctl.h>
9
10 #include "ipfw2.h"
11
12--- ipfw3-2012.orig/ipfw/ipfw2.c
13+++ ipfw3-2012/ipfw/ipfw2.c
14@@ -24,7 +24,6 @@
15 #include <sys/param.h>
16 #include <sys/socket.h>
17 #include <sys/sockio.h>
18-#include <sys/sysctl.h>
19
20 #include "ipfw2.h"
21
diff --git a/main/ipfw/remove-werror.patch b/main/ipfw/remove-werror.patch
deleted file mode 100644
index 0632d1eded..0000000000
--- a/main/ipfw/remove-werror.patch
+++ /dev/null
@@ -1,10 +0,0 @@
1--- a/ipfw/Makefile
2+++ b/ipfw/Makefile
3@@ -21,7 +21,6 @@
4 ifneq ($(VER),openwrt)
5 ifeq ($(OSARCH),Linux)
6 EXTRA_CFLAGS += -D__BSD_VISIBLE
7- EXTRA_CFLAGS += -Werror
8 # Required by GCC 4.6
9 EXTRA_CFLAGS += -Wno-unused-but-set-variable
10 endif
diff --git a/main/ipfw/type-correctness.patch b/main/ipfw/type-correctness.patch
deleted file mode 100644
index 287dc2cfa7..0000000000
--- a/main/ipfw/type-correctness.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1--- ipfw3-2012.orig/ipfw/include/timeconv.h
2+++ ipfw3-2012/ipfw/include/timeconv.h
3@@ -1,13 +1,15 @@
4 /*
5 * simple override for _long_to_time()
6 */
7+#include <stdint.h>
8+
9 #ifndef _TIMECONV_H_
10 #define _TIMECONV_H_
11 static __inline time_t
12 _long_to_time(long tlong)
13 {
14- if (sizeof(long) == sizeof(__int32_t))
15- return((time_t)(__int32_t)(tlong));
16+ if (sizeof(long) == sizeof(int32_t))
17+ return((time_t)(int32_t)(tlong));
18 return((time_t)tlong);
19 }
20
21--- ipfw3-2012.orig/sys/netinet/ip_fw.h
22+++ ipfw3-2012/sys/netinet/ip_fw.h
23@@ -445,10 +445,10 @@
24
25 /* Apply ipv6 mask on ipv6 addr */
26 #define APPLY_MASK(addr,mask) \
27- (addr)->__u6_addr.__u6_addr32[0] &= (mask)->__u6_addr.__u6_addr32[0]; \
28- (addr)->__u6_addr.__u6_addr32[1] &= (mask)->__u6_addr.__u6_addr32[1]; \
29- (addr)->__u6_addr.__u6_addr32[2] &= (mask)->__u6_addr.__u6_addr32[2]; \
30- (addr)->__u6_addr.__u6_addr32[3] &= (mask)->__u6_addr.__u6_addr32[3];
31+ (addr)->s6_addr32[0] &= (mask)->s6_addr32[0]; \
32+ (addr)->s6_addr32[1] &= (mask)->s6_addr32[1]; \
33+ (addr)->s6_addr32[2] &= (mask)->s6_addr32[2]; \
34+ (addr)->s6_addr32[3] &= (mask)->s6_addr32[3];
35
36 /* Structure for ipv6 */
37 typedef struct _ipfw_insn_ip6 {