aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-05-08 13:04:40 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-08 13:05:33 +0000
commit9fe31efc0e34942447c95a19dbaaddcbd0f1af5c (patch)
treecd4445d4a09ccccab056c43a7f4eab48692ee69c
parentcd4a4d4cbca4d05db9f4f8fea0de1cbf82c6a755 (diff)
downloadalpine_aports-9fe31efc0e34942447c95a19dbaaddcbd0f1af5c.tar.bz2
alpine_aports-9fe31efc0e34942447c95a19dbaaddcbd0f1af5c.tar.xz
alpine_aports-9fe31efc0e34942447c95a19dbaaddcbd0f1af5c.zip
community/quazip: build with cmake
cmake will give a suffix "5" which seems to be expected by nomacs
-rw-r--r--community/quazip/APKBUILD17
-rw-r--r--community/quazip/cmake-path.patch10
2 files changed, 22 insertions, 5 deletions
diff --git a/community/quazip/APKBUILD b/community/quazip/APKBUILD
index 975006ad0f..d3ccc10ec9 100644
--- a/community/quazip/APKBUILD
+++ b/community/quazip/APKBUILD
@@ -3,7 +3,7 @@
3# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 3# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
4pkgname=quazip 4pkgname=quazip
5pkgver=0.7.6 5pkgver=0.7.6
6pkgrel=1 6pkgrel=2
7pkgdesc="C++ wrapper for the Gilles Vollant's ZIP/UNZIP C package" 7pkgdesc="C++ wrapper for the Gilles Vollant's ZIP/UNZIP C package"
8options="!check" # Has no testsuite 8options="!check" # Has no testsuite
9url="https://sourceforge.net/projects/quazip/" 9url="https://sourceforge.net/projects/quazip/"
@@ -12,17 +12,24 @@ arch="all"
12license="LGPL-2.1-or-later WITH custom-static-linking-exception" 12license="LGPL-2.1-or-later WITH custom-static-linking-exception"
13makedepends="qt5-qtbase-dev cmake" 13makedepends="qt5-qtbase-dev cmake"
14subpackages="$pkgname-dev $pkgname-doc" 14subpackages="$pkgname-dev $pkgname-doc"
15source="quazip-$pkgver.tar.gz::https://github.com/stachenov/quazip/archive/$pkgver.tar.gz" 15source="quazip-$pkgver.tar.gz::https://github.com/stachenov/quazip/archive/$pkgver.tar.gz
16 cmake-path.patch"
16replaces="quazip-qt5" 17replaces="quazip-qt5"
17 18
18build() { 19build() {
19 qmake-qt5 PREFIX=/usr 20 mkdir -p build
21 cd build
22 cmake -DCMAKE_INSTALL_PREFIX=/usr \
23 -DBUILD_WITH_QT4:BOOL=OFF \
24 -DCMAKE_CXX_FLAGS="$CFLAGS -fPIC" \
25 ..
20 make 26 make
21} 27}
22 28
23package() { 29package() {
24 make INSTALL_ROOT="$pkgdir" install 30 make -C build DESTDIR="$pkgdir" install
25 install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING 31 install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
26} 32}
27 33
28sha512sums="4325a69918216bb66c6a7c53589ef73473c3752151522a135dd9c92dbf722b29656aea7be0314c84399a214391eca79296ecda5811ab31845d8cf53c010110d1 quazip-0.7.6.tar.gz" 34sha512sums="4325a69918216bb66c6a7c53589ef73473c3752151522a135dd9c92dbf722b29656aea7be0314c84399a214391eca79296ecda5811ab31845d8cf53c010110d1 quazip-0.7.6.tar.gz
3506946c73c0e95e824066b55074086fd6aa0da2e9f4e0a267577276edf1048e8706a621c8e039a180512eaae00c88f32619ba59c7167c02d048374c1fef77b272 cmake-path.patch"
diff --git a/community/quazip/cmake-path.patch b/community/quazip/cmake-path.patch
new file mode 100644
index 0000000000..79152dfa1e
--- /dev/null
+++ b/community/quazip/cmake-path.patch
@@ -0,0 +1,10 @@
1diff --git a/CMakeLists.txt b/CMakeLists.txt
2index 3d2fb55..98be14e 100644
3--- a/CMakeLists.txt
4+++ b/CMakeLists.txt
5@@ -60,4 +60,4 @@ set(QUAZIP_LIB_TARGET_NAME quazip${QUAZIP_LIB_VERSION_SUFFIX} CACHE
6
7 add_subdirectory(quazip)
8
9-install(FILES FindQuaZip.cmake RENAME FindQuaZip${QUAZIP_LIB_VERSION_SUFFIX}.cmake DESTINATION ${CMAKE_ROOT}/Modules)
10+install(FILES FindQuaZip.cmake RENAME FindQuaZip${QUAZIP_LIB_VERSION_SUFFIX}.cmake DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/cmake/QuaZip)