aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-08 08:03:44 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-08 11:54:04 +0000
commita49d405135de6dac503d819fa22471d5d9ad0061 (patch)
tree45466c04ac233a15a84dab045a2aba16d5490d9d
parentaad5a8a8108c7eb9cbe303caab51bb49a6eb9886 (diff)
downloadalpine_aports-a49d405135de6dac503d819fa22471d5d9ad0061.tar.bz2
alpine_aports-a49d405135de6dac503d819fa22471d5d9ad0061.tar.xz
alpine_aports-a49d405135de6dac503d819fa22471d5d9ad0061.zip
community/quazip: fixup
- Fix license - Disable check with comment
-rw-r--r--community/quazip/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/community/quazip/APKBUILD b/community/quazip/APKBUILD
index 3adc0b4ffd..975006ad0f 100644
--- a/community/quazip/APKBUILD
+++ b/community/quazip/APKBUILD
@@ -1,26 +1,28 @@
1# Contributor: Leo <thinkabit.ukim@gmail.com>
1# Contributor: Carlo Landmeter <clandmeter@gmail.com> 2# Contributor: Carlo Landmeter <clandmeter@gmail.com>
2# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 3# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
3pkgname=quazip 4pkgname=quazip
4pkgver=0.7.6 5pkgver=0.7.6
5pkgrel=0 6pkgrel=1
6pkgdesc="C++ wrapper for the Gilles Vollant's ZIP/UNZIP C package" 7pkgdesc="C++ wrapper for the Gilles Vollant's ZIP/UNZIP C package"
8options="!check" # Has no testsuite
7url="https://sourceforge.net/projects/quazip/" 9url="https://sourceforge.net/projects/quazip/"
8arch="all" 10arch="all"
9license="LGPL" 11# Has custom static linking exception
12license="LGPL-2.1-or-later WITH custom-static-linking-exception"
10makedepends="qt5-qtbase-dev cmake" 13makedepends="qt5-qtbase-dev cmake"
11subpackages="$pkgname-dev" 14subpackages="$pkgname-dev $pkgname-doc"
12source="quazip-$pkgver.tar.gz::https://github.com/stachenov/quazip/archive/$pkgver.tar.gz" 15source="quazip-$pkgver.tar.gz::https://github.com/stachenov/quazip/archive/$pkgver.tar.gz"
13builddir="$srcdir/$pkgname-$pkgver" 16replaces="quazip-qt5"
14 17
15build() { 18build() {
16 cd "$builddir"
17 qmake-qt5 PREFIX=/usr 19 qmake-qt5 PREFIX=/usr
18 make 20 make
19} 21}
20 22
21package() { 23package() {
22 cd "$builddir"
23 make INSTALL_ROOT="$pkgdir" install 24 make INSTALL_ROOT="$pkgdir" install
25 install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
24} 26}
25 27
26sha512sums="4325a69918216bb66c6a7c53589ef73473c3752151522a135dd9c92dbf722b29656aea7be0314c84399a214391eca79296ecda5811ab31845d8cf53c010110d1 quazip-0.7.6.tar.gz" 28sha512sums="4325a69918216bb66c6a7c53589ef73473c3752151522a135dd9c92dbf722b29656aea7be0314c84399a214391eca79296ecda5811ab31845d8cf53c010110d1 quazip-0.7.6.tar.gz"