aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-05-08 09:43:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-08 09:43:50 +0000
commitf132727c38e89d0179e686ae74eb80754ae82214 (patch)
tree363db78a8bee55fada0454c314ae73c76fa66615
parent0e33b1df3ab38a33fd0f4701760229d24b5af4e0 (diff)
downloadalpine_aports-f132727c38e89d0179e686ae74eb80754ae82214.tar.bz2
alpine_aports-f132727c38e89d0179e686ae74eb80754ae82214.tar.xz
alpine_aports-f132727c38e89d0179e686ae74eb80754ae82214.zip
main/libelf: purge. replaced by elfutils
-rw-r--r--main/libelf/APKBUILD44
1 files changed, 0 insertions, 44 deletions
diff --git a/main/libelf/APKBUILD b/main/libelf/APKBUILD
deleted file mode 100644
index 35f5af9950..0000000000
--- a/main/libelf/APKBUILD
+++ /dev/null
@@ -1,44 +0,0 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=libelf
3pkgver=0.8.13
4pkgrel=3
5pkgdesc="libelf is a free ELF object file access library"
6url="http://www.mr511.de/software/"
7arch="all"
8license="GPL"
9depends=
10makedepends=
11subpackages="$pkgname-dev"
12source="http://www.mr511.de/software/$pkgname-$pkgver.tar.gz"
13
14builddir="$srcdir/$pkgname-$pkgver"
15
16prepare() {
17 cd "$builddir"
18 default_prepare
19 update_config_sub
20}
21
22build() {
23 cd "$builddir"
24 ./configure \
25 --build=$CBUILD \
26 --host=$CHOST \
27 --prefix=/usr \
28 --enable-shared \
29 --enable-gnu-names \
30 --enable-compat \
31 --disable-nls
32 make
33}
34
35check() {
36 cd "$builddir"
37 make check
38}
39
40package() {
41 cd "$builddir"
42 make install prefix="$pkgdir"/usr
43}
44sha512sums="d2a4ea8ccc0bbfecac38fa20fbd96aefa8e86f8af38691fb6991cd9c5a03f587475ecc2365fc89a4954c11a679d93460ee9a5890693112f6133719af3e6582fe libelf-0.8.13.tar.gz"