aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-19 22:51:44 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-24 16:43:22 -0300
commit46ecca97e9e72e1a0228912666c9278226be53b9 (patch)
tree6244a9a8ad09ad7b51658f3e9ca0bcbd36873c41
parent835349acfdb4950ceb46d81354b952a4934a294a (diff)
downloadalpine_aports-46ecca97e9e72e1a0228912666c9278226be53b9.tar.bz2
alpine_aports-46ecca97e9e72e1a0228912666c9278226be53b9.tar.xz
alpine_aports-46ecca97e9e72e1a0228912666c9278226be53b9.zip
testing/py3-mongo: drop py2
-rw-r--r--testing/py3-mongo/APKBUILD43
1 files changed, 9 insertions, 34 deletions
diff --git a/testing/py3-mongo/APKBUILD b/testing/py3-mongo/APKBUILD
index d85f4ce849..e2d5cc787d 100644
--- a/testing/py3-mongo/APKBUILD
+++ b/testing/py3-mongo/APKBUILD
@@ -1,55 +1,30 @@
1# Contributor: Danilo Falcão <danilo@falcao.org> 1# Contributor: Danilo Falcão <danilo@falcao.org>
2# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch> 2# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
3pkgname=py-mongo 3pkgname=py3-mongo
4_pkgname=pymongo 4_pkgname=pymongo
5pkgver=3.7.2 5pkgver=3.7.2
6pkgrel=0 6pkgrel=1
7pkgdesc="A Python driver for MongoDB" 7pkgdesc="Python3 driver for MongoDB"
8url="https://github.com/mongodb/mongo-python-driver" 8url="https://github.com/mongodb/mongo-python-driver"
9arch="all" 9arch="all"
10license="Apache-2.0" 10license="Apache-2.0"
11depends="" 11makedepends="python3-dev py3-setuptools"
12makedepends="python2-dev python3-dev py-setuptools"
13install=""
14subpackages="py2-$_pkgname:_py2 py3-$_pkgname:_py3"
15source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz" 12source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
16builddir="$srcdir"/$_pkgname-$pkgver 13builddir="$srcdir"/$_pkgname-$pkgver
17 14
15replaces="py-mongo" # Backwards compatibility
16provides="py-mongo=$pkgver-r$pkgrel" # Backwards compatibility
17
18build() { 18build() {
19 cd "$builddir"
20 python2 setup.py build
21 python3 setup.py build 19 python3 setup.py build
22} 20}
23 21
24
25package() {
26 mkdir -p "$pkgdir"
27}
28
29
30check() { 22check() {
31 cd "$builddir"
32 python2 setup.py test
33 python3 setup.py test 23 python3 setup.py test
34} 24}
35 25
36_py2() { 26package() {
37 replaces="$pkgname" 27 python3 setup.py install --prefix=/usr --root="$pkgdir"
38 _py python2
39}
40
41_py3() {
42 _py python3
43}
44
45_py() {
46 local python="$1"
47 pkgdesc="$pkgdesc (for $python)"
48 depends="$depends $python"
49 install_if="$pkgname=$pkgver-r$pkgrel $python"
50
51 cd "$builddir"
52 $python setup.py install --prefix=/usr --root="$subpkgdir"
53} 28}
54 29
55sha512sums="4d1dfe03d94f381f27cfb5c8dd4f75ecbab90567fdc4dd594b880031e68825eda6285c8b261a4c9d76fb7ccc92c91e27ae2f696525f7732b1f0084794042a33d pymongo-3.7.2.tar.gz" 30sha512sums="4d1dfe03d94f381f27cfb5c8dd4f75ecbab90567fdc4dd594b880031e68825eda6285c8b261a4c9d76fb7ccc92c91e27ae2f696525f7732b1f0084794042a33d pymongo-3.7.2.tar.gz"