aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-11-13 22:55:32 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-11-13 23:01:30 +0100
commit1b6e0423fe49ceb607750ffe3bc4edc130787d03 (patch)
tree02dd9cae64e829bf374fb6135cd0cc1f8a494fc6
parent76be7ea2011e480f36d0ad08862fdb27d366ca99 (diff)
downloadalpine_aports-1b6e0423fe49ceb607750ffe3bc4edc130787d03.tar.bz2
alpine_aports-1b6e0423fe49ceb607750ffe3bc4edc130787d03.tar.xz
alpine_aports-1b6e0423fe49ceb607750ffe3bc4edc130787d03.zip
main/uwsgi: set --wait for start-stop-daemon to 200 by default
To fix problem when uWSGI immediatelly after the start fails, but OpenRC doesn't recognize it.
-rw-r--r--main/uwsgi/APKBUILD4
-rw-r--r--main/uwsgi/uwsgi.initd3
2 files changed, 4 insertions, 3 deletions
diff --git a/main/uwsgi/APKBUILD b/main/uwsgi/APKBUILD
index 13501aaf89..d61b14a213 100644
--- a/main/uwsgi/APKBUILD
+++ b/main/uwsgi/APKBUILD
@@ -4,7 +4,7 @@
4# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 4# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
5pkgname=uwsgi 5pkgname=uwsgi
6pkgver=2.0.18 6pkgver=2.0.18
7pkgrel=2 7pkgrel=3
8pkgdesc="uWSGI application container server" 8pkgdesc="uWSGI application container server"
9url="http://projects.unbit.it/uwsgi/" 9url="http://projects.unbit.it/uwsgi/"
10arch="all" 10arch="all"
@@ -197,7 +197,7 @@ _plugin() {
197} 197}
198 198
199sha512sums="6561703279bcc4a81311d033810ac066d0f113bab13b0942f3eef86cac29c584a6641b52476840d6895151aee5ed064ae2d03b18932cf7f47e62f4eeed76da61 uwsgi-2.0.18.tar.gz 199sha512sums="6561703279bcc4a81311d033810ac066d0f113bab13b0942f3eef86cac29c584a6641b52476840d6895151aee5ed064ae2d03b18932cf7f47e62f4eeed76da61 uwsgi-2.0.18.tar.gz
20063137d45437e00deb970d66e2abddf7f235636b748f6cf545f54ff5557066c2a71db5c4a3bab2edceb4e65d3d7fac887f1f4c0e77658127e02b64d3026780b4c uwsgi.initd 2003467644e8b4fd05b3b6a769fb47d93cd1f9339294a187d023b75ba0a582544f18d22885d4e8a1351b39a023a3ed47bbf89ab24e3424fb2f04dc7d7399c815f13 uwsgi.initd
201370202e143d0e041a2e36905346080d3ca592c9a74705a8c4e142a1307d22b921c10e673d683ca284ea27d184474ed86edd7723a6e590d35a562ad7cf6afa529 uwsgi.ini 201370202e143d0e041a2e36905346080d3ca592c9a74705a8c4e142a1307d22b921c10e673d683ca284ea27d184474ed86edd7723a6e590d35a562ad7cf6afa529 uwsgi.ini
2022798c9d2e49e29292ffe6a5a29b866301c78d5f322fc5d07dfa9569efdaa5220237a5f6744652fbdd957be29311ddaff190541333f042cbf0e907dfa98ce3e2a readme.emperor 2022798c9d2e49e29292ffe6a5a29b866301c78d5f322fc5d07dfa9569efdaa5220237a5f6744652fbdd957be29311ddaff190541333f042cbf0e907dfa98ce3e2a readme.emperor
203f3cff00926929a5bb40afafb65fd5228582af35fbf524562282020c4c4ae9c659231b2381f4b3cceb18e8f3f6c888c21bdd8ed4ddcd81e92fbc6a0891800ce38 alpine.buildconf 203f3cff00926929a5bb40afafb65fd5228582af35fbf524562282020c4c4ae9c659231b2381f4b3cceb18e8f3f6c888c21bdd8ed4ddcd81e92fbc6a0891800ce38 alpine.buildconf
diff --git a/main/uwsgi/uwsgi.initd b/main/uwsgi/uwsgi.initd
index 69ab2da193..95821babca 100644
--- a/main/uwsgi/uwsgi.initd
+++ b/main/uwsgi/uwsgi.initd
@@ -6,6 +6,7 @@
6# variable uwsgi_opts or config file specified by variable uwsgi_conf. 6# variable uwsgi_opts or config file specified by variable uwsgi_conf.
7 7
8: ${pidfile:="/run/$RC_SVCNAME/uwsgi.pid"} 8: ${pidfile:="/run/$RC_SVCNAME/uwsgi.pid"}
9: ${wait:=200} # milliseconds
9 10
10extra_started_commands='reload stats' 11extra_started_commands='reload stats'
11description_reload='Gracefully reload all the workers and the master process' 12description_reload='Gracefully reload all the workers and the master process'
@@ -14,7 +15,7 @@ description_stats='Dump uWSGI statistics to log file'
14command='/usr/sbin/uwsgi' 15command='/usr/sbin/uwsgi'
15command_args="--die-on-term ${uwsgi_opts:-}" 16command_args="--die-on-term ${uwsgi_opts:-}"
16command_background='yes' 17command_background='yes'
17start_stop_daemon_args='--quiet' 18start_stop_daemon_args="--quiet --wait $wait"
18retry='INT/30/KILL/5' 19retry='INT/30/KILL/5'
19 20
20if [ "$RC_SVCNAME" = 'uwsgi' ]; then 21if [ "$RC_SVCNAME" = 'uwsgi' ]; then